<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Days of Our Lives Round Table: Valentine&#39;s Day Edition - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/' property='og:url'>
<meta content="Days of Our Lives Round Table: Valentine's Day Edition" property='og:title'>
<meta content="Who is Salem's most romantic couple, who should be a couple, and which characters do you want to send out of town. Our Days of Our Lives round table team chooses..." property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ygyHZQxp--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1390625699/attachment/days-of-our-lives-round-table.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='500' property='og:image:width'>
<meta content='295' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--emILOMEe--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449071/making-a-sacrifice-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='532' property='og:image:width'>
<meta content='840' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--emILOMEe--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449071/making-a-sacrifice-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='532' property='og:image:width'>
<meta content='840' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--YQXGj0NR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1577635671/tall-face-to-face-with-stevano-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='677' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--XDx_dfon--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811666/gabis-wedding-is-disrupted-days-of-our-lives.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='425' property='og:image:width'>
<meta content='679' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--qHd55ehB--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449130/jennifer-remembers-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='505' property='og:image:width'>
<meta content='844' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--GnOLC3kH--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1580051231/tall-shawn-arrives-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='537' property='og:image:width'>
<meta content='840' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--NAtXbTn0--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581448962/smuggling-stevano-out-days-of-our-lives.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--3K79gbDv--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811788/lani-arrives-days-of-our-lives.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='426' property='og:image:width'>
<meta content='680' property='og:image:height'>
<meta content='2020-02-16T08:00:00-05:00' property='article:published_time'>
<meta content='2020-02-16T18:22:42-05:00' property='article:modified_time'>
<meta content='Days of Our Lives' property='article:tag'>
<meta content='Round Tables' property='article:tag'>
<meta content='Soap Operas' property='article:tag'>
<meta content='Christine Orlando' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content="Days of Our Lives Round Table: Valentine's Day Edition" name='twitter:title'>
<meta content="Who is Salem's most romantic couple, who should be a couple, and which characters do you want to send out of town. Our Days of Our Lives round table team chooses..." name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ygyHZQxp--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1390625699/attachment/days-of-our-lives-round-table.jpg' name='twitter:image:src'>

<meta content="Who is Salem&#39;s most romantic couple, who should be a couple, and which characters do you want to send out of town. Our Days of Our Lives..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Days of Our Lives');
ga('set', 'dimension2', 'Christine Orlando');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "days-of-our-lives", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/","mainEntityOfPage":"https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/","headline":"Days of Our Lives Round Table: Valentine's Day Edition","datePublished":"2020-02-16T08:00:00-05:00","dateModified":"2020-02-16T18:22:42-05:00","description":"Who is Salem's most romantic couple, who should be a couple, and which characters do you want to send out of town. Our Days of Our Lives round table team chooses...","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--4Io5RA7p--/c_scale,f_auto,h_410,q_auto,w_696/v1390625699/attachment/days-of-our-lives-round-table","height":410,"width":696},"author":{"@type":"Person","name":"Christine Orlando"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='41' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--h8n86FcR--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1421782164/banner/days-of-our-lives.jpg" /></div></div>
<div class='title'>
<h1><a href="/shows/days-of-our-lives/">Days of Our Lives</a></h1>
<span class='airs'>
Fridays
12:00 PM
on
NBC
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/days-of-our-lives/">Days of Our Lives News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/days-of-our-lives/tags/reviews/">Days of Our Lives Reviews</a></li>
<li><a class="" data-title="Spoilers" href="/shows/days-of-our-lives/tags/spoilers/">Days of Our Lives Spoilers</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/days-of-our-lives/episodes/">Days of Our Lives Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/days-of-our-lives/">Days of Our Lives Quotes</a></li>
<li><a class="" data-title="Cast" href="/shows/days-of-our-lives/cast/">Days of Our Lives Cast</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/days-of-our-lives/">Days of Our Lives Pictures</a></li>
<li><a class="" data-title="Videos" href="/videos/shows/days-of-our-lives/">Days of Our Lives Videos</a></li>
<li><a class="" data-title="Round Tables" href="/shows/days-of-our-lives/tags/round-tables/">Days of Our Lives Round Tables</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Days of Our Lives</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
<a class="btn btn-social btn-facebook btn-block btn-lg" href="https://www.facebook.com/287969064742702" target="_blank"><i class="fa fa-facebook"></i> Days of Our Lives Facebook</a>
<a class="btn btn-social btn-twitter btn-block btn-lg" href="https://twitter.com/DaysTVF" target="_blank"><i class="fa fa-twitter"></i> Days of Our Lives Twitter</a>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Days of Our Lives Round Table: Valentine's Day Edition</h1>
<small>
<a href="/authors/corlando/" rel="author"><img alt="Corlando" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--QCtv189x--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1460954502/user/corlando.png" />
<a href="/authors/corlando/" rel="author">Christine Orlando</a>
</a>at
<time datetime="2020-02-16T08:00:00-05:00" itemprop="datePublished">February 16, 2020  8:00 am</time>.
&nbsp;Updated at
<time datetime="2020-02-16T18:22:42-05:00" itemprop="dateModified">February 16, 2020  6:22 pm</time>.
</small>
</header>
<div class='body'>
<p>
	It was Valentine’s Day in Salem and did anyone expect a wedding to really go off without a hitch?</p>
<p>
	Our TV Fanatics Jack Ori and Christine Orlando are joined by Trey and Sportsgirl from <a href="http://myhourglass.proboards.com/" target="_blank">MyHourglass a Days of Our Lives fan forum</a> to pick Salem’s most romantic couples past and present, which characters should be paired romantically that aren’t, and who they want to see leave Salem!</p>
<div style="max-width:500px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<div href=""><div class="image_wrapper" style="padding-bottom:59.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ygyHZQxp--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1390625699/attachment/days-of-our-lives-round-table.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--rM5ezm3k--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1390625699/attachment/days-of-our-lives-round-table.jpg" class="lazyload" alt="Days of Our Lives RT - depreciated -"></div></div>
</div>
<p>
	<strong>Who is Salem’s current most romantic pairing? </strong></p>
<p>
	<em>Trey: </em>Doug and Julie are always a romantic pairing!</p><div id="stp_target"></div>
<p>
	Of the newer couples, I am really enjoying Sarah and Xander. I like how they have grown together. Xander wants to be a better man for her and she accepts him for his own faults.</p>
<p>
	Plus Xander and Maggie are so cute together.</p>
<p>
	<em>Jack:</em> I love the classic couples. Julie and Doug are one of my all-time favorite pairings, as are Jack and Jennifer. At those times that we get to see these couples interact, they're both very romantic.</p>
<p>
	Occasionally John and Marlena bring the romance too.</p>
<p>
	<em>Sportsgirl:</em> It may be a tie between Marlena &amp; John and Julie &amp; Doug. Both been together a long time and totally dedicated to each other.</p>
<p>
	<em>Christine:</em> I’m loving Sarah and Xander because the show has taken the time to bring them together slowly which is far more fun. They also do a wonderful job of combining both humor and romance.</p>
<p>
	My second favorite is Jack and Jennifer for many of the same reasons.</p>
<p>
	It's your turn TV Fanatics. Who do you think is the most romantic couple currently in Salem?</p>
<p>
	<div class="row"><div class="col-xs-10 col-xs-offset-1" id="poll_3083">
<div id="poll_3083">
<form accept-charset="UTF-8" action="/polls/choose-the-most-romantic-couple-currently-in-salem/vote/" class="simple_form new_poll_response" data-remote="true" id="new_poll_response" method="post" novalidate="novalidate" role="form">
<div style="display:none"><input name="utf8" type="hidden" value="✓"></div>
<div class="alert alert-danger error" style="display:none;margin:10px;"></div>
<div class="alert alert-success success" style="display:none;margin:10px;"></div>
<div class="form-group radio_buttons optional poll_response_poll_answer_id">
<span class="radio"><label for="poll_response_poll_answer_id_12353"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12353" name="poll_response[poll_answer_id]" type="radio" value="12353">Doug and Julie</label></span><span class="radio"><label for="poll_response_poll_answer_id_12354"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12354" name="poll_response[poll_answer_id]" type="radio" value="12354">Jack and Jennifer</label></span><span class="radio"><label for="poll_response_poll_answer_id_12355"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12355" name="poll_response[poll_answer_id]" type="radio" value="12355">Nicole and Eric</label></span><span class="radio"><label for="poll_response_poll_answer_id_12356"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12356" name="poll_response[poll_answer_id]" type="radio" value="12356">Victor and Maggie</label></span><span class="radio"><label for="poll_response_poll_answer_id_12357"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12357" name="poll_response[poll_answer_id]" type="radio" value="12357">Kayla and Justin</label></span><span class="radio"><label for="poll_response_poll_answer_id_12358"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12358" name="poll_response[poll_answer_id]" type="radio" value="12358">Sarah and Xander</label></span><span class="radio"><label for="poll_response_poll_answer_id_12359"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12359" name="poll_response[poll_answer_id]" type="radio" value="12359">John and Marlena</label></span><span class="radio"><label for="poll_response_poll_answer_id_12360"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12360" name="poll_response[poll_answer_id]" type="radio" value="12360">Brady and Kristen</label></span><span class="radio"><label for="poll_response_poll_answer_id_12361"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12361" name="poll_response[poll_answer_id]" type="radio" value="12361">Eli and Gabi</label></span><span class="radio"><label for="poll_response_poll_answer_id_12362"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12362" name="poll_response[poll_answer_id]" type="radio" value="12362">Will and Sonny</label></span><span class="radio"><label for="poll_response_poll_answer_id_12364"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12364" name="poll_response[poll_answer_id]" type="radio" value="12364">Chad and Abigail</label></span><span class="radio"><label for="poll_response_poll_answer_id_12365"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12365" name="poll_response[poll_answer_id]" type="radio" value="12365">Ben and Ciara</label></span><span class="radio"><label for="poll_response_poll_answer_id_12366"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12366" name="poll_response[poll_answer_id]" type="radio" value="12366">Tony and Anna</label></span><span class="radio"><label for="poll_response_poll_answer_id_12363"><input class="radio_buttons optional" id="poll_response_poll_answer_id_12363" name="poll_response[poll_answer_id]" type="radio" value="12363">Other - leave the details in the comments below</label></span>
</div>
<div class="clearfix">
<div class="pull-right"><a class="btn btn-default" href="/polls/choose-the-most-romantic-couple-currently-in-salem/">View Poll »</a></div>
<input class="btn btn-primary" data-disable-with="Voting..." name="commit" type="submit" value="Vote">
</div>
</form>


</div>
</div></div></p>
<div style="max-width:380px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/making-a-sacrifice-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:157.89473684210526%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--emILOMEe--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449071/making-a-sacrifice-days-of-our-lives.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--9J9N3ObR--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449071/making-a-sacrifice-days-of-our-lives.jpg" class="lazyload" alt="Making a Sacrifice - Days of Our Lives"></div></a>
</div>
<p>
	<strong>Who is the most romantic Days of Our Lives couple of all time? </strong></p>
<p>
	<em>Trey:</em> My favorite Days couple has always been Patch and Kayla. Everything about their courtship and things they overcame (Kayla's rape, deafness, etc. have always been thrilling).</p>
<p>
	I hate how they broke up, but am interested in seeing if Steve ever recovers from being Stevano or if this is a permanent casting for Steven Nichols.</p>
<p>
	<em>Jack: </em>Steve and Kayla are tied with Jack and Jennifer for my all-time favorite -- not counting Tom and Alice, of course.</p>
<p>
	<em>Sportsgirl:</em> All-time has to be Tom &amp; Alice. I remember vaguely those two together especially when Tom was the beat poet Norm de Plume.</p>
<p>
	<em>Christine:</em> I loved Bo and Hope. They just fit together in a way that you don’t see very often and I miss them.</p>
<p>
	I’m also a huge fan of Jack and Jennifer and I always did love Shane and Kimberly when they were together on the show.</p>
<div style="max-width:435px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tall-face-to-face-with-stevano-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:107.58620689655172%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--YQXGj0NR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1577635671/tall-face-to-face-with-stevano-days-of-our-lives.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--JUEj-e6t--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1577635671/tall-face-to-face-with-stevano-days-of-our-lives.jpg" class="lazyload" alt="(TALL) Face to Face With Stevano - Days of Our Lives"></div></a>
</div>
<p>
	<strong>Are there two characters who aren’t currently a couple but you’d like to see them paired together? </strong></p>
<p>
	<em>Trey: </em>I would have loved to see Kate reconnect with Roman again. I would also have loved for Days to have explored Rafe and Nicole as more than friends.</p>
<p>
	<em>Jack</em>: I have long wanted to see Nicole and Rafe give it a try. I've always enjoyed their friendship and think they might make a good couple.</p>
<p>
	<em>Sportsgirl:</em> I have always thought that Rafe &amp; Nicole would make a great couple. Neither one has had success in the love department plus both are similar as in Nicole being a part sleuth, not a career, but as in character trait.</p>
<p>
	They did have a nice friendship at one time until the writers forgot about it.</p>
<p>
	Christine: Wow, this is unanimous. I’ve always thought that Rafe and Nicole could build a great romance on their friendship and I’m disappointed that the show never took the time to explore this.</p>
<div style="max-width:375px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/gabis-wedding-is-disrupted-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:160.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--XDx_dfon--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811666/gabis-wedding-is-disrupted-days-of-our-lives.png" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--hoRGzqex--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811666/gabis-wedding-is-disrupted-days-of-our-lives.png" class="lazyload" alt="Gabi's Wedding Is Disrupted - Days of Our Lives"></div></a>
</div>
<p>
	<strong>Who had the best and the worst outfits at Gabi and Eli’s wedding? </strong></p>
<p>
	<em>Trey: </em>Best - tough to tell. Everyone looked lovely. Worst - Lani by default.</p>
<p>
	<em>Jack: </em>I liked Abby's dress. I thought both Julie and Gabi's dresses were weird. The guys all looked good in their tuxes/suits.</p>
<p>
	<em>Sportsgirl: </em>I don't usually pay much attention to outfits. I didn't particularly like Gabi's gown but I despised Abigail’s dress. Why do most of her outfits look so big on her? I wish I had paid more attention to the clothes.</p>
<p>
	<em>Christine: </em>Worst is a tie between Gabi’s cheesy prom dress that she wore to her own wedding and Abigail’s horrible bright green monstrosity.</p>
<p>
	I agree with Sportsgirl, Abigail’s clothes never seem to fit her well. As for the best, both Eli and Brady looked very handsome in their tuxedos.</p>
<div style="max-width:359px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/jennifer-remembers-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:167.13091922005572%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--qHd55ehB--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449130/jennifer-remembers-days-of-our-lives.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--bJQ7i8c5--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581449130/jennifer-remembers-days-of-our-lives.jpg" class="lazyload" alt="Jennifer Remembers - Days of Our Lives"></div></a>
</div>
<p>
	<strong>Do you think anyone will be able to get through to Hope now that they know Princess Gina has taken over her body and if so, who?</strong></p>
<p>
	<em>Trey: </em>I think Jennifer could get through to Gina. There's a reason Gina didn't kill her when she woke from the coma and maybe that was in part due to Hope.</p>
<p>
	<em>Jack: </em>I think they need to surgically remove that microchip, as Shawn suggested. Why they're treating this as if Hope has DID is beyond me.</p>
<p>
	<em>Sportsgirl: </em>I don't think Hope was brainwashed. I think she was chipped and I believe someone, probably Rafe, will discover that and Kayla will remove the chip.</p>
<p>
	<em>Christine: </em>Yeah, that chip needs to be removed because if Shawn couldn’t reach her then I’m not sure anyone can.</p>
<p>
	Ciara has barely noticed there’s anything wrong with her mom and although Hope might love Jennifer, Princess Gina still tossed her off of a balcony so I don’t think her feelings for her cousin are enough to bring her around.</p>
<div style="max-width:383px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tall-shawn-arrives-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:156.6579634464752%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--GnOLC3kH--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1580051231/tall-shawn-arrives-days-of-our-lives.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1U6HKZ0i--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1580051231/tall-shawn-arrives-days-of-our-lives.jpg" class="lazyload" alt="(TALL) Shawn Arrives - Days of Our Lives"></div></a>
</div>
<p>
	<strong>Rumor has it that a few characters may be leaving the show in the coming weeks. Without giving away any spoilers, which characters would you choose to leave Salem? </strong></p>
<p>
	<em>Trey: </em>I’d choose to retire Ciara's character for a while. She's become one note with her Ben obsession and I don't enjoy watching how they've changed her into such a lovesick cheerleader for Ben. I don't enjoy them anymore.</p>
<p>
	I'd also be okay never seeing Clyde Weston. </p>
<p>
	<em>Jack:</em> I would get rid of Lani and her eternal whining and insistence she's helpless.</p>
<p>
	I also could do without Stevano and Gina. Restore them to who they are supposed to be and send those doppelgangers packing.</p>
<p>
	Finally, I see no use or need for Evan and would much rather see Will get free and he and Sonny try again to have another child.</p>
<p>
	<em>Sportsgirl:</em> I could do without Chad &amp; Abigail and sourpuss Eric needs to go. He is so rarely happy &amp; smiling.</p>
<p>
	<em>Christine: </em>Wow, I have quite a list. Ciara can go. Like Trey said, her only character trait is her obsession with Ben and I no longer care.</p>
<p>
	Lani does nothing but whine and very little to actually help herself so she can leave Salem too.</p>
<p>
	Chad and Abigail are dull beyond words. If the show can’t come up with anything interesting for them then send them back to Europe.</p>
<p>
	Finally, I’m so over this Princess Gina/Stevano fiasco. Let’s send them back into whatever reaches of Hell from which they came and get back to Hope and Steve.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/smuggling-stevano-out-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:66.53846153846153%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--NAtXbTn0--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581448962/smuggling-stevano-out-days-of-our-lives.jpg" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--eXeCeSam--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581448962/smuggling-stevano-out-days-of-our-lives.jpg" class="lazyload" alt="Smuggling Stevano Out - Days of Our Lives"></div></a>
</div>
<p>
	<strong>What was your favorite quote, scene, or storyline from this week’s Days of Our Lives? </strong></p>
<p>
	Trey: I liked seeing some of the action and adventures in Prague. It's fun seeing the characters having adventures and excitement again. I am not enjoying watching how mean Stevano is to Kayla.</p>
<p>
	I can't wait to see how the wedding drama plays out.</p>
<p>
	I think one of my favorite lines was from Victor telling Justin that it was no wonder he had a stroke because of the stress of all the false accusations against him. </p>
<p>
	<em>Jack:</em> I laughed out loud at Victor saying that people accusing him falsely was why he had a stroke. </p>
<p>
	<em>Sportsgirl:</em> Any Xander and Sarah scene. They are so adorable together. It was funny when Sarah told Nicole &amp; Eric they were a couple and they looked at her like "UGH" and she just blew them off saying he is a changed man.</p>
<p>
	<em>Christine:</em> It was good to hear Kayla finally get to tell “Steve” off although I wish she would have walked out on him much sooner.</p>
<p>
	Also, Chad and Abby trying to explain the Stefano/Princess Gina situation to Gabi was comical with <a href="https://www.tvfanatic.com/quotes/shows/days-of-our-lives/">Days of Our Lives quotes</a> like this… </p>
<p>
	<blockquote>
<p>Chad: He tried to kill Hattie Adams.<br>Gabi: Of course he did. Anybody who’s had her as a waitress would want to kill her. </p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/of-course-he-did-anybody-whos-had-her-as-a-waitress-would-want-t/">Of course he did. Anybody who’s had her as a waitress would want to kill her.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Finally, Valerie’s return. She hasn’t said much yet but her hair was absolutely gorgeous!</p>
<div style="max-width:375px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/lani-arrives-days-of-our-lives/"><div class="image_wrapper" style="padding-bottom:160.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--3K79gbDv--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811788/lani-arrives-days-of-our-lives.png" data-pin-description="Days of Our Lives Round Table: Valentine's Day Edition" data-pin-url="https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--x3oGlmhO--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581811788/lani-arrives-days-of-our-lives.png" class="lazyload" alt="Lani Arrives - Days of Our Lives"></div></a>
</div>
<p>
	Want to chat more about the happenings in Salem? Then check out Jack Ori’s Days of Our Lives review here at TV Fanatic.</p>


<div class="buttons admin edit_object_links" data-user-id="13225"><button class="btn btn-primary" data-href="/admin/post/86398/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/86398/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>C. Orlando</b> is a TV Fanatic Staff Writer. Follow her on <a href="http://twitter.com/ProudTVJunkie">Twitter</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/' data-id='86398' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-86398' data-disqus-url='https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-86398";
  var disqus_url = "https://www.tvfanatic.com/2020/02/days-of-our-lives-round-table-valentines-day-edition/";
  var disqus_title = "Days of Our Lives Round Table: Valentine\'s Day Edition";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Days of Our Lives Round Table: Valentine\'s Day Edition"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2020/02/days-of-our-lives-review-week-of-2-10-20-fake-lovers-and-false-l/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/days-of-our-lives/" rel="tag">Days of Our Lives</a>, <a href="/tags/round-tables/" rel="tag">Round Tables</a>, <a href="/tags/soap-operas/" rel="tag">Soap Operas</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/days-of-our-lives/">Days of Our Lives Quotes</a></h4>
<blockquote>
<p>Eli: I just want what's best for the baby.<br>JJ: Did she make you godfather or something? Cause you're being awfully protective of our baby.</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/did-she-make-you-godfather-or-something-cause-youre-being-awfull/">Did she make you godfather or something? Cause you&#39;re being awfully protective of our baby.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2018-03-09">March 09, 2018</time></li>
</ul>
</blockquote>
<blockquote>
<p> I keep wanting to believe the man you were is still in there somewhere. The man I fell so hard for, the man I married. But if you keep going down this path, you will not only lose the election, you will lose your soul.<br></p>
<small>Jennifer</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/i-keep-wanting-to-believe-the-man-you-were-is-still-in-there-som/">I keep wanting to believe the man you were is still in there somewhere. The man I fell so...</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2019-03-08">March 08, 2019</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/shows/days-of-our-lives/">Days of Our Lives</a></h4>
<ul class='nav'>
<li>
<a class="clearfix" href="/2020/02/days-of-our-lives-round-table-valentines-day-addition/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Days of Our Lives Round Table: Valentine&#39;s Day Edition" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Ez7uKlYd--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1390625699/attachment/days-of-our-lives-round-table" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--5GwyT3l3--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1390625699/attachment/days-of-our-lives-round-table 31w, https://tv-fanatic-res.cloudinary.com/iu/s--FYYehOix--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1390625699/attachment/days-of-our-lives-round-table 62w, https://tv-fanatic-res.cloudinary.com/iu/s--7CZATpRl--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1390625699/attachment/days-of-our-lives-round-table 93w, https://tv-fanatic-res.cloudinary.com/iu/s--Ez7uKlYd--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1390625699/attachment/days-of-our-lives-round-table 125w, https://tv-fanatic-res.cloudinary.com/iu/s--Ts2LIaXK--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1390625699/attachment/days-of-our-lives-round-table 187w, https://tv-fanatic-res.cloudinary.com/iu/s--8H-Q2d26--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1390625699/attachment/days-of-our-lives-round-table 250w, https://tv-fanatic-res.cloudinary.com/iu/s--8BmgRKLR--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1390625699/attachment/days-of-our-lives-round-table 312w, https://tv-fanatic-res.cloudinary.com/iu/s--zCQLql7p--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1390625699/attachment/days-of-our-lives-round-table 375w" /></div></div>
</div>
Days of Our Lives Round Table: Valentine's Day Edition
</a></li>
<li>
<a class="clearfix" href="/2020/02/days-of-our-lives-review-week-of-2-10-20-fake-lovers-and-false-l/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Days of Our Lives Review Week of 2-10-20: Fake Lovers and False Love" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--9Ct6t_BX--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1581448962/smuggling-stevano-out-days-of-our-lives" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--2v68It1x--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1581448962/smuggling-stevano-out-days-of-our-lives 31w, https://tv-fanatic-res.cloudinary.com/iu/s--ZDAORFO1--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1581448962/smuggling-stevano-out-days-of-our-lives 62w, https://tv-fanatic-res.cloudinary.com/iu/s--iYXFZBvD--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1581448962/smuggling-stevano-out-days-of-our-lives 93w, https://tv-fanatic-res.cloudinary.com/iu/s--9Ct6t_BX--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1581448962/smuggling-stevano-out-days-of-our-lives 125w, https://tv-fanatic-res.cloudinary.com/iu/s--rGv7BjL5--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1581448962/smuggling-stevano-out-days-of-our-lives 187w, https://tv-fanatic-res.cloudinary.com/iu/s--5BFsLbgf--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1581448962/smuggling-stevano-out-days-of-our-lives 250w, https://tv-fanatic-res.cloudinary.com/iu/s--jstvlxN7--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1581448962/smuggling-stevano-out-days-of-our-lives 312w, https://tv-fanatic-res.cloudinary.com/iu/s--F_cVod1g--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1581448962/smuggling-stevano-out-days-of-our-lives 375w" /></div></div>
</div>
Days of Our Lives Review Week of 2-10-20: Fake Lovers and False Love
</a></li>
<li>
<a class="clearfix" href="/2020/02/days-of-our-lives-cast-shake-up-continues-galen-gering-fired/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Days of Our Lives Cast Shake-Up Continues: Galen Gering Fired" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--jtbVG9GX--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1581687320/attachment/rafe-hernandez" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--OWyAoaly--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1581687320/attachment/rafe-hernandez 31w, https://tv-fanatic-res.cloudinary.com/iu/s--j0uatJ3K--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1581687320/attachment/rafe-hernandez 62w, https://tv-fanatic-res.cloudinary.com/iu/s--MP0ZSxc2--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1581687320/attachment/rafe-hernandez 93w, https://tv-fanatic-res.cloudinary.com/iu/s--jtbVG9GX--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1581687320/attachment/rafe-hernandez 125w, https://tv-fanatic-res.cloudinary.com/iu/s--epMUduYI--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1581687320/attachment/rafe-hernandez 187w, https://tv-fanatic-res.cloudinary.com/iu/s--q_FmI0mG--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1581687320/attachment/rafe-hernandez 250w, https://tv-fanatic-res.cloudinary.com/iu/s--gBXLl5l1--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1581687320/attachment/rafe-hernandez 312w, https://tv-fanatic-res.cloudinary.com/iu/s--aj1C5Un_--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1581687320/attachment/rafe-hernandez 375w" /></div></div>
</div>
Days of Our Lives Cast Shake-Up Continues: Galen Gering Fired
</a></li>
</ul>

</div>
</div>
</div>
<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/days-of-our-lives/">Days of Our Lives Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/stevanos-shocking-reveal-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Stevano&#39;s Shocking Reveal - Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Nl_-upPi--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581868299/stevanos-shocking-reveal-days-of-our-lives.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tall-stevanos-shocking-reveal-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="(TALL) Stevano&#39;s Shocking Reveal - Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--CjvmVUwX--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581867864/tall-stevanos-shocking-reveal-days-of-our-lives.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/a-unsettling-dream-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="A Unsettling Dream - Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--xf-ImsqW--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581867776/a-unsettling-dream-days-of-our-lives.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tall-an-unsettling-dream-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="(TALL) An Unsettling Dream - Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--SZkIaZ3B--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581867692/tall-an-unsettling-dream-days-of-our-lives.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/jarlena-bring-on-the-romance-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Jarlena Bring On The Romance - Days Of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1cIaTW9j--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581867540/jarlena-bring-on-the-romance-days-of-our-lives.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tall-jarlena-bring-on-the-romance-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="(TALL) Jarlena Bring On the Romance  - Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--cL9QnXVp--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1581867372/tall-jarlena-bring-on-the-romance-days-of-our-lives.jpg" /></div></div>
</a></div>
</div>

</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/videos/shows/days-of-our-lives/">Days of Our Lives Videos</a></h4>
<div class='row'>
<div class='col-xs-12'>
<a class="thumbnail" href="/videos/days-of-our-lives-preview-for-the-week-of-8-slash-19-slash-2019/"><div class="image_outter_wrapper" style="max-width:313px;"><div class="image_wrapper" style="padding-bottom:61.66134185303515%;"><img alt="Days of Our Lives Preview For The Week of 8/19/2019" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--7VCPHX3L--/t_v_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1566156179/video/days-of-our-lives-preview-for-the-week-of-8-slash-19-slash-2019.jpg" /></div></div>
<div class='caption'>Days of Our Lives Preview For The Week of 8/19/2019</div>
</a></div>
</div>
<div class='row videos'>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/martha-madison-talks-days-of-our-lives/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="Martha Madison Talks Days of Our Lives" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--n2SB5z2Q--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1448883055/video/martha-madison-talks-days-of-our-lives.jpg" /></div></div>
<div class='caption'>Martha Madison Talks Days of Our Lives</div>
</a></div>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/kassie-depaiva-and-jen-lilley-interview/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="Kassie DePaiva and Jen Lilley Interview" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--g6NPrbHf--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1448882990/video/kassie-depaiva-and-jen-lilley-interview.jpg" /></div></div>
<div class='caption'>Kassie DePaiva and Jen Lilley Interview</div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/">Shows</a></li> <li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li> <li>Days of Our Lives Round Table: Valentine&#39;s Day Edition</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/criminal-minds/">Criminal Minds</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/the-100/">The 100</a></li>
<li><a href="/shows/the-good-place/">The Good Place</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
<li><a href="/shows/the-new-pope/">The New Pope</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/the-magicians/">The Magicians</a></li>
<li><a href="/shows/succession/">Succession</a></li>
<li><a href="/shows/the-blacklist/">The Blacklist</a></li>
<li><a href="/shows/legacies/">Legacies</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/the-flash/">The Flash</a></li>
<li><a href="/shows/chilling-adventures-of-sabrina/">Chilling Adventures of Sabrina</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2020/02/">February 2020</a></li>
<li><a href="/2020/01/">January 2020</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
<li><a href="/2010/">2010 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2020 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2020 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
