<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/' property='og:url'>
<meta content='Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick' property='og:title'>
<meta content='In this exclusive sneak peek at Good Witch Season 6 Episode 3, Joy gets an official welcome into the family and a tease of her new existence as a Merriwick.' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--wW_ARC3M--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579504/merriwick-knowledge-the-good-witch-s6e3.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='355' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--P-h4a5mU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579561/to-family-the-good-witch-s6e3.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='437' property='og:image:width'>
<meta content='672' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--psIgR8Rc--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579548/the-merriwick-energy-the-good-witch-s6e3.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='447' property='og:image:width'>
<meta content='672' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Rjzhm1rJ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1566443395/slides/3867/lucifer-and-chloe-lucifer.gif' property='og:image'>
<meta content='image/gif' property='og:image:type'>
<meta content='500' property='og:image:width'>
<meta content='240' property='og:image:height'>
<meta content='2020-05-16T13:00:00-04:00' property='article:published_time'>
<meta content='2020-05-15T17:55:26-04:00' property='article:modified_time'>
<meta content='Good Witch' property='article:tag'>
<meta content='Clips' property='article:tag'>
<meta content='Exclusives' property='article:tag'>
<meta content='Carissa Pavlica' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick' name='twitter:title'>
<meta content='In this exclusive sneak peek at Good Witch Season 6 Episode 3, Joy gets an official welcome into the family and a tease of her new existence as a Merriwick.' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--wW_ARC3M--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579504/merriwick-knowledge-the-good-witch-s6e3.png' name='twitter:image:src'>

<meta content="In this exclusive sneak peek at Good Witch Season 6 Episode 3, Joy gets an official welcome into the family and a tease of her new..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Good Witch');
ga('set', 'dimension2', 'Carissa Pavlica');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "the-good-witch", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/","mainEntityOfPage":"https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/","headline":"Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick","datePublished":"2020-05-16T13:00:00-04:00","dateModified":"2020-05-15T17:55:26-04:00","description":"In this exclusive sneak peek at Good Witch Season 6 Episode 3, Joy gets an official welcome into the family and a tease of her new existence as a Merriwick.","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--mird4qY6--/f_auto,q_auto/v1589579504/merriwick-knowledge-the-good-witch-s6e3","height":673,"width":1191},"author":{"@type":"Person","name":"Carissa Pavlica"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2509' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Good Witch" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1K5MB6yX--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1588374937/banner/the-good-witch.png" /></div></div>
<div class='title'>
<h1><a href="/shows/the-good-witch/">Good Witch</a></h1>
<span class='airs'>
Sundays
 8:00 PM
on
Hallmark
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/the-good-witch/">Good Witch News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/the-good-witch/tags/reviews/">Good Witch Reviews</a></li>
<li><a class="" data-title="Watch Online" href="/shows/the-good-witch/full-episodes/">Good Witch Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/the-good-witch/episodes/">Good Witch Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/the-good-witch/">Good Witch Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/the-good-witch/">Good Witch Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Good Witch</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick</h1>
<small>
<a href="/authors/modwild/" rel="author"><img alt="Modwild" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--6dZMlBAd--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1516234513/user/modwild.jpg" />
<a href="/authors/modwild/" rel="author">Carissa Pavlica</a>
</a>at
<time datetime="2020-05-16T13:00:00-04:00" itemprop="datePublished">May 16, 2020  1:00 pm</time>.
</small>
</header>
<div class='body'>
<p>
	If you <a href="https://www.tvfanatic.com/shows/the-good-witch/episodes/">watch Good Witch online</a>, then you know there's a new Merriwick in town!</p>
<p>
	Joy Harper arrived in Middleton with a purpose -- to discover more about her family.</p>
<p>
	With seemingly no family left, Joy ached to find elusive members of her family tree that she had never known.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/merriwick-knowledge-the-good-witch-s6e3/"><div class="image_wrapper" style="padding-bottom:56.34615384615385%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--wW_ARC3M--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579504/merriwick-knowledge-the-good-witch-s6e3.png" data-pin-description="Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick" data-pin-url="https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--lHV-qa9X--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579504/merriwick-knowledge-the-good-witch-s6e3.png" class="lazyload" alt="Merriwick Knowledge - Good Witch Season 6 Episode 3"></div></a>
</div>
<p>
	What she discovers at Grey House is that her Merriwick cousins are anything but the average ordinary family.</p><div id="stp_target"></div>
<p>
	<a href="https://www.tvfanatic.com/shows/the-good-witch/episodes/season-6/the-clock/">Good Witch Season 6 Episode 3</a> is a good indication that the magical qualities we've known the Merriwicks possess will be in the spotlight like never before.</p>
<p>
	When Abigail first arrived in Middleton, she had a chip on her shoulder and an attitude that set her apart from her cousin, Cassie.</p>
<p>
	Knowing that history makes Joy's arrival a lot of fun because Abigail really leans into her role as mentor the younger Merriwick.</p>
<div style="max-width:390px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/to-family-the-good-witch-s6e3/"><div class="image_wrapper" style="padding-bottom:153.84615384615387%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--P-h4a5mU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579561/to-family-the-good-witch-s6e3.png" data-pin-description="Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick" data-pin-url="https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--WozxyGFm--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579561/to-family-the-good-witch-s6e3.png" class="lazyload" alt="To Family - Good Witch Season 6 Episode 3"></div></a>
</div>
<p>
	And it's so lovely knowing how far Abigail has grown during Good Witch's run.</p>
<p>
	In this exclusive clip, which previews the opening of "The Clock," the charm running through this blossoming familial relationship is already apparent.</p>
<p>
	It might be one of my very favorite scenes of the series so far because of the way Joy gets welcomed to the family with hints of what's to come between the three.</p>
<p>
	Take a look:</p>
<p style="text-align: center;">
	<iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/X7kaxTL7JB4" width="560"></iframe></p>
<p>
	The three take a trip to an estate sale that holds all kinds of surprises for them that then carries right back to their business in Middleton.</p>
<p>
	Elsewhere in the episode, Sam gets a first-hand look at someone who greatly benefits from an emotional support animal, and that gets his professional creative juices flowing.</p>
<p>
	George gets surprised with a visit from an old buddy from the service, and when George discovers the true reason for the visit, he springs into action as he once when they served together.</p>
<p>
	And you will get such a kick out of Martha being Martha that I don't want to spoil it, but her latest endeavor is so delightfully in character that you're going to love it!</p>
<div style="max-width:399px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/the-merriwick-energy-the-good-witch-s6e3/"><div class="image_wrapper" style="padding-bottom:150.37593984962405%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--psIgR8Rc--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579548/the-merriwick-energy-the-good-witch-s6e3.png" data-pin-description="Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick" data-pin-url="https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--42XX-ZUC--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579548/the-merriwick-energy-the-good-witch-s6e3.png" class="lazyload" alt="The Merriwick Energy - Good Witch Season 6 Episode 3"></div></a>
</div>
<p>
	The preview wouldn't be complete without a tease about two of our favorite dating couples in Middleton.</p>
<p>
	Stephanie gets a surprise from an ex that threatens to upend things with Adam. Does he really have something to worry about?</p>
<p>
	And Abigail gets put on the spot as Donovan has a special memory of their time together that she doesn't share but will go to great lengths to discover, much to our amusement.</p>
<p>
	Switching the focal point of Good Witch gives the series new energy that you don't want to miss.</p>
<p>
	Check out our Good Witch interviews (Kat Barrell is coming next week), and be here right after Good Witch airs on Sunday for a full review!</p>
<p>
	<div class="slideshow_teaser image_outter_wrapper ggnoads">
<a data-event-action="teaser" data-event-label="31 Couples Who Inspired Each Other's Inner Comedian" data-event="slideshow" href="/slideshows/31-couples-who-inspired-each-others-inner-comedian/"><div class="image_wrapper" style="padding-bottom: 62.5%">
<img alt="" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--qRY77Svc--/c_fill,h_200,w_320/c_fill,h_200,l_upload:slides:3867:simon-and-isabelle-shadowhunters,w_320,x_324/c_fill,h_200,l_upload:slides:3867:jackson-and-rocki-fuller-house,w_320,x_-162,y_204/c_fill,h_200,l_upload:slides:3867:stiles-and-lydia-teen-wolf,w_320,x_162,y_102/f_auto,fl_lossy,q_auto:420/v1566443395/slides/3867/lucifer-and-chloe-lucifer.jpg">
</div>
<div class="title">
31 Couples Who Inspired Each Other's Inner Comedian
</div>
<div class="start">
Start Gallery
<i class="fa fa-long-arrow-right"></i>
</div>
</a>
</div>
</p>


<div class="buttons admin edit_object_links" data-user-id="15328"><button class="btn btn-primary" data-href="/admin/post/88051/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/88051/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Carissa Pavlica</b> is the managing editor and a staff writer for TV Fanatic. She's a member of the <a href="http://www.criticschoice.com/members/cpavlica/">Critic&#39;s Choice Association</a>, enjoys mentoring writers, cats, and passionately discussing the nuances of television and film.  Follow her on <a href="http://twitter.com/CarissaPavlica">Twitter</a> and email her here at <a href="mailto:carissa@tvfanatic.com">TV Fanatic</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/' data-id='88051' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-88051' data-disqus-url='https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-88051";
  var disqus_url = "https://www.tvfanatic.com/2020/05/good-witch-exclusive-sneak-peek-joy-has-a-lot-to-learn-about-bei/";
  var disqus_title = "Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2020/05/watch-good-witch-online-season-6-episode-2/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/the-good-witch/" rel="tag">Good Witch</a>, <a href="/tags/clips/" rel="tag">Clips</a>, <a href="/tags/exclusives/" rel="tag">Exclusives</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/the-good-witch/episodes/the-clock/">Good Witch Season 6 Episode 3 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/took-you-long-enough-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Took You Long Enough - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ZUIE_k18--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579574/took-you-long-enough-the-good-witch-s6e3.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/to-family-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="To Family - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--YNABvctu--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579561/to-family-the-good-witch-s6e3.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/the-merriwick-energy-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="The Merriwick Energy - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--4AQZooTy--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579548/the-merriwick-energy-the-good-witch-s6e3.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/the-maltese-falcon-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="The Maltese Falcon - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1JJv2ZvJ--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579531/the-maltese-falcon-the-good-witch-s6e3.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tea-drinker-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tea Drinker - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Rc-A-_UU--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579517/tea-drinker-the-good-witch-s6e3.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/merriwick-knowledge-the-good-witch-s6e3/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Merriwick Knowledge - Good Witch Season 6 Episode 3" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--FPlag5ve--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589579504/merriwick-knowledge-the-good-witch-s6e3.png" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/the-good-witch/episodes/season-6/the-clock/","url":"https://www.tvfanatic.com/shows/the-good-witch/episodes/season-6/the-clock/","name":"The Clock","episodeNumber":3,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/the-good-witch/episodes/season-6/","url":"https://www.tvfanatic.com/shows/the-good-witch/episodes/season-6/","seasonNumber":6},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/the-good-witch/","url":"https://www.tvfanatic.com/shows/the-good-witch/","name":"Good Witch"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2020-05-17","location":{"@type":"Country","name":"US"}},"description":"Cassie and Abigail accompany Joy to  an estate sale  as she begins  renovating  Martha’s mayor’s mansion, but Cassie soon discovers her newest Grey House guest has some lessons to learn on Good Witch Season 6 Episode 3.","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/the-good-witch/full-episodes/season-6/the-clock/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2020-05-17T00:00","availabilityEnds":"2021-05-16T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--Y8JwzgTU--/c_thumb,f_auto,g_auto,h_3077,q_auto,w_2051/v1589568995/couple-in-love-the-good-witch","height":3077,"width":2051}}</script>
<h4>
<div class='clearfix'>
<time class="air" datetime="2020-05-17">5/17/20</time>
<div class='number'><a href="/shows/the-good-witch/episodes/season-6/the-clock/">Good Witch Season 6 Episode 3</a></div>
</div>
<div class='title'>The Clock</div>
</h4>
<img alt="Couple in Love - Good Witch" src="https://tv-fanatic-res.cloudinary.com/iu/s--ORMjaMWb--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1589568995/couple-in-love-the-good-witch.jpg" />
<ul class='nav nav-pills'>
<li><a href="/gallery/shows/the-good-witch/episodes/the-clock/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/the-good-witch/">Good Witch</a></li> <li><a href="/shows/the-good-witch/episodes/season-6/">Good Witch Season 6</a></li> <li><a href="/shows/the-good-witch/episodes/season-6/the-clock/">Good Witch Season 6 Episode 3</a></li> <li>Good Witch Exclusive Sneak Peek: Joy Has a Lot To Learn About Being a Merriwick</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/motherland-fort-salem/">Motherland: Fort Salem</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/how-to-get-away-with-murder/">How to Get Away with Murder</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/the-100/">The 100</a></li>
<li><a href="/shows/chicago-pd/">Chicago PD</a></li>
<li><a href="/shows/9-1-1/">9-1-1</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/what-we-do-in-the-shadows/">What We Do In The Shadows</a></li>
<li><a href="/shows/zoeys-extraordinary-playlist/">Zoey&#39;s Extraordinary Playlist</a></li>
<li><a href="/shows/legacies/">Legacies</a></li>
<li><a href="/shows/westworld/">Westworld</a></li>
<li><a href="/shows/the-blacklist/">The Blacklist</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2020/05/">May 2020</a></li>
<li><a href="/2020/04/">April 2020</a></li>
<li><a href="/2020/03/">March 2020</a></li>
<li><a href="/2020/02/">February 2020</a></li>
<li><a href="/2020/01/">January 2020</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
<li><a href="/2010/">2010 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2020 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2020 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
