<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6 - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/' property='og:url'>
<meta content='Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6' property='og:title'>
<meta content="On Filthy Rich Season 1 Episode 5, Margaret and Ginger's tenuous partnership may collapse because of a salacious video. Eugene makes some big moves. Read our review!" property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CBPVCl4b--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675835/yopi-and-maggie-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='406' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--kuvT8QQq--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675947/antonio-in-the-middle-tall-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='807' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--fHXzUary--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603663189/pulled-into-a-debacle-filthy-rich.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='393' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--EAJHRicV--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676295/investigative-board-tall-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='836' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--LUn8yDyd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603050728/grasping-at-control-tall-filthy-rich-s1e4.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='854' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ll_Nh7O5--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847341/bring-out-the-stool-tall-filthy-rich-s1e3.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='822' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Q0Vn5NEF--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676558/luke-and-ginger-tall-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='849' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s---d1u4S9f--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601226753/basic-becky-tall-filthy-rich-s1e2.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='837' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--n2Ruv8i---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676786/forbidden-love-tall-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='829' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--nm7oLNSy--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676920/driving-a-ghost-tall-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='856' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--PAJCqAM6--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675746/aimless-wanderer-filthy-rich-s1e5.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='928' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--a5pCPKJO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229101/hbic-filthy-rich-s1e2.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--DpST6dIA--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229536/chatting-over-drinks-filthy-rich-s1e2.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--aGjFmmMZ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603052323/juliette-returns-tall-filthy-rich-s1e4.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='831' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--HvOL9beU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847264/worlds-greatest-tall-filthy-rich-s1e3.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='842' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--MSdireMG--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1600323271/beautiful-matriarch-tall-filthy-rich-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='783' property='og:image:height'>
<meta content='2020-10-26T22:00:00-04:00' property='article:published_time'>
<meta content='2020-10-26T22:01:35-04:00' property='article:modified_time'>
<meta content='Filthy Rich' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Jasmine Blu' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6' name='twitter:title'>
<meta content="On Filthy Rich Season 1 Episode 5, Margaret and Ginger's tenuous partnership may collapse because of a salacious video. Eugene makes some big moves. Read our review!" name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CBPVCl4b--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675835/yopi-and-maggie-filthy-rich-s1e5.jpg' name='twitter:image:src'>

<meta content="On Filthy Rich Season 1 Episode 5, Margaret and Ginger&#39;s tenuous partnership may collapse because of a salacious video. Eugene makes some..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Filthy Rich');
ga('set', 'dimension2', 'Jasmine Blu');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "filthy-rich", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/","mainEntityOfPage":"https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/","headline":"Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6","datePublished":"2020-10-26T22:00:00-04:00","dateModified":"2020-10-26T22:01:35-04:00","description":"On Filthy Rich Season 1 Episode 5, Margaret and Ginger's tenuous partnership may collapse because of a salacious video. Eugene makes some big moves. Read our review!","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--RHev7BQP--/f_auto,q_auto/v1603675835/yopi-and-maggie-filthy-rich-s1e5","height":4096,"width":6346},"author":{"@type":"Person","name":"Jasmine Blu"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2821' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Filthy Rich" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Stap8gjh--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1600652916/banner/filthy-rich.jpg" /></div></div>
<div class='title'>
<h1><a href="/shows/filthy-rich/">Filthy Rich</a></h1>
<span class='airs'>
Mondays
 9:00 PM
on
FOX
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/filthy-rich/">Filthy Rich News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/filthy-rich/tags/reviews/">Filthy Rich Reviews</a></li>
<li><a class="" data-title="Watch Online" href="/shows/filthy-rich/full-episodes/">Filthy Rich Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/filthy-rich/episodes/">Filthy Rich Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/filthy-rich/">Filthy Rich Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/filthy-rich/">Filthy Rich Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Filthy Rich</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6</h1>
<small>
<a href="/authors/blu/" rel="author"><img alt="Blu" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--IhuDiizY--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1379964334/user/blu.png" />
<a href="/authors/blu/" rel="author">Jasmine Blu</a>
</a>at
<time datetime="2020-10-26T22:00:00-04:00" itemprop="datePublished">October 26, 2020 10:00 pm</time>.
</small>
</header>
<div class='body'>
<p>
	Have we reached a turning point in the season where it has turned everything up a notch?</p>
<p>
	Under the cloak of Mardi Gras, <a href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/">Filthy Rich Season 1 Episode 5</a> dug deeper into the background of some characters, gave us peeks at potential motivations, and the hour made some big moves that could change the course of everything.</p>
<p>
	All in all, so far, it was one of the most solid hours of the series.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/antonio-in-the-middle-tall-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:128.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--kuvT8QQq--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675947/antonio-in-the-middle-tall-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--e6Hou3HE--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675947/antonio-in-the-middle-tall-filthy-rich-s1e5.jpg" class="lazyload" alt="Antonio in the Middle - Tall  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	All one ever wanted was for Margaret and Ginger to work with one another. In theory, they'd do better together than they would apart.</p><div id="stp_target"></div>
<p>
	Sadly, even when Margaret and Ginger are working together, they're not working together.</p>
<p>
	Dear, God; maybe we should've been more specific. What we want is for Margaret and Ginger to work together and learn how to communicate and trust one another. It's a big ask, we know.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/pulled-into-a-debacle-filthy-rich/"><div class="image_wrapper" style="padding-bottom:62.30769230769231%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--fHXzUary--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603663189/pulled-into-a-debacle-filthy-rich.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--dD_BbMLn--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603663189/pulled-into-a-debacle-filthy-rich.jpg" class="lazyload" alt="Pulled Into a Debacle - Filthy Rich"></div></a>
</div>
<p>
	Margaret and Ginger are coming at the same problem from two different angles and with a similar motivation. They both want to protect their loved ones.</p>
<p>
	The problem is that neither of their loved ones consists of the same people, so they're not invested enough in the other person's beloved individuals to make the best calls.</p>
<p>
	It's beyond frustrating. All we need is for two women to genuinely care about one another enough to look out for each other. They have moments when it's evident that they do, but there's something in the way of that.</p>
<p>
	<blockquote>
<p>Tina: I've never gone a day without talking to you.<br>Ginger: Be strong for me, and I'll be strong for you.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/be-strong-for-me-and-ill-be-strong-for-you/">Be strong for me, and I'll be strong for you.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	The 18:20 are dangerous, and it feels as though Margaret underestimates how much and Ginger overestimates her ability to handle them.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/investigative-board-tall-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:132.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--EAJHRicV--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676295/investigative-board-tall-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--yeMP5lJw--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676295/investigative-board-tall-filthy-rich-s1e5.jpg" class="lazyload" alt="Investigative Board - Tall  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	It took a lot for Ginger to compromise the integrity she has for her clients, girls, and business to record the men. However, it was an understandable decision given the circumstances. I don't know if Ginger was right or wrong to keep the Virgil video from Margaret.</p>
<p>
	By not sharing the information, it meant the "Ladies Table" was all talk. How can they work together if they're not forthcoming with one another?</p>
<p>
	But based on what Margaret did with the information the second she found out about it, she only confirmed why Ginger's reluctance was valid.</p>
<p>
	<blockquote>
<p> You can control her? Who's running this Holy War? If I go down, everyone goes down.</p>
<small>Virgil</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/you-can-control-her-whos-running-this-holy-war-if-i-go-down-ever/">You can control her? Who's running this Holy War? If I go down, everyone goes down.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Margaret can't hold water if you provided a cup when it comes down to certain things. All she saw was that Virgil and the 18:20 getting their hooks into Eric, and she was unable to consider anything beyond that.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/grasping-at-control-tall-filthy-rich-s1e4/"><div class="image_wrapper" style="padding-bottom:135.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--LUn8yDyd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603050728/grasping-at-control-tall-filthy-rich-s1e4.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--PPvdkKBO--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603050728/grasping-at-control-tall-filthy-rich-s1e4.jpg" class="lazyload" alt="Grasping at Control - Tall  - Filthy Rich Season 1 Episode 4"></div></a>
</div>
<p>
	She wanted to use the tape as leverage against Virgil to get him to drop out of politics, but Luke and Ginger were right about how a scandalous video could barely affect a politician.</p>
<p>
	If they wanted to take down Virgil and the others, they needed something bigger that could effectively destroy them. Margaret couldn't think about that because of her laser-focus on Eric.</p>
<p>
	The exposure of that tape could put a dent in Virgil, but it also would rile up the rest of the powerful men. It also endangered so many other people, like Ginger, Tina, their employees, and so much more.</p>
<p>
	The problem with the 18:20 is anyone can be collateral damage, which is what Ginger was driving at when she confronted Margaret and Franklin.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/bring-out-the-stool-tall-filthy-rich-s1e3/"><div class="image_wrapper" style="padding-bottom:130.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ll_Nh7O5--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847341/bring-out-the-stool-tall-filthy-rich-s1e3.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--61bz86aP--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847341/bring-out-the-stool-tall-filthy-rich-s1e3.jpg" class="lazyload" alt="Bring Out the Stool - Tall - Filthy Rich Season 1 Episode 3"></div></a>
</div>
<p>
	Margaret's intentions are, at times, murky, but it does seem as if she means well in her way. But she's punching above her weight, blindfolded, with no steady footing.</p>
<p>
	They keep telling us that Margaret is powerful, but she more often than not feels out of her depth. She's in a chess game playing checkers.</p>
<p>
	By revealing the existence of the tape, it put Ginger in jeopardy. It was no surprise at all that the 18:20 henchman, in all of his pseudo-religious rationale, found her and roughed her up until he got what he thought he wanted.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/luke-and-ginger-tall-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:134.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Q0Vn5NEF--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676558/luke-and-ginger-tall-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Du1bU4qB--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676558/luke-and-ginger-tall-filthy-rich-s1e5.jpg" class="lazyload" alt="Luke and Ginger - Tall  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	Margaret said she could protect Ginger and her mother, but could she? No one even noticed that Ginger was missing, and even though Margaret was at the door later and suspected something was wrong, she didn't push it farther.</p>
<p>
	I wanted her to breakdown the door, see what Ginger had endured, and the two women to have a real, soul-to-soul moment. But that didn't happen.</p>
<p>
	Becky was the one to have a moment with Ginger, and boy was that an unexpected twist! Becky's lack of romantic interest in Eric and stance on sex makes so much more sense, and so does her fixation on Ginger.</p>
<p>
	Becky is attracted to women. It was already a surprise that Ginger broke down in front of Becky and that the blond bandaged her up.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/basic-becky-tall-filthy-rich-s1e2/"><div class="image_wrapper" style="padding-bottom:132.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s---d1u4S9f--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601226753/basic-becky-tall-filthy-rich-s1e2.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--teLUnhbj--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601226753/basic-becky-tall-filthy-rich-s1e2.jpg" class="lazyload" alt="Basic Becky - Tall - Filthy Rich Season 1 Episode 2"></div></a>
</div>
<p>
	But when Becky reached for Ginger's face, and the sparks between them were flying, it was a twist I didn't see coming at all, which is not something I can say about most of them.</p>
<p>
	Becky almost submitted to her yearnings and sinning, and ironically, she did it while trying to stop Eric from doing the same. It's too late, though.</p>
<p>
	Eric and Rachel were already getting it on like two giddy teenagers. If I had to choose which romance was more endearing, Eric and Rachel beat out Mark and Rose.</p>
<p>
	Eric was livid when he learned of the tapes because of his fear of exposure, but the moment he could confront Rachel about it, she assured him that she deleted all of his.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/forbidden-love-tall-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:131.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--n2Ruv8i---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676786/forbidden-love-tall-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--gdtSwVaA--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676786/forbidden-love-tall-filthy-rich-s1e5.jpg" class="lazyload" alt="Forbidden Love - Tall  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	She loves him; they love one another, and goodness, the Monreauxs are a messy bunch.</p>
<p>
	If anyone could get through to Eric, it's probably Rachel, but then again, who knows? Maybe it's a job for Eugene.</p>
<p>
	<blockquote>
<p> Franklin, I need you to come home.</p>
<small>Margaret</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/franklin-i-need-you-to-come-home/">Franklin, I need you to come home.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	The ongoing theme about ghosts and the past haunting folks was a nice touch, and Eugene wandered around like a living ghost, soaking up all the information about everything.</p>
<p>
	Mark's stoner friends drove into town so they could blackmail him for money. How far is the ride from Colorado to New Orleans? They drive back and forth as if it's around the corner.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/driving-a-ghost-tall-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:135.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--nm7oLNSy--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676920/driving-a-ghost-tall-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--SRqZ9n4D--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676920/driving-a-ghost-tall-filthy-rich-s1e5.jpg" class="lazyload" alt="Driving a Ghost - tall  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	It didn't take more than two brain cells for anyone to guess that Mark was only impersonating his brother to help with the medical expenses, but Augie and TK didn't have two brain cells to spare, so Rose and Mark went to pay them off.</p>
<p>
	Mark loves Rose, but the Monreaux lifestyle throws him off. They pay off anyone who stands in their way, and they don't bat an eye.</p>
<p>
	<blockquote>
<p>Mark: Who even are you to these people?<br>Franklin.  I can ask you the same thing.<br>Mark: No, I didn't mean it like that. I've just never been around this much money before, and I've never met people like any of you. Not you, you seem cool, but the Monreauxs -- if they don't want to deal with people, they just throw money at them to make them go away.<br>Franklin: Oh, they try.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/who-even-are-you-to-these-people-franklin-i-can-ask-you-the-same/">Who even are you to these people? Franklin.  I can ask you the same thing.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Eugene has figured out that Mark is not Jason, and he also knows that Rose is aware of this and in a relationship with Mark.</p>
<p>
	I loved when Eugene stole the money back from them after warning them about karma and righteousness, and he took the money to his real son.</p>
<p>
	<blockquote>
<p> I just wish Margaret could love me back. I just wish I felt like any of 'em knew how to love me back.</p>
<small>Franklin</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/i-just-wish-margaret-could-love-me-back-i-just-wish-i-felt-like/">I just wish Margaret could love me back. I just wish I felt like any of 'em knew how to love...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Did anyone gasp when the real Jason opened his eyes after Eugene's forehead kiss? It's the right kind of soap-opera messiness that one can devour.</p>
<p>
	Think of all the drama that will ensue from this event alone!</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/aimless-wanderer-filthy-rich-s1e5/"><div class="image_wrapper" style="padding-bottom:147.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--PAJCqAM6--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675746/aimless-wanderer-filthy-rich-s1e5.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--YmEzpQNw--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675746/aimless-wanderer-filthy-rich-s1e5.jpg" class="lazyload" alt="Aimless Wanderer  - Filthy Rich Season 1 Episode 5"></div></a>
</div>
<p>
	Eugene slowly revealing himself to select people is an interesting tactic, and I'm curious as to why he's taking this approach.</p>
<p>
	Also, what does it say that about where he stands right now that he would rather reveal himself to the outcasts? Tina was the first to see him, and now Ginger knows her father is alive too.</p>
<p>
	However, I don't know what she gained from threatening Franklin the way that she did. Why would she believe that Eugene, a man who she didn't even see most of her life, would care about them ruining her business?</p>
<p>
	They spoke of vengeance and avenging one person or another, but what makes Ginger think her father will be her avenger? Why is she confident about this?</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/hbic-filthy-rich-s1e2/"><div class="image_wrapper" style="padding-bottom:66.53846153846153%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--a5pCPKJO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229101/hbic-filthy-rich-s1e2.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--CquPYphE--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229101/hbic-filthy-rich-s1e2.jpg" class="lazyload" alt="HBIC  - Filthy Rich Season 1 Episode 2"></div></a>
</div>
<p>
	Although, maybe she's basing this on what she saw at Luke's house. He's piecing together that the 18:20 are behind Eugene's plane crash, so maybe she's banking on Eugene coming for them and maybe Margaret and Franklin, too?</p>
<p>
	I don't know. It's hard to figure out Ginger's thought process there, but I wish she would focus.</p>
<p>
	<blockquote>
<p>Ginger: You people are so low.<br>Margaret: Why not look at this as an opportunity for change?<br>Ginger: You crossed a line. You came for my business. I'm coming for yours.<br>Franklin: Ginger, wait! <br>Ginger: To think that I actually trusted you! My mom was right. My dad is watching all of us, and he knows exactly what you just did to his daughter.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/to-think-that-i-actually-trusted-you-my-mom-was-right-my-dad-is/">To think that I actually trusted you! My mom was right. My dad is watching all of us, and he...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	We're just waiting for Eugene to strike. I do wonder if Franklin believes Ginger, and if he does, what will he do about it. He doesn't seem as though he was a big fan of Eugene.</p>
<p>
	The flashbacks were interesting, as it makes Margaret, Franklin, and Eugene's relationship make more sense.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/chatting-over-drinks-filthy-rich-s1e2/"><div class="image_wrapper" style="padding-bottom:66.53846153846153%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--DpST6dIA--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229536/chatting-over-drinks-filthy-rich-s1e2.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--TQMGYFU4--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601229536/chatting-over-drinks-filthy-rich-s1e2.jpg" class="lazyload" alt="Chatting over Drinks  - Filthy Rich Season 1 Episode 2"></div></a>
</div>
<p>
	It sounds as though Margaret didn't come from any money either, so there was a time when she and Franklin were one and the same. Margaret marrying Eugene pulled her farther away from Franklin.</p>
<p>
	And there is something to be said about easily some can make transitions from poverty to wealth over others, but more importantly, it's sad that Franklin has spent his entire life in love with Margaret, and she doesn't love him the same way.</p>
<p>
	<blockquote>
<p> Eugene's world ain't ours, Franklin.</p>
<small>Young Margaret</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/eugenes-world-aint-ours-franklin/">Eugene's world ain't ours, Franklin.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	And Franklin isn't even sure any of them care about him. But it was a nice tidbit, showing that Franklin's mother was the law enforcement officer/angel that guided Eugene.</p>
<p>
	Why is that? It was his mother and Franklin's mom urging him to get his life together from beyond the grave.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/juliette-returns-tall-filthy-rich-s1e4/"><div class="image_wrapper" style="padding-bottom:131.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--aGjFmmMZ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603052323/juliette-returns-tall-filthy-rich-s1e4.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--BCTxn-8K--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603052323/juliette-returns-tall-filthy-rich-s1e4.jpg" class="lazyload" alt="Juliette Returns - Tall - Filthy Rich Season 1 Episode 4"></div></a>
</div>
<p>
	Even with this new information, Franklin remains hard to place. I can guess that falls more on Margaret's side than anyone or anything else, but he also resents that he's putting more into these relationships than he gets out of them.</p>
<p>
	The show has so many players, and it's hard to place who is going to do what. But there are always some wildcards in the bunch.</p>
<p>
	<blockquote>
<p>Tina: The past is too big a burden. If I'm ever going to be well, I can't drag it along with me.<br>Franklin: Don't I know it. </p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/the-past-is-too-big-a-burden-if-im-ever-going-to-be-well-i-cant/">The past is too big a burden. If I'm ever going to be well, I can't drag it along with me.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Yopi is such a liability, and it's upsetting that Antonio has to deal with her. Every second we spend getting to know Yopi more, it's easier to understand how Antonio is gravitating to Margaret.</p>
<p>
	Yopi's double-double cross made all the sense in the world, for a woman who follows the money and is an eternal opportunist.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/worlds-greatest-tall-filthy-rich-s1e3/"><div class="image_wrapper" style="padding-bottom:133.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--HvOL9beU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847264/worlds-greatest-tall-filthy-rich-s1e3.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--AaMLZQAK--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1601847264/worlds-greatest-tall-filthy-rich-s1e3.jpg" class="lazyload" alt="World's Greatest - Tall - Filthy Rich Season 1 Episode 3"></div></a>
</div>
<p>
	It's all of these different outliers who are making the Monreaux saga pure insanity, but that's what we tune in for, yes?</p>
<p>
	<em>Spilling Sweet Tea:</em></p>
<ul>
	<li>
		We did NOT get Eric singing during this installment, and I missed it a little.</li>
</ul>
<ul>
	<li>
		Why is Tina so trusting of Margaret of Franklin? She handed the video over too easy, but she always does this even when she knows she's working against her daughter to do things. </li>
</ul>
<ul>
	<li>
		Franklin told Ginger that Margaret was a caretaker for her mom too, and I'm wondering how that'll pop up again. </li>
</ul>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/beautiful-matriarch-tall-filthy-rich-s1e1/"><div class="image_wrapper" style="padding-bottom:124.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--MSdireMG--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1600323271/beautiful-matriarch-tall-filthy-rich-s1e1.jpg" data-pin-description="Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6" data-pin-url="https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--gBy6Hhfv--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1600323271/beautiful-matriarch-tall-filthy-rich-s1e1.jpg" class="lazyload" alt="Beautiful Matriarch - Tall  - Filthy Rich Season 1 Episode 1"></div></a>
</div>
<ul>
	<li>
		Is there more going on between Yopi and Don? It seems as though Don could be working against the collective interest of the 18:20. He was unfazed by the potential collapse of Virgil's political career.</li>
</ul>
<ul>
	<li>
		Margaret tossing the toilet paper at the parade was funny as a throwback to Trump tossing out TP to hurricane victims, but also, folks were definitely looking for that during the early days of the pandemic, yes?</li>
</ul>
<p>
	Over to you, Filthy Rich Fanatics? What about that ending? There's so much to dicuss, please, hit the comments!</p>
<p>
	Don't forget, you can <a href="https://www.tvfanatic.com/shows/filthy-rich/full-episodes/">watch Filthy Rich online</a> here via TV Fanatic.</p>

<div class='widget'>
<h3>
<a href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/"><span>Proverbs 20:6</span></a>
Review
</h3>
<b>Editor Rating:</b>
4.5
/ 5.0
<ul class="star-rating"><li class="current-rating" style="width:90%;">4.5 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_34449'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li class="current-rating" style="width:0%;">0.0 / 5.0</li><li><a class="star star-1" data-method="post" data-remote="true" href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/vote/?rating%5Brating%5D=1" rel="nofollow">1</a></li> <li><a class="star star-2" data-method="post" data-remote="true" href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/vote/?rating%5Brating%5D=2" rel="nofollow">2</a></li> <li><a class="star star-3" data-method="post" data-remote="true" href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/vote/?rating%5Brating%5D=3" rel="nofollow">3</a></li> <li><a class="star star-4" data-method="post" data-remote="true" href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/vote/?rating%5Brating%5D=4" rel="nofollow">4</a></li> <li><a class="star star-5" data-method="post" data-remote="true" href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/vote/?rating%5Brating%5D=5" rel="nofollow">5</a></li></ul></div>
<br>
Unrated
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="15642"><button class="btn btn-primary" data-href="/admin/post/90000/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/90000/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Jasmine Blu</b> is a senior staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/bleuangel88">Twitter</a>.</p>
</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/' data-id='90000' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-90000' data-disqus-url='https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-90000";
  var disqus_url = "https://www.tvfanatic.com/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/";
  var disqus_title = "Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Filthy Rich Season 1 Episode 5 Review: Proverbs 20:6"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2020/10/watch-filthy-rich-online-season-1-episode-4/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/filthy-rich/" rel="tag">Filthy Rich</a>, <a href="/tags/reviews/" rel="tag">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/filthy-rich/episodes/proverbs-20-6/">Filthy Rich Season 1 Episode 5 Quotes</a></h4>
<blockquote>
<p> Eugene's world ain't ours, Franklin.</p>
<small>Young Margaret</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/eugenes-world-aint-ours-franklin/">Eugene&#39;s world ain&#39;t ours, Franklin.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-10-25">October 25, 2020</time></li>
</ul>
</blockquote>
<blockquote>
<p>Tina: I've never gone a day without talking to you.<br>Ginger: Be strong for me, and I'll be strong for you.</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/be-strong-for-me-and-ill-be-strong-for-you/">Be strong for me, and I&#39;ll be strong for you.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-10-25">October 25, 2020</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/filthy-rich/episodes/proverbs-20-6/">Filthy Rich Season 1 Episode 5 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/driving-a-ghost-tall-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Driving a Ghost - tall  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--h66Kr6s7--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676920/driving-a-ghost-tall-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/forbidden-love-tall-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Forbidden Love - Tall  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--mY-J0KAV--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676786/forbidden-love-tall-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/luke-and-ginger-tall-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Luke and Ginger - Tall  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--6y3Hi35G--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676558/luke-and-ginger-tall-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/investigative-board-tall-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Investigative Board - Tall  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--A0XTsiCi--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603676295/investigative-board-tall-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/antonio-in-the-middle-tall-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Antonio in the Middle - Tall  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--V3qfu13I--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675947/antonio-in-the-middle-tall-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/yopi-and-maggie-filthy-rich-s1e5/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Yopi and Maggie  - Filthy Rich Season 1 Episode 5" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--a8CMs2am--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603675835/yopi-and-maggie-filthy-rich-s1e5.jpg" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/filthy-rich/episodes/season-1/proverbs-20-6/","url":"https://www.tvfanatic.com/shows/filthy-rich/episodes/season-1/proverbs-20-6/","name":"Proverbs 20:6","episodeNumber":5,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/filthy-rich/episodes/season-1/","url":"https://www.tvfanatic.com/shows/filthy-rich/episodes/season-1/","seasonNumber":1},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/filthy-rich/","url":"https://www.tvfanatic.com/shows/filthy-rich/","name":"Filthy Rich"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2020-10-26","location":{"@type":"Country","name":"US"}},"description":"On Filthy Rich Season 1 Episode 5, Reverend Paul and Eric – much to Margaret's dismay – appear in a political commercial for the local Governor.","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/filthy-rich/full-episodes/season-1/proverbs-20-6/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2020-10-26T00:00","availabilityEnds":"2021-10-26T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--vf1knb6Q--/c_thumb,f_auto,g_auto,h_3683,q_auto,w_2455/v1603663189/pulled-into-a-debacle-filthy-rich","height":3683,"width":2455}}</script>
<h4>
<div class='clearfix'>
<time class="air" datetime="2020-10-26">10/26/20</time>
<div class='number'><a href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/">Filthy Rich Season 1 Episode 5</a></div>
</div>
<div class='title'>Proverbs 20:6</div>
</h4>
<img alt="Pulled Into a Debacle - Filthy Rich" src="https://tv-fanatic-res.cloudinary.com/iu/s--9f2oK4Ok--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1603663189/pulled-into-a-debacle-filthy-rich.jpg" />
<ul class='nav nav-pills'>
<li><a href="/2020/10/filthy-rich-season-1-episode-5-review-proverbs-20-6/">Review</a></li>
<li><a href="/quotes/shows/filthy-rich/episodes/proverbs-20-6/">Quotes</a></li>
<li><a href="/gallery/shows/filthy-rich/episodes/proverbs-20-6/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/filthy-rich/">Filthy Rich</a></li> <li><a href="/shows/filthy-rich/episodes/season-1/">Filthy Rich Season 1</a></li> <li><a href="/shows/filthy-rich/episodes/season-1/proverbs-20-6/">Filthy Rich Season 1 Episode 5</a></li> <li>Filthy Rich Review: Mardi Gras Madness</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/ted-lasso/">Ted Lasso</a></li>
<li><a href="/shows/lovecraft-country/">Lovecraft Country</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/the-100/">The 100</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/p-valley/">P-Valley</a></li>
<li><a href="/shows/the-haunting-of-hill-house/">The Haunting of Hill House</a></li>
<li><a href="/shows/star-trek-discovery/">Star Trek: Discovery</a></li>
<li><a href="/shows/yellowstone/">Yellowstone</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/what-we-do-in-the-shadows/">What We Do In The Shadows</a></li>
<li><a href="/shows/the-boys/">The Boys</a></li>
<li><a href="/shows/how-to-get-away-with-murder/">How to Get Away with Murder</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2020/10/">October 2020</a></li>
<li><a href="/2020/09/">September 2020</a></li>
<li><a href="/2020/08/">August 2020</a></li>
<li><a href="/2020/07/">July 2020</a></li>
<li><a href="/2020/06/">June 2020</a></li>
<li><a href="/2020/05/">May 2020</a></li>
<li><a href="/2020/04/">April 2020</a></li>
<li><a href="/2020/03/">March 2020</a></li>
<li><a href="/2020/02/">February 2020</a></li>
<li><a href="/2020/01/">January 2020</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
<li><a href="/2010/">2010 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2020 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2020 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
