<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/' property='og:url'>
<meta content='Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud' property='og:title'>
<meta content='The Drew Crew searched for the missing shroud on Nancy Drew Season 2 Episode 9 while the Bobbsey twins resurfaced to cause some trouble. Read on for our review!' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--JtWIOeji--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109313/nancy-and-amanda-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--XWLDp-KR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109756/bobbsey-twins-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--3kXpVTgV--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109738/trouble-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--75uxvBGl--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109530/amanda-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--7PZ2Iww9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109587/search-for-the-shroud-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--4BzRBAoD--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109637/george-and-nick-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--5HEotcLn--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109572/nick-and-george-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Ef8wGxNv--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109667/nancy-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--0vj5dEIR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109698/gil-bobbsey-nancy-drew-season-2-episode-9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='600' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='2021-03-24T23:24:49-04:00' property='article:published_time'>
<meta content='2021-03-24T23:23:53-04:00' property='article:modified_time'>
<meta content='Nancy Drew' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Sarah Little' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud' name='twitter:title'>
<meta content='The Drew Crew searched for the missing shroud on Nancy Drew Season 2 Episode 9 while the Bobbsey twins resurfaced to cause some trouble. Read on for our review!' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--JtWIOeji--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109313/nancy-and-amanda-nancy-drew-season-2-episode-9.jpg' name='twitter:image:src'>

<meta content="The Drew Crew searched for the missing shroud on Nancy Drew Season 2 Episode 9 while the Bobbsey twins resurfaced to cause some trouble...." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Nancy Drew');
ga('set', 'dimension2', 'Sarah Little');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "nancy-drew", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/","mainEntityOfPage":"https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/","headline":"Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud","datePublished":"2021-03-24T23:24:49-04:00","dateModified":"2021-03-24T23:23:53-04:00","description":"The Drew Crew searched for the missing shroud on Nancy Drew Season 2 Episode 9 while the Bobbsey twins resurfaced to cause some trouble. Read on for our review!","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--drkj3OJ3--/f_auto,q_auto/v1616109313/nancy-and-amanda-nancy-drew-season-2-episode-9","height":800,"width":1200},"author":{"@type":"Person","name":"Sarah Little"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2588' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Nancy Drew" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--8JChEJj1--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1568999236/banner/nancy-drew.jpg" /></div></div>
<div class='title'>
<h1><a href="/shows/nancy-drew/">Nancy Drew</a></h1>
<span class='airs'>
Wednesdays
 9:00 PM
on
The CW
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/nancy-drew/">Nancy Drew News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/nancy-drew/tags/reviews/">Nancy Drew Reviews</a></li>
<li><a class="" data-title="Watch Online" href="/shows/nancy-drew/full-episodes/">Nancy Drew Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/nancy-drew/episodes/">Nancy Drew Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/nancy-drew/">Nancy Drew Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/nancy-drew/">Nancy Drew Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Nancy Drew</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud</h1>
<small>
<a href="/authors/sarahlittle96/" rel="author"><img alt="Sarahlittle96" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--OE0V4MNV--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1569983872/user/sarahlittle96.jpg" />
<a href="/authors/sarahlittle96/" rel="author">Sarah Little</a>
</a>at
<time datetime="2021-03-24T23:24:49-04:00" itemprop="datePublished">March 24, 2021 11:24 pm</time>.
</small>
</header>
<div class='body'>
<p>
	Things are heating up, folks.</p>
<p>
	The Bobbsey twins returned on <a href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/">Nancy Drew Season 2 Episode 9</a>, and thanks to them, romance is in the air for a couple of members of the Drew Crew. But are these new couples built to last?</p>
<p>
	The backstory for Gil and Amanda weaved nicely into the mystery component of Nancy Drew, and it showed us why Nancy and Gil are being pushed together, as well as Ace and Amanda.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/bobbsey-twins-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--XWLDp-KR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109756/bobbsey-twins-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--EhyOrlFR--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109756/bobbsey-twins-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Bobbsey Twins - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	Gil and Amanda did not have it easy growing up thanks to their mother supposedly being murdered when they were six. But, in a shocking turn of events, their mother was never murdered. What is this show without a game-changing twist every episode?</p><div id="stp_target"></div>
<p>
	We can assume that Rosemary faked her own death to protect her children from a monster that was haunting her. And knowing Nancy Drew, we can also conclude that this monster is real.</p>
<p>
	All we know for certain, though, is that this story isn't over, and we are about to see a lot more of the Bobbsey family.</p>
<p>
	<blockquote>
<p>Nancy: Do you trust me?<br>George: Why? But also, yes.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/why-but-also-yes/">Why? But also, yes.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	I do hope that the mystery of their mother's disappearance somehow ties into the Drew Crew's ordeal with the supernatural spirits that Nancy released on <a href="https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/the-drowned-woman/">Nancy Drew Season 2 Episode 5</a>. Or with getting rid of Odette for good.</p>
<p>
	Overall, this episode was great for character building and the mystery of the week, but we were missing a tie-in to the overarching story of <a href="https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/">Nancy Drew Season 2</a>. Hopefully, they get back to it on Nancy Drew Season 2 Episode 10.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/trouble-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--3kXpVTgV--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109738/trouble-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--GsD953E0--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109738/trouble-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Trouble - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	Gil is somehow both the complete opposite of Nancy and the same person as her. I guess you could call them two sides of the same coin.</p>
<p>
	Now, whether that's a good or bad thing for their developing romance remains to be seen.</p>
<p>
	Gil does seem like the bad boy that Nancy can't help but feel drawn to, though. And we all know how that story ends.</p>
<p>
	<blockquote>
<p>Nick: So, this thing that could kill you, it was...it was just in your locker.<br>George: It was locked in my locker.<br>Nick: Right. Oh, okay. But not in a bank or a safe or somewhere that's actually-<br>George: Hey, Ace. Was anything else taken?<br></p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/hey-ace-was-anything-else-taken/">Hey, Ace. Was anything else taken?</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	But they do make for an intriguing team for the time being. Gil makes Nancy look like the most cautious person in Horseshoe Bay with his impatience and recklessness. In turn, she grounds him.</p>
<p>
	There's no doubt that Gil is a passionate guy as his emotions were all over the place during the hour. It will be interesting to see how a relationship between him and Nancy unfolds as the season continues.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/amanda-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--75uxvBGl--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109530/amanda-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--fQw_j_Og--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109530/amanda-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Amanda - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	The other new pairing is Ace and Amanda, who first flirted on <a href="https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/the-legend-of-the-murder-hotel/">Nancy Drew Season 2 Episode 7</a>.</p>
<p>
	We still don't know a lot about Amanda, other than the fact that she can talk her brother down from the ledge. But Ace appears to be infatuated with her.</p>
<p>
	They are both calm and collected individuals from what we have seen. Perhaps they are the same as Nancy and Gil, however -- similar, but opposite at the same time.</p>
<p>
	It's way too early on in these relationships to deem them epic romances, but there is a reason why they are being pushed together. And we think we can identify it.</p>
<p>
	At this point, it looks like the writers are building to the possibility of having a romance develop between Nancy and Ace in the future.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/search-for-the-shroud-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--7PZ2Iww9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109587/search-for-the-shroud-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--cNC5e3ar--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109587/search-for-the-shroud-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Search for the Shroud - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	The Nancy and Ace of it all has been subtly teased for some time now. Fans and critics have picked up on the telling signs, but things are now in full motion.</p>
<p>
	Their friendship is one of the best parts of the show, and the prospect of that turning into something more is very appealing.</p>
<p>
	Some of the best romances on television are the ones that start as a friendship. And Nancy and Ace have developed a relationship born of trust and reliability.</p>
<p>
	<blockquote>
<p>Art Gallery Worker: Restrooms are for clients only.<br>Nancy: Oh.<br>Ace: That's a shame cause we'd heard great things about your restrooms.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/thats-a-shame-cause-wed-heard-great-things-about-your-restrooms/">That's a shame cause we'd heard great things about your restrooms.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Like they said during their final scene on "The Bargain of the Blood Shroud," they know each other. And not just on a surface level. They understand one another deeply.</p>
<p>
	And that is most likely why a lot of fans are rooting for Nancy and Ace as a couple. They already have a strong friendship, so the thought that the writers might be pushing them together romantically is exciting.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/george-and-nick-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--4BzRBAoD--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109637/george-and-nick-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nsDT_aMf--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109637/george-and-nick-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="George and Nick - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	Not to be outdone by the new couples, the relationship between Nick and George took up a lot of time on the hour.</p>
<p>
	Nick is crazy in love with George. He acted like a madman when he showed up at the Bobbsey home and demanded Gil to give him the shroud.</p>
<p>
	And while George doesn't wear her heart on her sleeve as Nick does, we know that she feels the same way about him. They are sweet together and balance one another quite well.</p>
<p>
	<blockquote>
<p>Nick: We had a visit from Odette.<br>George: Oh, that bitch.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/oh-that-bitch/">Oh, that bitch.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	But Odette is not making it easy for the couple. She, too, was in love once. And all she wants to do is get back to her, even if that meant killing George.</p>
<p>
	Thankfully, Nick was able to appeal to the romantic side of Odette and get her to step off the ledge.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/nick-and-george-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--5HEotcLn--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109572/nick-and-george-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Re7ZvPbP--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109572/nick-and-george-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Nick and George - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	Odette is such a fun character to have around, and we can tell that Leah Lewis is having the best time playing her. But we do hope that she leaves George's body very soon.</p>
<p>
	George has had one too many near-death experiences in only two seasons of the show. Can't someone else get possessed for once?</p>
<p>
	As time goes on, we can see that Odette is not an evil person. We feel terrible about the things she has had to go through, but George doesn't deserve to be timesharing her body with an ancient Frenchwoman.</p>
<p>
	Hopefully, the Drew Crew finds a solution to this whole ordeal soon because it would be awful to see George on the brink of death for what feels like the hundredth time.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/nancy-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Ef8wGxNv--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109667/nancy-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--GHfTpL3J--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109667/nancy-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Nancy - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	Aside from the many romance subplots of the episode, Bess was struggling to accept her banishment from the Marvin family.</p>
<p>
	Who knew that Carson Drew, of all people, would be the one to make her feel better?</p>
<p>
	<blockquote>
<p>Amanda: You don't have siblings, do you?<br>Ace: That's, um, a question.</p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/thats-um-a-question/">That's, um, a question.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	All Bess needed was a little bit of distraction. And, surprisingly, Bess is quite good at editing Carson's speeches for law hearings. Could she be the next person from the Drew Crew that Carson hires?</p>
<p>
	There's no doubt that she could use something to redirect all her negative energy.</p>
<p>
	In any case, the pairing up of Carson and Bess just goes to show that Nancy Drew has created such wonderful, complex characters that each one of them fits together so well. This show knows how to display meaningful dynamics like no other series on television.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/gil-bobbsey-nancy-drew-season-2-episode-9/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--0vj5dEIR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109698/gil-bobbsey-nancy-drew-season-2-episode-9.jpg" data-pin-description="Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud" data-pin-url="https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--rvE0iXk9--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109698/gil-bobbsey-nancy-drew-season-2-episode-9.jpg" class="lazyload" alt="Gil Bobbsey - Nancy Drew Season 2 Episode 9"></div></a>
</div>
<p>
	What did you think, Nancy Drew Fanatics?</p>
<p>
	Are you excited to see more of the Bobbsey twins? Are you hoping for a romance between Nancy and Ace somewhere down the line? How bad do you want Odette gone?</p>
<p>
	And does anyone else think that Ace might just be a Hardy Boy after that last scene?</p>
<p>
	Let me know in the comments, and do not forget that you can <a href="/shows/nancy-drew/full-episodes/">watch Nancy Drew online</a> right here via TV Fanatic!</p>
<p>
	Nancy Drew airs Wednesdays at 9/8c on The CW.</p>

<div class='widget'>
<h3>
<a href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/"><span>The Bargain of the Blood Shroud</span></a>
Review
</h3>
<b>Editor Rating:</b>
4.3
/ 5.0
<ul class="star-rating"><li class="current-rating" style="width:86%;">4.3 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_35421'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li class="current-rating" style="width:100%;">5.0 / 5.0</li><li><a class="star star-1" data-method="post" data-remote="true" href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/vote/?rating%5Brating%5D=1" rel="nofollow">1</a></li> <li><a class="star star-2" data-method="post" data-remote="true" href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/vote/?rating%5Brating%5D=2" rel="nofollow">2</a></li> <li><a class="star star-3" data-method="post" data-remote="true" href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/vote/?rating%5Brating%5D=3" rel="nofollow">3</a></li> <li><a class="star star-4" data-method="post" data-remote="true" href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/vote/?rating%5Brating%5D=4" rel="nofollow">4</a></li> <li><a class="star star-5" data-method="post" data-remote="true" href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/vote/?rating%5Brating%5D=5" rel="nofollow">5</a></li></ul></div>
<br>
<span class='numeric_rating'>
Rating:
<span>5.0</span>
/ 5.0
</span>
<span class='total_votes'>
(<span>1</span> Vote)
</span>
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="260434"><button class="btn btn-primary" data-href="/admin/post/92385/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/92385/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Sarah Little</b> is a staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/SarahLittle96">Twitter</a>.</p></p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/' data-id='92385' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-92385' data-disqus-url='https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-92385";
  var disqus_url = "https://www.tvfanatic.com/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/";
  var disqus_title = "Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Nancy Drew Season 2 Episode 9 Review: The Bargain of the Blood Shroud"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2021/03/watch-nancy-drew-online-season-2-episode-8/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/nancy-drew/" rel="tag">Nancy Drew</a>, <a href="/tags/reviews/" rel="tag">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/nancy-drew/episodes/the-bargain-of-the-blood-shroud/">Nancy Drew Season 2 Episode 9 Quotes</a></h4>
<blockquote>
<p>Nick: So, this thing that could kill you, it was...it was just in your locker.<br>George: It was locked in my locker.<br>Nick: Right. Oh, okay. But not in a bank or a safe or somewhere that's actually-<br>George: Hey, Ace. Was anything else taken?<br></p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/hey-ace-was-anything-else-taken/">Hey, Ace. Was anything else taken?</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-03-24">March 24, 2021</time></li>
</ul>
</blockquote>
<blockquote>
<p>Nick: We had a visit from Odette.<br>George: Oh, that bitch.</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/oh-that-bitch/">Oh, that bitch.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-03-24">March 24, 2021</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/nancy-drew/episodes/the-bargain-of-the-blood-shroud/">Nancy Drew Season 2 Episode 9 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/bobbsey-twins-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Bobbsey Twins - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--S5RcoYDN--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109756/bobbsey-twins-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/trouble-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Trouble - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--cQtEV-lC--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109738/trouble-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/amanda-and-gil-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Amanda and Gil - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--PPD9teR9--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109719/amanda-and-gil-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/gil-bobbsey-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Gil Bobbsey - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--apmJwi3V--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109698/gil-bobbsey-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/gil-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Gil - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--DXxKmWWX--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109682/gil-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/nancy-nancy-drew-season-2-episode-9/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Nancy - Nancy Drew Season 2 Episode 9" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--xtqCPHH3--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109667/nancy-nancy-drew-season-2-episode-9.jpg" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/","url":"https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/","name":"The Bargain of the Blood Shroud","episodeNumber":9,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/","url":"https://www.tvfanatic.com/shows/nancy-drew/episodes/season-2/","seasonNumber":2},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/nancy-drew/","url":"https://www.tvfanatic.com/shows/nancy-drew/","name":"Nancy Drew"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2021-03-24","location":{"@type":"Country","name":"US"}},"description":"On Nancy Drew Season 2 Episode 9, Nancy and the Drew Crew strike a deal with Gil Bobbsey. Meanwhile, Carson runs into a distraught Bess.","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/nancy-drew/full-episodes/season-2/the-bargain-of-the-blood-shroud/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2021-03-24T00:00","availabilityEnds":"2022-03-24T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--K7V7iL9F--/c_thumb,f_auto,g_auto,h_800,q_auto,w_533/v1616109313/nancy-and-amanda-nancy-drew-season-2-episode-9","height":800,"width":533}}</script>
<h4>
<div class='clearfix'>
<time class="air" datetime="2021-03-24">3/24/21</time>
<div class='number'><a href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/">Nancy Drew Season 2 Episode 9</a></div>
</div>
<div class='title'>The Bargain of the Blood Shroud</div>
</h4>
<img alt="Nancy and Amanda - Nancy Drew Season 2 Episode 9" src="https://tv-fanatic-res.cloudinary.com/iu/s--l7oxhyVj--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1616109313/nancy-and-amanda-nancy-drew-season-2-episode-9.jpg" />
<ul class='nav nav-pills'>
<li><a href="/2021/03/nancy-drew-season-2-episode-9-review-the-bargain-of-the-blood-sh/">Review</a></li>
<li><a href="/quotes/shows/nancy-drew/episodes/the-bargain-of-the-blood-shroud/">Quotes</a></li>
<li><a href="/gallery/shows/nancy-drew/episodes/the-bargain-of-the-blood-shroud/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/nancy-drew/">Nancy Drew</a></li> <li><a href="/shows/nancy-drew/episodes/season-2/">Nancy Drew Season 2</a></li> <li><a href="/shows/nancy-drew/episodes/season-2/the-bargain-of-the-blood-shroud/">Nancy Drew Season 2 Episode 9</a></li> <li>Nancy Drew Review: The Bargain of the Blood Shroud</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/resident-alien/">Resident Alien</a></li>
<li><a href="/shows/ted-lasso/">Ted Lasso</a></li>
<li><a href="/shows/new-amsterdam/">New Amsterdam</a></li>
<li><a href="/shows/good-girls/">Good Girls</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/ncis/">NCIS</a></li>
<li><a href="/shows/9-1-1/">9-1-1</a></li>
<li><a href="/shows/superstore/">Superstore</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
<li><a href="/shows/station-19/">Station 19</a></li>
<li><a href="/shows/the-walking-dead/">The Walking Dead</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/the-vampire-diaries/">The Vampire Diaries</a></li>
<li><a href="/shows/yellowstone/">Yellowstone</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2021/03/">March 2021</a></li>
<li><a href="/2021/02/">February 2021</a></li>
<li><a href="/2021/01/">January 2021</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2021 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2021 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
