<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Dynasty Season Finale Spoilers: Fallon vs. Eva! - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/' property='og:url'>
<meta content='Dynasty Season Finale Spoilers: Fallon vs. Eva!' property='og:title'>
<meta content='Dynasty Season 4 Episode 22 will conclude the current season of the soapy drama, and we should prepare for a lot of drama. Get all the details.' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--1qN8w7wd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632920260/fallon-and-amanda-dynasty.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='371' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--7_02YIhQ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561184/blake-asks-for-help-dynasty-s4e21.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='744' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Y00NuMoo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631955369/fallon-apologizes-dynasty-s4e19.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='737' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--M73GUMcX--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265829/amanda-hits-back-dynasty-s4e18.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='725' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--iLiYO7F1--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265653/adam-sulks-dynasty-s4e18.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='941' property='og:image:height'>
<meta content='2021-09-29T10:00:00-04:00' property='article:published_time'>
<meta content='2021-09-29T09:00:09-04:00' property='article:modified_time'>
<meta content='Dynasty' property='article:tag'>
<meta content='Promos' property='article:tag'>
<meta content='Spoilers' property='article:tag'>
<meta content='The CW' property='article:tag'>
<meta content='Paul Dailly' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Dynasty Season Finale Spoilers: Fallon vs. Eva!' name='twitter:title'>
<meta content='Dynasty Season 4 Episode 22 will conclude the current season of the soapy drama, and we should prepare for a lot of drama. Get all the details.' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--1qN8w7wd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632920260/fallon-and-amanda-dynasty.png' name='twitter:image:src'>

<meta content="Dynasty Season 4 Episode 22 will conclude the current season of the soapy drama, and we should prepare for a lot of drama. Get all the..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Dynasty');
ga('set', 'dimension2', 'Paul Dailly');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "dynasty", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/","mainEntityOfPage":"https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/","headline":"Dynasty Season Finale Spoilers: Fallon vs. Eva!","datePublished":"2021-09-29T10:00:00-04:00","dateModified":"2021-09-29T09:00:09-04:00","description":"Dynasty Season 4 Episode 22 will conclude the current season of the soapy drama, and we should prepare for a lot of drama. Get all the details.","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--b9O1QAb8--/f_auto,q_auto/v1632920260/fallon-and-amanda-dynasty","height":1298,"width":2202},"author":{"@type":"Person","name":"Paul Dailly"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2178' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Dynasty" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Mg4KFiU7--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1618266387/banner/dynasty.png" /></div></div>
<div class='title'>
<h1><a href="/shows/dynasty/">Dynasty</a></h1>
<span class='airs'>
Fridays
 9:00 PM
on
The CW
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/dynasty/">Dynasty News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/dynasty/tags/reviews/">Dynasty Reviews</a></li>
<li><a class="" data-title="Spoilers" href="/shows/dynasty/tags/spoilers/">Dynasty Spoilers</a></li>
<li><a class="" data-title="Watch Online" href="/shows/dynasty/full-episodes/">Dynasty Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/dynasty/episodes/">Dynasty Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/dynasty/">Dynasty Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/dynasty/">Dynasty Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Dynasty</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Dynasty Season Finale Spoilers: Fallon vs. Eva!</h1>
<small>
<a href="/authors/pauldailly92/" rel="author"><img alt="Pauldailly92" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--jzYlH3ci--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1437338558/user/pauldailly92.jpg" />
<a href="/authors/pauldailly92/" rel="author">Paul Dailly</a>
</a>at
<time datetime="2021-09-29T10:00:00-04:00" itemprop="datePublished">September 29, 2021 10:00 am</time>.
</small>
</header>
<div class='body'>
<p>
	Are you ready to say goodbye to the Carringtons?</p>
<p>
	<a href="https://www.tvfanatic.com/2021/09/dynasty-review-here-comes-the-scheming-bride/">Dynasty Season 4 Episode 22</a> will conclude the current season of the soapy drama, and it's going to be a lot of fun.</p>
<p>
	"Blake (Grant Show) and Cristal (Daniella Alonso) work together on the new obstacles threatening Blake's senatorial campaign," reads the official logline from the network. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/fallon-and-amanda-dynasty/"><div class="image_wrapper" style="padding-bottom:58.84615384615385%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--1qN8w7wd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632920260/fallon-and-amanda-dynasty.png" data-pin-description="Dynasty Season Finale Spoilers: Fallon vs. Eva!" data-pin-url="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--9ecCYxkD--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632920260/fallon-and-amanda-dynasty.png" class="lazyload" alt="Fallon and Amanda - Dynasty"></div></a>
</div>
<p>
	If you watch Dynasty online, you know the series has laned heavily on Blake's pursuit of power on a political front.</p><div id="stp_target"></div>
<p>
	With the season finale upon us, we can expect some wild developments on the back of it.</p>
<p>
	We'll probably also get a throwback to a moment from the past for good measure.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/blake-asks-for-help-dynasty-s4e21/"><div class="image_wrapper" style="padding-bottom:118.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--7_02YIhQ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561184/blake-asks-for-help-dynasty-s4e21.png" data-pin-description="Dynasty Season Finale Spoilers: Fallon vs. Eva!" data-pin-url="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--MVz8iv3o--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561184/blake-asks-for-help-dynasty-s4e21.png" class="lazyload" alt="Blake Asks for Help - Dynasty Season 4 Episode 21"></div></a>
</div>
<p>
	But, what will happen between Fallon, Liam, and Eva?</p>
<p>
	"Fallon (Elizabeth Gillies) turns to Amanda (guest star Eliza Bennett) for help regarding Liam (Adam Huber) and their marriage."</p>
<p>
	We know Eva is ready to change everything for Liam and Fallon, thanks to her manipulation.</p>
<p>
	Liam officially called time on their marriage on Dynasty Season 4 Episode 21, and it looks like Fallon will have her work cut out for her if she wants to get her man back.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/fallon-apologizes-dynasty-s4e19/"><div class="image_wrapper" style="padding-bottom:117.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Y00NuMoo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631955369/fallon-apologizes-dynasty-s4e19.png" data-pin-description="Dynasty Season Finale Spoilers: Fallon vs. Eva!" data-pin-url="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--a0-zBVpj--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631955369/fallon-apologizes-dynasty-s4e19.png" class="lazyload" alt="Fallon Apologizes - Dynasty Season 4 Episode 19"></div></a>
</div>
<p>
	It's nice to see Fallon turning to her sister because, despite a rocky beginning, they've carved out quite the relationship so far.</p>
<p>
	It's hard to imagine Eva being unmasked early into the finale, so we should probably expect much of this plot to carry forward to Dynasty Season 5.</p>
<p>
	"Sam (Rafael de la Fuente), Culhane (Robert C. Riley) and Kirby (Maddison Brown) work on the finishing touches for the opening of The Sahara Club, as Sam gets advice from an unexpected source," the logline adds.</p>
<p>
	"Alexis (Elaine Hendrix) continues her scheming as Dominique (Michael Michele) worries about Jeff's (Sam Adegoke) health.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/amanda-hits-back-dynasty-s4e18/"><div class="image_wrapper" style="padding-bottom:114.99999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--M73GUMcX--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265829/amanda-hits-back-dynasty-s4e18.png" data-pin-description="Dynasty Season Finale Spoilers: Fallon vs. Eva!" data-pin-url="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--uApPzXLf--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265829/amanda-hits-back-dynasty-s4e18.png" class="lazyload" alt="Amanda Hits Back - Dynasty Season 4 Episode 18"></div></a>
</div>
<p>
	Alexis has been randomly pursuing Dominique of late, and it's been bizarre.</p>
<p>
	Jeff's been pressing on with his plans to reach space, but he hasn't been taking his medication and has been going off the rails.</p>
<p>
	Will he reach space in the finale?</p>
<p>
	"Adam (Sam Underwood) finds himself in yet another precarious position," the logline concludes.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/adam-sulks-dynasty-s4e18/"><div class="image_wrapper" style="padding-bottom:149.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--iLiYO7F1--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265653/adam-sulks-dynasty-s4e18.png" data-pin-description="Dynasty Season Finale Spoilers: Fallon vs. Eva!" data-pin-url="https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--IhEDAgJd--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1631265653/adam-sulks-dynasty-s4e18.png" class="lazyload" alt="Adam Sulks - Dynasty Season 4 Episode 18"></div></a>
</div>
<p>
	Adam has found himself in a lot of wild situations throughout the run of the show, but hopefully, he will finally face the consequences for his actions.</p>
<p>
	Maybe we'll finally get some intel on what happened to Steven. That would be fun, right?</p>
<p>
	What are your thoughts on all of the drama on the way?</p>
<p>
	Hit the comments below.</p>
<p>
	<strong>Catch the Dynasty season finale Friday, October 1, on The CW. </strong></p>
<p style="text-align: center;">
	<iframe allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/uvZbQVHhxLQ" title="YouTube video player" width="560"></iframe></p>


<div class="buttons admin edit_object_links" data-user-id="66541"><button class="btn btn-primary" data-href="/admin/post/95428/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/95428/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Paul Dailly</b> is the Associate Editor for TV Fanatic. Follow him on <a href="http://twitter.com/pauldailly1992">Twitter</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/' data-id='95428' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-95428' data-disqus-url='https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-95428";
  var disqus_url = "https://www.tvfanatic.com/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/";
  var disqus_title = "Dynasty Season Finale Spoilers: Fallon vs. Eva!";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Dynasty Season Finale Spoilers: Fallon vs. Eva!"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2021/09/watch-dynasty-online-season-4-episode-20/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/dynasty/" rel="tag">Dynasty</a>, <a href="/tags/promos/" rel="tag">Promos</a>, <a href="/tags/spoilers/" rel="tag">Spoilers</a>, <a href="/networks/cw/" rel="tag">The CW</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/dynasty/">Dynasty Quotes</a></h4>
<blockquote>
<p>Steven: Quick question: is there a cactus where your heart should be?</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/is-there-a-cactus-where-your-heart-should-be/">is there a cactus where your heart should be?</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2017-10-18">October 18, 2017</time></li>
</ul>
</blockquote>
<blockquote>
<p> Everyday, I take one mans dirt and turn it into diamonds. And digging up insider info is even easier when they assume I work for the airline, instead of owning the plane. </p>
<small>Fallon</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/everyday-i-take-one-mans-dirt-and-turn-it-into-diamonds-and-digg/">Everyday, I take one mans dirt and turn it into diamonds. And digging up insider info is even...</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2017-10-11">October 11, 2017</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/shows/dynasty/">Dynasty</a></h4>
<ul class='nav'>
<li>
<a class="clearfix" href="/2021/09/dynasty-season-finale-spoilers-fallon-vs-eva/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Dynasty Season Finale Spoilers: Fallon vs. Eva!" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--xq_xJGik--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1632920260/fallon-and-amanda-dynasty" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--bkZMSbXi--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1632920260/fallon-and-amanda-dynasty 31w, https://tv-fanatic-res.cloudinary.com/iu/s--eGTNQnS6--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1632920260/fallon-and-amanda-dynasty 62w, https://tv-fanatic-res.cloudinary.com/iu/s--Wc6es0Bt--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1632920260/fallon-and-amanda-dynasty 93w, https://tv-fanatic-res.cloudinary.com/iu/s--xq_xJGik--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1632920260/fallon-and-amanda-dynasty 125w, https://tv-fanatic-res.cloudinary.com/iu/s--AfLXW-bP--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1632920260/fallon-and-amanda-dynasty 187w, https://tv-fanatic-res.cloudinary.com/iu/s--v7xtyFW1--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1632920260/fallon-and-amanda-dynasty 250w, https://tv-fanatic-res.cloudinary.com/iu/s--lU6pPSaA--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1632920260/fallon-and-amanda-dynasty 312w, https://tv-fanatic-res.cloudinary.com/iu/s--xxIXJpRe--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1632920260/fallon-and-amanda-dynasty 375w" /></div></div>
</div>
Dynasty Season Finale Spoilers: Fallon vs. Eva!
</a></li>
<li>
<a class="clearfix" href="/2021/09/watch-dynasty-online-season-4-episode-20/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Watch Dynasty Online: Season 4 Episode 20" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ZJBJmlGg--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1631955358/happy-liam-dynasty-s4e19" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--nc68tTIj--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1631955358/happy-liam-dynasty-s4e19 31w, https://tv-fanatic-res.cloudinary.com/iu/s--2D5WdFp4--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1631955358/happy-liam-dynasty-s4e19 62w, https://tv-fanatic-res.cloudinary.com/iu/s--R_fMCuzA--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1631955358/happy-liam-dynasty-s4e19 93w, https://tv-fanatic-res.cloudinary.com/iu/s--ZJBJmlGg--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1631955358/happy-liam-dynasty-s4e19 125w, https://tv-fanatic-res.cloudinary.com/iu/s--9C2-95QC--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1631955358/happy-liam-dynasty-s4e19 187w, https://tv-fanatic-res.cloudinary.com/iu/s--ALHlTB7r--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1631955358/happy-liam-dynasty-s4e19 250w, https://tv-fanatic-res.cloudinary.com/iu/s--fKBrUvZZ--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1631955358/happy-liam-dynasty-s4e19 312w, https://tv-fanatic-res.cloudinary.com/iu/s--oS-rYoBL--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1631955358/happy-liam-dynasty-s4e19 375w" /></div></div>
</div>
Watch Dynasty Online: Season 4 Episode 20
</a></li>
<li>
<a class="clearfix" href="/2021/09/dynasty-review-here-comes-the-scheming-bride/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Dynasty Review: Here Comes the Scheming Bride!" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--g83lL1Dp--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1632499600/a-trip-dynasty" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--FZkYIkXP--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1632499600/a-trip-dynasty 31w, https://tv-fanatic-res.cloudinary.com/iu/s--JGprDZqM--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1632499600/a-trip-dynasty 62w, https://tv-fanatic-res.cloudinary.com/iu/s--7ilgYKPs--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1632499600/a-trip-dynasty 93w, https://tv-fanatic-res.cloudinary.com/iu/s--g83lL1Dp--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1632499600/a-trip-dynasty 125w, https://tv-fanatic-res.cloudinary.com/iu/s--o_6ERWTf--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1632499600/a-trip-dynasty 187w, https://tv-fanatic-res.cloudinary.com/iu/s--F-THPktM--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1632499600/a-trip-dynasty 250w, https://tv-fanatic-res.cloudinary.com/iu/s--MKBTt94L--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1632499600/a-trip-dynasty 312w, https://tv-fanatic-res.cloudinary.com/iu/s---ITclwUF--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1632499600/a-trip-dynasty 375w" /></div></div>
</div>
Dynasty Review: Here Comes the Scheming Bride!
</a></li>
</ul>

</div>
</div>
</div>
<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/dynasty/">Dynasty Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/fallon-and-amanda-dynasty/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Fallon and Amanda - Dynasty" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--a6nTA4WM--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632920260/fallon-and-amanda-dynasty.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/a-scheming-alexis-dynasty/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="A Scheming Alexis - Dynasty" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--YyRjinqB--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632705586/a-scheming-alexis-dynasty.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/blake-on-the-microphones-dynasty-s4e21/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Blake on the Microphones - Dynasty Season 4 Episode 21" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--uiljfHVZ--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561203/blake-on-the-microphones-dynasty-s4e21.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/blake-asks-for-help-dynasty-s4e21/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Blake Asks for Help - Dynasty Season 4 Episode 21" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--R2xchOTh--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561184/blake-asks-for-help-dynasty-s4e21.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/sam-needs-help-dynasty-s4e21/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Sam Needs Help - Dynasty Season 4 Episode 21" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1YHo9-s9--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561169/sam-needs-help-dynasty-s4e21.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/cristals-answers-dynasty-s4e21/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Cristal&#39;s Answers - Dynasty Season 4 Episode 21" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--_YCLlho9--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1632561156/cristals-answers-dynasty-s4e21.png" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/">Shows</a></li> <li><a href="/shows/dynasty/">Dynasty</a></li> <li>Dynasty Season Finale Spoilers: Fallon vs. Eva!</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/ted-lasso/">Ted Lasso</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/power-book-iii-raising-kanan/">Power Book III: Raising Kanan</a></li>
<li><a href="/shows/9-1-1/">9-1-1</a></li>
<li><a href="/shows/only-murders-in-the-building/">Only Murders In the Building</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/nine-perfect-strangers/">Nine Perfect Strangers</a></li>
<li><a href="/shows/good-girls/">Good Girls</a></li>
<li><a href="/shows/succession/">Succession</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/the-league/">The League</a></li>
<li><a href="/shows/power/">Power</a></li>
<li><a href="/shows/the-resident/">The Resident</a></li>
<li><a href="/shows/the-rookie/">The Rookie</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2021/09/">September 2021</a></li>
<li><a href="/2021/08/">August 2021</a></li>
<li><a href="/2021/07/">July 2021</a></li>
<li><a href="/2021/06/">June 2021</a></li>
<li><a href="/2021/05/">May 2021</a></li>
<li><a href="/2021/04/">April 2021</a></li>
<li><a href="/2021/03/">March 2021</a></li>
<li><a href="/2021/02/">February 2021</a></li>
<li><a href="/2021/01/">January 2021</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2021 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2021 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
