<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>A Million Little Things Season 4 Episode 19 Review: Out of Hiding - TV Fanatic</title>
<link rel="shortcut icon" type="image/x-icon" href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" />
<link rel="canonical" href="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" />

<link rel="alternate" type="application/atom+xml" title="TV Fanatic Feed" href="https://www.tvfanatic.com/rss.xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/' property='og:url'>
<meta content='A Million Little Things Season 4 Episode 19 Review: Out of Hiding' property='og:title'>
<meta content="Our review of A Million Little Things Season 4 Episode 19 discusses Maggie and Gary's single hope and another shocker about the night Peter died. Check it out! " property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--bE3FC2_N--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331288/baby-making-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--YseDI0FD--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331469/two-parents-one-embryo-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='788' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--LVBXXYey--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1649131951/parent-trap-a-million-little-things-s4e14.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='788' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--4zix0vLO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1648097377/tyrell-offers-support-tall-a-million-little-things-s4e13.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='901' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--TaF_ZnKS--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725037/shanice-steps-out-a-million-little-things-s4e18.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='943' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--0WXAyM25--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645252193/greta-a-million-little-things-s4e9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='945' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--PO3KfD2g--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645251966/new-paths-a-million-little-things-s4e9.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='787' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--6htZaaBI--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331724/standing-by-maddox-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='788' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--TG2rZBMm--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332111/maddoxs-parents-tall-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='733' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--emS6-2BA--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332192/nervous-for-the-future-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='945' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--hkekDZhg--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332257/needing-mom-tall-a-million-little-things-s4e19.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='759' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Ea07lbXi--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1638394806/eddies-fresh-start-tall-a-million-little-things-s4e8.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='770' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ZyC1pNec--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646261051/anna-meets-the-friends-tall-a-million-little-things-s4e10.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='789' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Mn-xH5nl--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725425/tyes-agenda-a-million-little-things-s4e18.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='787' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--yJT_37jj--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651087437/annas-lie-tall-a-million-little-things-s4e17.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='769' property='og:image:height'>
<meta content='2022-05-12T01:15:19-04:00' property='article:published_time'>
<meta content='2022-05-12T01:19:17-04:00' property='article:modified_time'>
<meta content='A Million Little Things' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Jasmine Blu' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='A Million Little Things Season 4 Episode 19 Review: Out of Hiding' name='twitter:title'>
<meta content="Our review of A Million Little Things Season 4 Episode 19 discusses Maggie and Gary's single hope and another shocker about the night Peter died. Check it out! " name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--bE3FC2_N--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331288/baby-making-a-million-little-things-s4e19.jpg' name='twitter:image:src'>

<meta name="description" content="Our review of A Million Little Things Season 4 Episode 19 discusses Maggie and Gary&#39;s single hope and another shocker about the night..."></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'A Million Little Things');
ga('set', 'dimension2', 'Jasmine Blu');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link rel="stylesheet" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" as="style" />
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" as="style" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "a-million-little-things", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/","mainEntityOfPage":"https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/","headline":"A Million Little Things Season 4 Episode 19 Review: Out of Hiding","datePublished":"2022-05-12T01:15:19-04:00","dateModified":"2022-05-12T01:19:17-04:00","description":"Our review of A Million Little Things Season 4 Episode 19 discusses Maggie and Gary's single hope and another shocker about the night Peter died. Check it out! ","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--ICE7woFs--/f_auto,q_auto/v1652331288/baby-making-a-million-little-things-s4e19","height":2002,"width":3000},"author":{"@type":"Person","url":"https://www.tvfanatic.com/authors/blu/","name":"Jasmine Blu"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input type="search" name="q" id="q" placeholder="Search" class="form-control" />
<div class='input-group-btn'><button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2430' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="A Million Little Things" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--vDyfd_4y--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1537247391/banner/a-million-little-things.jpg" class="lazyload" /></div></div>
<div class='title'>
<h1><a href="/shows/a-million-little-things/">A Million Little Things</a></h1>
<span class='airs'>
Wednesdays
10:00 PM
on
ABC
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/a-million-little-things/">A Million Little Things News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/a-million-little-things/tags/reviews/">A Million Little Things Reviews</a></li>
<li><a class="" data-title="Spoilers" href="/shows/a-million-little-things/tags/spoilers/">A Million Little Things Spoilers</a></li>
<li><a class="" data-title="Watch Online" href="/shows/a-million-little-things/full-episodes/">A Million Little Things Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/a-million-little-things/episodes/">A Million Little Things Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/a-million-little-things/">A Million Little Things Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/a-million-little-things/">A Million Little Things Pictures</a></li>
<li><a class="" data-title="Videos" href="/videos/shows/a-million-little-things/">A Million Little Things Videos</a></li>
<li><a class="" data-title="Round Tables" href="/shows/a-million-little-things/tags/round-tables/">A Million Little Things Round Tables</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow A Million Little Things</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>A Million Little Things Season 4 Episode 19 Review: Out of Hiding</h1>
<small>
<a rel="author" href="/authors/blu/"><img class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--IhuDiizY--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1379964334/user/blu.png" alt="Blu" />
<a rel="author" href="/authors/blu/">Jasmine Blu</a>
</a>at
<time datetime="2022-05-12T01:15:19-04:00" itemprop="datePublished">May 12, 2022  1:15 am</time>.
</small>
</header>
<div class='body'>
<p>
	They dropped a couple of bombs on us during this penultimate episode.</p>
<p>
	By the end of <a href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/">A Million Little Things Season 4 Episode 19</a>, Maggie and Gary only had a single shot of having a baby with one viable embryo. Rome's tenure as a teacher may have ended thanks to his high school bully, and Katherine and Greta possibly went up in flames.</p>
<p>
	But more importantly, Anna may have really killed Peter, or maybe Kai did; what is the truth?</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/two-parents-one-embryo-a-million-little-things-s4e19/"><div class="image_wrapper" style="padding-bottom:125.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--YseDI0FD--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331469/two-parents-one-embryo-a-million-little-things-s4e19.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--PlPDcDPM--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331469/two-parents-one-embryo-a-million-little-things-s4e19.jpg" class="lazyload" alt="Two Parents, One Embryo  - A Million Little Things Season 4 Episode 19"></div></a>
</div>
<p>
	As far as storylines go, the most mediocre of the bunch was the situation with Tyrell, Vali, and Gina.</p><div id="stp_target"></div>
<p>
	The Howards are adorable, aren't they? One of the funniest moments was when the two commiserated over their mutual distaste for Tyrell's relationship with Vali.</p>
<p>
	<blockquote>
<p> Maybe we both just need some space to figure out what's best for us.</p>
<small>Greta</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/maybe-we-both-just-need-some-space-to-figure-out-whats-best-for/">Maybe we both just need some space to figure out what's best for us.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	If you've ever watched a loved one become a totally different person while with someone, or you aren't the biggest fan of the person they are with, the Howards couldn't have been more relatable.</p>
<p>
	Tyrell and Vali have only been dating for five minutes, and this relationship has already disrupted things and caused drama. It was bad enough when they had sex in the house when they thought Gina wasn't home.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/parent-trap-a-million-little-things-s4e14/"><div class="image_wrapper" style="padding-bottom:125.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--LVBXXYey--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1649131951/parent-trap-a-million-little-things-s4e14.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Tsz1fDtQ--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1649131951/parent-trap-a-million-little-things-s4e14.jpg" class="lazyload" alt="Parent Trap - A Million Little Things Season 4 Episode 14"></div></a>
</div>
<p>
	But now Tyrell, the same teen who was just stressing out about not getting into his top pick for college, blew off his orientation at Yale. YALE!</p>
<p>
	And we can only surmise that it's because Vali tickled his happy stick, and now he's hopelessly, recklessly, and stupidly in love. Why are teenagers like this?</p>
<p>
	He worked so hard to achieve this, and now he's throwing it away because he's probably too afraid to leave Vali behind.</p>
<p>
	And it's already troubling that Vali has such a hold on him. Tyrell bolted the second Gina wanted to talk about him blowing off Yale. But Vali had the audacity to give her input and tell Gina about herself as if anyone asked for her freaking opinion.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tyrell-offers-support-tall-a-million-little-things-s4e13/"><div class="image_wrapper" style="padding-bottom:143.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--4zix0vLO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1648097377/tyrell-offers-support-tall-a-million-little-things-s4e13.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--3RAt9PgK--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1648097377/tyrell-offers-support-tall-a-million-little-things-s4e13.jpg" class="lazyload" alt="Tyrell Offers Support -tall  - A Million Little Things Season 4 Episode 13"></div></a>
</div>
<p>
	We don't talk to Regina Howard that way; we just don't!</p>
<p>
	Vali is driving a wedge between Tyrell and the Howards, and it's not pretty. For the most part, they didn't have any issues with Tyrell, but they're about to get a taste of what it's like when you're raising a teenager, and they go against your wishes.</p>
<p>
	And it'll get even messier when Val is factored into all of this.</p>
<p>
	Katherine's relationships were no less complicated, and it's as if neither she nor Eddie can ever be happy for too long. There are about half a dozen others, if that isn't an argument for why they should reunite.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/shanice-steps-out-a-million-little-things-s4e18/"><div class="image_wrapper" style="padding-bottom:149.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--TaF_ZnKS--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725037/shanice-steps-out-a-million-little-things-s4e18.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--TOvfijOp--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725037/shanice-steps-out-a-million-little-things-s4e18.jpg" class="lazyload" alt="Shanice Steps Out  - A Million Little Things Season 4 Episode 18"></div></a>
</div>
<p>
	Shanice entering the picture only made some things they hadn't addressed come to the surface. Perhaps, it was only a matter of time before the blissful teen romance phase of Katherine and Greta's relationship dissipated and things got real.</p>
<p>
	Some parts of the situation were complex because it wasn't Katherine's place to out Shanice to Greta for the sake of their relationship. But Katherine should've been upfront with Shanice about having a girlfriend.</p>
<p>
	Greta seemed conflicted by some of what happened, and Katherine was probably a bit too honest about the whole ordeal, making it worse.</p>
<p>
	Sadly, there's some merit to what Greta was saying, though. It probably was too much for her to start dating someone when she's in the middle of a divorce. And it's apparent that there's still something there between her and her wife.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/greta-a-million-little-things-s4e9/"><div class="image_wrapper" style="padding-bottom:150.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--0WXAyM25--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645252193/greta-a-million-little-things-s4e9.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--kY35dWnA--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645252193/greta-a-million-little-things-s4e9.jpg" class="lazyload" alt="Greta  - A Million Little Things Season 4 Episode 9"></div></a>
</div>
<p>
	And Katherine probably should have dated more and explored herself and her options further rather than jumping into another full-fledged relationship after her divorce.</p>
<p>
	Ironically, when Shanice left the first time, she advised Katherine to do the same thing Greta suggested, explore her sexuality and date more.</p>
<p>
	Carter offered up the same and drove Katherine back to Shanice, but she's in love with Greta, and that's who she wants.</p>
<p>
	It seemed like she was imposing on a special bond and moment when she showed up, and Greta was with her ex after their cat died. It wouldn't be that surprising if Greta rekindled things with the woman.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/new-paths-a-million-little-things-s4e9/"><div class="image_wrapper" style="padding-bottom:125.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--PO3KfD2g--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645251966/new-paths-a-million-little-things-s4e9.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--8jtszCUL--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645251966/new-paths-a-million-little-things-s4e9.jpg" class="lazyload" alt="New Paths  - A Million Little Things Season 4 Episode 9"></div></a>
</div>
<p>
	And now it's awkward because Theo is wondering where Greta is, and it serves as a reminder of how fast they went with their relationship. It was too soon for Greta to move in, even temporarily.</p>
<p>
	But is it wrong if I'm still holding out that Katherine and Eddie will just find their way back to one another?</p>
<p>
	<blockquote>
<p> Look, I know I'm not your favorite person, but I love her, and I miss her, and I want to find her so I can tell her that. </p>
<small>Katherine</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/look-i-know-im-not-your-favorite-person-but-i-love-her-and-i-mis/">Look, I know I'm not your favorite person, but I love her, and I miss her, and I want to find...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	When will we get justice for Maddox or Rome? It better be swift!</p>
<p>
	Rome was put in a no-win situation when Maddox asked him to speak to his parents. No way on earth was Rome going to go into that meeting and misgender Maddox when he recognizes the young teen for who and what he is.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/standing-by-maddox-a-million-little-things-s4e19/"><div class="image_wrapper" style="padding-bottom:125.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--6htZaaBI--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331724/standing-by-maddox-a-million-little-things-s4e19.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--BKiXr_1T--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331724/standing-by-maddox-a-million-little-things-s4e19.jpg" class="lazyload" alt="Standing By Maddox  - A Million Little Things Season 4 Episode 19"></div></a>
</div>
<p>
	But it also meant that he risked the ire of Maddox's parents every time he respected Maddox by not using Madison or she/her pronouns.</p>
<p>
	And by stating that his class was a safe space where Maddox could be Maddox even if he weren't allowed to be at home, he gave the parents the ammunition to remove him from the equation so they could stay in denial and write this off as another "phase."</p>
<p>
	The real shocker was learning that Maddox's father was also Rome's high school bully, the kid who played a racist prank on him and taunted him.</p>
<p>
	Ironically, Clark's apology when he sat down with Rome felt genuine, and perhaps it was. However, that moment of contrition over his racism was short-lived, when the power move born out of his transphobia was getting Rome fired or pulling all the funding and donations from the school.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/maddoxs-parents-tall-a-million-little-things-s4e19/"><div class="image_wrapper" style="padding-bottom:116.25000000000001%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--TG2rZBMm--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332111/maddoxs-parents-tall-a-million-little-things-s4e19.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--EsSLAspd--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332111/maddoxs-parents-tall-a-million-little-things-s4e19.jpg" class="lazyload" alt="Maddox's Parents -tall  - A Million Little Things Season 4 Episode 19"></div></a>
</div>
<p>
	Maggie and Gary's journey toward parenthood hasn't been easy, but they leave us with glimmers of hope despite every bump in the road.</p>
<p>
	While Gary took a backseat for most of the hour, suffering from a stomach bug, it meant that Maggie and Patricia could bond further, and their scenes were effective.</p>
<p>
	Maggie put up a front and tried to act as if she wasn't nervous or scared, but all of this was happening quickly, and there were so many unknowns.</p>
<p>
	It's scary to think about what'll happen if they have kids if they don't, if something will happen to them or their child. The whole process is nerve-wracking.</p>
<div style="max-width:399px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/nervous-for-the-future-a-million-little-things-s4e19/"><div class="image_wrapper" style="padding-bottom:150.37593984962405%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--emS6-2BA--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332192/nervous-for-the-future-a-million-little-things-s4e19.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--57owS2lw--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332192/nervous-for-the-future-a-million-little-things-s4e19.jpg" class="lazyload" alt="Nervous for the Future  - A Million Little Things Season 4 Episode 19"></div></a>
</div>
<p>
	And Maggie was showing signs of doubt that she'd be a good mom, but Patricia was there to tell her that there was no parent handbook.</p>
<p>
	Despite their many issues, she loves Maggie and always has, and Maggie turned out okay. Maggie would be a great mom.</p>
<p>
	<blockquote>
<p> I've never not needed you, mom, and I really need you now. I'm not scared. I'm terrified. What if something goes wrong and they can't get any eggs. What if they do? I don't know if I'm going to be a good mom.</p>
<small>Maggie</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/ive-never-not-needed-you-mom-and-i-really-need-you-now-im-not-sc/">I've never not needed you, mom, and I really need you now. I'm not scared. I'm terrified....</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	They've been working hard to put the tension and rocky relationship between Maggie and her mother to bed, and Millier and Hardin sell every ounce of that complex bond.</p>
<p>
	In the end, there was no better person to be there for Maggie at that appointment, including Gary. Sometimes a girl needs her mom.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/needing-mom-tall-a-million-little-things-s4e19/"><div class="image_wrapper" style="padding-bottom:120.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--hkekDZhg--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332257/needing-mom-tall-a-million-little-things-s4e19.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--vlhQK6EY--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332257/needing-mom-tall-a-million-little-things-s4e19.jpg" class="lazyload" alt="Needing Mom -tall  - A Million Little Things Season 4 Episode 19"></div></a>
</div>
<p>
	With only one viable embryo, they have to pour all their hope and optimism into this shot at their happy family. They weren't expecting that, but there's nothing to do but keep the faith.</p>
<p>
	You can tell they're both worried about what happens if this doesn't pan out, but they're trying to be strong and hopeful for each other. For their sake, let's hope this is it.</p>
<p>
	And for Eddie's sake, let's hope he breaks up with Anna. Even if she didn't kill Peter, there are too many red flags and complications.</p>
<p>
	Sadly, he's in it so deep with her that it'll break his heart if things don't work out. Like Katherine, it's become apparent that he probably should've spent more time single and casually dating instead of jumping into a serious relationship where he wants to travel the world with a freshly divorced functioning alcoholic.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/eddies-fresh-start-tall-a-million-little-things-s4e8/"><div class="image_wrapper" style="padding-bottom:122.24999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Ea07lbXi--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1638394806/eddies-fresh-start-tall-a-million-little-things-s4e8.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--0IHhtFB_--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1638394806/eddies-fresh-start-tall-a-million-little-things-s4e8.jpg" class="lazyload" alt="Eddie's Fresh Start -tall - A Million Little Things Season 4 Episode 8"></div></a>
</div>
<p>
	The weird thing about their weekend getaway was the implication that they needed time alone when Anna has a house to herself that Eddie regularly stays at.</p>
<p>
	And they took a detour from their plans to fulfill some dream Eddie had as a teen.</p>
<p>
	All the cuteness of that excursion evaporated when the ableist front desk clerk at the hotel lied about being overbooked because he assumed Eddie needed the disable friendly accommodations that were under repair.</p>
<p>
	If he had been upfront with Eddie and learned that Eddie could make other rooms work, he could've avoided the shame he likely experienced when Anna duped him into booking their room with a British accent.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/anna-meets-the-friends-tall-a-million-little-things-s4e10/"><div class="image_wrapper" style="padding-bottom:125.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ZyC1pNec--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646261051/anna-meets-the-friends-tall-a-million-little-things-s4e10.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--jHNPaQaq--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646261051/anna-meets-the-friends-tall-a-million-little-things-s4e10.jpg" class="lazyload" alt="Anna Meets the Friends -tall - A Million Little Things Season 4 Episode 10"></div></a>
</div>
<p>
	Eddie and Anna were better sports about the blatant, flagrant violations of the ADA. It's likely the sole accessible room was out of order for some time. The place deserved to be ripped apart and doxxed to hell.</p>
<p>
	Shockingly, Kai didn't continue stalking them during that ordeal. Instead, Sophie was stalking her a bit after her sympathy and concern for Kai turned to anger when she saw the horrible things Kai said about not believing Sophie at first.</p>
<p>
	I wish there were a way to dig Peter up, revive him, and beat his ass again.</p>
<p>
	He took his grooming to a whole new level with Kai, and this girl truly believed that he was in love with her, and they had a full-blown relationship.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tyes-agenda-a-million-little-things-s4e18/"><div class="image_wrapper" style="padding-bottom:125.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Mn-xH5nl--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725425/tyes-agenda-a-million-little-things-s4e18.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--2klzXlEV--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651725425/tyes-agenda-a-million-little-things-s4e18.jpg" class="lazyload" alt="Tye's Agenda - A Million Little Things Season 4 Episode 18"></div></a>
</div>
<p>
	She didn't feel like a victim, even though she was.</p>
<p>
	The pieces started to come together when Sophie realized that she was the student Peter came to see. But it makes you wonder why Peter brought a date then. Was he trying to discourage Kai or make her jealous?</p>
<p>
	<blockquote>
<p> It wasn't the same for me and Peter. We were in love. </p>
<small>Kai</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/it-wasnt-the-same-for-me-and-peter-we-were-in-love/">It wasn't the same for me and Peter. We were in love.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	He succeeded in making her jealous, and she drove to his house the night of his death. And as a result, she claims she saw Anna there.</p>
<p>
	Kai could be lying, but why would she come after Anna and not the woman Peter was with that night? And it's not like Anna hasn't been shady. Also, it would explain why Kai was following Anna.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/annas-lie-tall-a-million-little-things-s4e17/"><div class="image_wrapper" style="padding-bottom:122.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--yJT_37jj--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651087437/annas-lie-tall-a-million-little-things-s4e17.jpg" data-pin-description="A Million Little Things Season 4 Episode 19 Review: Out of Hiding" data-pin-url="https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--5HD75d-d--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1651087437/annas-lie-tall-a-million-little-things-s4e17.jpg" class="lazyload" alt="Anna's Lie -tall  - A Million Little Things Season 4 Episode 17"></div></a>
</div>
<p>
	It would be a catch-22 here because if Anna killed Peter, then it's a bit predictable, even if they gave us twists and turns until that reveal. However, if Kai harms Peter, it's a troubling depiction of a victim.</p>
<p>
	Going into the finale, we have a lot to process and discover!</p>
<p>
	Over to you, AMLT Fanatics. Who do you think killed Peter? Will Greta and Katherine reunite? Sound off below.</p>
<p>
	You can <a href="/shows/a-million-little-things/full-episodes/">watch A Million Little Things online</a> here via TV Fanatic.</p>



<div class='widget'>
<h3>
<a href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/"><span>Out of Hiding</span></a>
Review
</h3>
<b>Editor Rating:</b>
4.3
/ 5.0
<ul class="star-rating"><li style="width:86%;" class="current-rating">4.3 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_38358'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li style="width:0%;" class="current-rating">0.0 / 5.0</li><li><a class="star star-1" rel="nofollow" data-remote="true" data-method="post" href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/vote/?rating%5Brating%5D=1">1</a></li> <li><a class="star star-2" rel="nofollow" data-remote="true" data-method="post" href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/vote/?rating%5Brating%5D=2">2</a></li> <li><a class="star star-3" rel="nofollow" data-remote="true" data-method="post" href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/vote/?rating%5Brating%5D=3">3</a></li> <li><a class="star star-4" rel="nofollow" data-remote="true" data-method="post" href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/vote/?rating%5Brating%5D=4">4</a></li> <li><a class="star star-5" rel="nofollow" data-remote="true" data-method="post" href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/vote/?rating%5Brating%5D=5">5</a></li></ul></div>
<br>
Unrated
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="15642"><button class="btn btn-primary" data-href="/admin/post/99464/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/99464/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Jasmine Blu</b> is a senior staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/bleuangel88">Twitter</a>.</p>
</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/' data-id='99464' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a role="tab" data-toggle="tab" id="facebook_comments_tab" href="#facebook_comments">Facebook</a>
</li>
<li role='presentation'>
<a role="tab" data-toggle="tab" id="disqus_comments_tab" href="#disqus_comments">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-99464' data-disqus-url='https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-99464";
  var disqus_url = "https://www.tvfanatic.com/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/";
  var disqus_title = "A Million Little Things Season 4 Episode 19 Review: Out of Hiding";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "A Million Little Things Season 4 Episode 19 Review: Out of Hiding"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div id="next_post_link" data-link="/2022/05/a-million-little-things-round-table-are-you-team-shanice-or-team/"></div>
<small class='hidden-print'>
Tags:
<a rel="tag" href="/shows/a-million-little-things/">A Million Little Things</a>, <a rel="tag" href="/tags/reviews/">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/a-million-little-things/episodes/out-of-hiding/">A Million Little Things Season 4 Episode 19 Quotes</a></h4>
<blockquote>
<p> Katherine, I left you once for Miami. I don't want to make that same mistake again.</p>
<small>Shanice</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/katherine-i-left-you-once-for-miami-i-dont-want-to-make-that-sam/">Katherine, I left you once for Miami. I don&#39;t want to make that same mistake again.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2022-05-11">May 11, 2022</time></li>
</ul>
</blockquote>
<blockquote>
<p> Maybe we both just need some space to figure out what's best for us.</p>
<small>Greta</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/maybe-we-both-just-need-some-space-to-figure-out-whats-best-for/">Maybe we both just need some space to figure out what&#39;s best for us.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2022-05-11">May 11, 2022</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/a-million-little-things/episodes/out-of-hiding/">A Million Little Things Season 4 Episode 19 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/needing-mom-tall-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Needing Mom -tall  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--GMRAvCcR--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332257/needing-mom-tall-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/nervous-for-the-future-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Nervous for the Future  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--WhskawZ3--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332192/nervous-for-the-future-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/maddoxs-parents-tall-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Maddox&#39;s Parents -tall  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--TWkZDCll--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652332111/maddoxs-parents-tall-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/standing-by-maddox-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Standing By Maddox  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--mri4EZFc--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331724/standing-by-maddox-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/two-parents-one-embryo-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Two Parents, One Embryo  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--d3RUgNnF--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331469/two-parents-one-embryo-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/baby-making-a-million-little-things-s4e19/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Baby Making  - A Million Little Things Season 4 Episode 19" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--DMHHLdQo--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652331288/baby-making-a-million-little-things-s4e19.jpg" class="lazyload" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/a-million-little-things/episodes/season-4/out-of-hiding/","url":"https://www.tvfanatic.com/shows/a-million-little-things/episodes/season-4/out-of-hiding/","name":"Out of Hiding","episodeNumber":19,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/a-million-little-things/episodes/season-4/","url":"https://www.tvfanatic.com/shows/a-million-little-things/episodes/season-4/","seasonNumber":4},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/a-million-little-things/","url":"https://www.tvfanatic.com/shows/a-million-little-things/","name":"A Million Little Things"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2022-05-11","location":{"@type":"Country","name":"US"}},"description":"On A Million Little Things Season 4 Episode 19, Katherine grapples with her history with Shanice and future with Greta while Rome runs into his childhood bully.","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/a-million-little-things/full-episodes/season-4/out-of-hiding/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2022-05-11T00:00","availabilityEnds":"2023-05-12T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--r8PWQoln--/c_thumb,f_auto,g_auto,h_600,q_auto,w_400/v1652230978/infertility-issues-a-million-little-things","height":600,"width":400}}</script>
<h4>
<div class='clearfix'>
<time datetime="2022-05-11" class="air">5/11/22</time>
<div class='number'><a href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/">A Million Little Things Season 4 Episode 19</a></div>
</div>
<div class='title'>Out of Hiding</div>
</h4>
<img alt="Infertility Issues - A Million Little Things" src="https://tv-fanatic-res.cloudinary.com/iu/s--HdUKwGa2--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1652230978/infertility-issues-a-million-little-things.jpg" />
<ul class='nav nav-pills'>
<li><a href="/2022/05/a-million-little-things-season-4-episode-19-review-out-of-hiding/">Review</a></li>
<li><a href="/quotes/shows/a-million-little-things/episodes/out-of-hiding/">Quotes</a></li>
<li><a href="/gallery/shows/a-million-little-things/episodes/out-of-hiding/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/a-million-little-things/">A Million Little Things</a></li> <li><a href="/shows/a-million-little-things/episodes/season-4/">A Million Little Things Season 4</a></li> <li><a href="/shows/a-million-little-things/episodes/season-4/out-of-hiding/">A Million Little Things Season 4 Episode 19</a></li> <li>A Million Little Things Review: Out of Hiding</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/star-trek-strange-new-worlds/">Star Trek: Strange New Worlds</a></li>
<li><a href="/shows/severance/">Severance</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
<li><a href="/shows/power/">Power</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/madam-secretary/">Madam Secretary</a></li>
<li><a href="/shows/9-1-1/">9-1-1</a></li>
<li><a href="/shows/ncis-los-angeles/">NCIS: Los Angeles</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/1883/">1883</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/the-resident/">The Resident</a></li>
<li><a href="/shows/the-blacklist/">The Blacklist</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2022/05/">May 2022</a></li>
<li><a href="/2022/04/">April 2022</a></li>
<li><a href="/2022/03/">March 2022</a></li>
<li><a href="/2022/02/">February 2022</a></li>
<li><a href="/2022/01/">January 2022</a></li>
<li><a href="/2021/">2021 Archives</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2022 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2022 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
