<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Stolen By Their Father Review: Sarah Drew Captures a Mother&#39;s Hellish Nightmare - TV Fanatic</title>
<link rel="shortcut icon" type="image/x-icon" href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" />
<link rel="canonical" href="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" />

<link rel="alternate" type="application/atom+xml" title="TV Fanatic Feed" href="https://www.tvfanatic.com/rss.xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/' property='og:url'>
<meta content="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" property='og:title'>
<meta content="On Stolen By Their Father, Sarah Drew's Lisbeth navigates two countries' failing systems when her abusive ex kidnaps her children and escapes to Greece. Read our review! " property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--pWskArbp--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646543767/kidnapping-her-daughters-back-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--8lLzbaHW--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646543975/kidnapping-back-her-daughters-sbtf-tall.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='764' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--UdZW5Cpm--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544197/let-down-lisbeth-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='816' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--JJz2QlCW--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544577/argumentative-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='774' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ujkG5HKU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544107/lisbth-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='419' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--wqdcL0F4--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544459/quarreling-parents-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='709' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Rvn0AXa7--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544291/back-to-greece-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='799' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Ov5ajWUJ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646545208/pi-work-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='770' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--hPznZiDU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544742/getting-to-greece-tall-sbtf.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='802' property='og:image:height'>
<meta content='2022-03-06T00:43:53-05:00' property='article:published_time'>
<meta content='2022-03-06T00:42:45-05:00' property='article:modified_time'>
<meta content='Lifetime' property='article:tag'>
<meta content='Movie Review' property='article:tag'>
<meta content='TV Movie' property='article:tag'>
<meta content='Jasmine Blu' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" name='twitter:title'>
<meta content="On Stolen By Their Father, Sarah Drew's Lisbeth navigates two countries' failing systems when her abusive ex kidnaps her children and escapes to Greece. Read our review! " name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--pWskArbp--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646543767/kidnapping-her-daughters-back-sbtf.jpg' name='twitter:image:src'>

<meta name="description" content="On Stolen By Their Father, Sarah Drew&#39;s Lisbeth navigates two countries&#39; failing systems when her abusive ex kidnaps her children and..."></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension2', 'Jasmine Blu');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link rel="stylesheet" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" as="style" />
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" as="style" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "lifetime", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/","mainEntityOfPage":"https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/","headline":"Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare","datePublished":"2022-03-06T00:43:53-05:00","dateModified":"2022-03-06T00:42:45-05:00","description":"On Stolen By Their Father, Sarah Drew's Lisbeth navigates two countries' failing systems when her abusive ex kidnaps her children and escapes to Greece. Read our review! ","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--KE02EcvN--/f_auto,q_auto/v1646543767/kidnapping-her-daughters-back-sbtf","height":3109,"width":4663},"author":{"@type":"Person","url":"https://www.tvfanatic.com/authors/blu/","name":"Jasmine Blu"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input type="search" name="q" id="q" placeholder="Search" class="form-control" />
<div class='input-group-btn'><button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>

<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare</h1>
<small>
<a rel="author" href="/authors/blu/"><img class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--IhuDiizY--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1379964334/user/blu.png" alt="Blu" />
<a rel="author" href="/authors/blu/">Jasmine Blu</a>
</a>at
<time datetime="2022-03-06T00:43:53-05:00" itemprop="datePublished">March  6, 2022 12:43 am</time>.
</small>
</header>
<div class='body'>
<p>
	What a horrific tale!</p>
<p>
	Sarah Drew's Lisbeth lived a mother's worst nightmare during <strong><em>Stolen By Their Father</em></strong> -- a ripped from the headlines film executive produced by Elizabeth Smart. Lisbeth's heartrending ordeal to get her daughters back was almost unbearable to watch.</p>
<p>
	And the worst part about it all was knowing that actual events inspired the film.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/kidnapping-back-her-daughters-sbtf-tall/"><div class="image_wrapper" style="padding-bottom:121.24999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--8lLzbaHW--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646543975/kidnapping-back-her-daughters-sbtf-tall.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--vEnCe3et--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646543975/kidnapping-back-her-daughters-sbtf-tall.jpg" class="lazyload" alt="Kidnapping Back Her Daughters -SBTF - Tall"></div></a>
</div>
<p>
	In some ways, Stolen By Their Father felt like an ambitious movie for the network. We had Sarah Drew playing the titular character, and the film had her jettisoning from the States to Greece.</p><div id="stp_target"></div>
<p>
	During a significant portion of the film, the gorgeous Greek backdrop was integral. You couldn't capture the tone, and Lisbeth's plight at this woman stuck in a foreign country, desperate, and not getting the proper aid she needed to protect her family.</p>
<p>
	They couldn't have captured the level of intensity, helplessness, and outcast status Lisbeth experienced without the Greek location. The film is enriched because of the Greek casting and actual location. All of that added to the overall frustration and ire you felt while following Lisbeth's experience.</p>
<p>
	Time and time again, we saw how much the system lets women like Lisbeth down, and it wasn't in one country, but two.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/let-down-lisbeth-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:129.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--UdZW5Cpm--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544197/let-down-lisbeth-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--MnXXA0ww--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544197/let-down-lisbeth-tall-sbtf.jpg" class="lazyload" alt="Let Down Lisbeth -tall - SBTF"></div></a>
</div>
<p>
	As a domestic violence survivor, the entire film was just a plethora of people in Alaska and Greece, letting her down at every conceivable turn. And if it wasn't bad enough that she was dismissed and treated poorly, they let her daughters down, too.</p>
<p>
	It seemed like Lisbeth was the only one who gave a damn about her children and what was in their best interest, and it was downright disturbing.</p>
<p>
	Greg was a vile creature; we knew as much because of their history, but his actions throughout the film got progressively worse, and it was hard to believe that his supposed charm was ever effective. Was there a time in the movie when he wasn't an ass to people?</p>
<p>
	Because of how unapologetically dickish he was, it was upsetting that he ever succeeded in anything throughout the movie. It felt as though he was as transparent as it could get, so it was confusing that people either enabled him or bought into his actions and lies.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/argumentative-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:122.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--JJz2QlCW--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544577/argumentative-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--L9Qgr4RS--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544577/argumentative-tall-sbtf.jpg" class="lazyload" alt="Argumentative -tall -SBTF"></div></a>
</div>
<p>
	He didn't appear to hide anything; Greg was brazen as hell about how much he enjoyed sticking it to Lisbeth, and there wasn't a time when he didn't present himself as a terrible man. Yet, he had the chief of police, judges, and others shrugging away his actions and volatile behavior and gaslighting Lisbeth.</p>
<p>
	At one point, people witnessed him slap her, and no one did anything about it.</p>
<p>
	For the entire film, it was Lisbeth begging people to help her and having to jump through hoops to prove that she was the reasonable person in this situation, and more often than not, it was all for naught.</p>
<p>
	It was enraging when she went to the American police, and the detective admitted that she didn't take Lisbeth seriously because Greg told people that she was mentally unstable.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/lisbth-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:66.34615384615384%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ujkG5HKU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544107/lisbth-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--4Ppx-ECl--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544107/lisbth-tall-sbtf.jpg" class="lazyload" alt="Lisbth -tall -SBTF"></div></a>
</div>
<p>
	She was a detective, with access to all the police records and restraining orders in place. Because of that alone, Lisbeth deserved the benefit of the doubt, but not acknowledging her concerns in favor of taking Greg's word wasted precious time.</p>
<p>
	It was similar in Greece, where Greg had more ground and pull, and it came across as if he had enough connections and an understanding of the legal system there that he kept worming his way around everything. Was Greece meant to come across as traditional and archaic?</p>
<p>
	Lisbeth's status as an American worked against her while there, but much of that also had to do with her being a woman. It was like she was powerless, and everything was designed to work in Greg's favor. No one wanted to consider that he was in the wrong for keeping his children because he was their father.</p>
<p>
	It didn't seem to matter that they were divorced, he had a history of abuse, or that she had legal custody of the girls in the States. The law was supposed to protect her, but for whatever reason, it never did. It sure as hell didn't do anything for the girls.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/quarreling-parents-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:112.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--wqdcL0F4--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544459/quarreling-parents-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ovqOqhYK--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544459/quarreling-parents-tall-sbtf.jpg" class="lazyload" alt="Quarreling Parents -tall -SBTF"></div></a>
</div>
<p>
	Months went by, and it was like no one cared to do anything. Did they expect Lisbeth to give up and stop looking for her kids? It was madness!</p>
<p>
	She went ten months with very little aid in getting her kids back, and if she didn't have the few connections she managed through her work, how much worse would it have been?</p>
<p>
	It was as plain as day that Greg only did all of this to screw with Lisbeth. It was already bad enough that he kidnapped the girls and filled their heads with lies about their mother. But on top of all of that, he wasn't even taking care of them.</p>
<p>
	Damn near a year later, she learned that they were bouncing around from place to place; he never had a steady job, the girls rarely went to school, and they were dirty and unkempt.</p>
<p>
	How could a judge know all these details and not determine that it was in the children's best interest to be with their mother, who had been searching for them forever?</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/back-to-greece-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:126.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Rvn0AXa7--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544291/back-to-greece-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ihW5Wxv1--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544291/back-to-greece-tall-sbtf.jpg" class="lazyload" alt="Back to Greece -Tall -SBTF"></div></a>
</div>
<p>
	The judge heard that Greg was abusive to Lisbeth and knew the kids were rarely at school and weren't living a stable life, but he still determined that moving them would be too much because they had already spent a year and a half in Greece.</p>
<p>
	It was heartbreaking when the girls revealed that he had been physically abusive to them.</p>
<p>
	My heart ached for Lisbeth, and Sarah Drew poured her all into this role, convincingly capturing Lisbeth's relentlessness, fear, determination, and more. She was the clear star of this film because, for the most part, everyone else seemed to fall to the wayside.</p>
<p>
	Kimonas Kouris was serviceable as the villainous Greg, but it also felt like we didn't get much to go on from his angle of things or see him in action until halfway through the film. He was very much capable of giving us so much more, but he oddly enough felt underused.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/pi-work-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:122.24999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Ov5ajWUJ--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646545208/pi-work-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--izGE8TRw--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646545208/pi-work-tall-sbtf.jpg" class="lazyload" alt="P.I. Work -tall - SBTF"></div></a>
</div>
<p>
	The private investigator stood out with time, but overall, this was Sarah Drew's film to carry, and she certainly did that. I still wish the other characters didn't fall into the background in a sea of forgetful names and faces.</p>
<p>
	The flashbacks also served to provide parallels from Lizbeth's current situation, fighting to get her daughters back to her past as a kidnapped child whose terrible mother ripped her away from a loving father.</p>
<p>
	It wasn't that the parallels didn't make sense, but their frequency didn't add very much to the film.</p>
<p>
	Lizbeth's triumphant Uno reverse kidnapping to get her kids back was such a nerve-wracking scene, but it was satisfying when we got to that point. The build-up took so long, and then it flew by once it happened. But then goodness, she brought her babies back home.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/getting-to-greece-tall-sbtf/"><div class="image_wrapper" style="padding-bottom:127.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--hPznZiDU--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544742/getting-to-greece-tall-sbtf.jpg" data-pin-description="Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare" data-pin-url="https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--LPuod1VT--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544742/getting-to-greece-tall-sbtf.jpg" class="lazyload" alt="Getting to Greece -tall - SBTF"></div></a>
</div>
<p>
	It just saddens me how deeply multiple systems let her down, and as a domestic abuse survivor, she was no stranger to that as it was.</p>
<p>
	Over to you, Lifetime Fanatics. What are your thoughts about this film? Hit the comments!</p>

<div class='widget'>
<h3>
Review
</h3>
<b>Editor Rating:</b>
4.3
/ 5.0
<ul class="star-rating"><li style="width:86%;" class="current-rating">4.3 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
</div>

<div class="buttons admin edit_object_links" data-user-id="15642"><button class="btn btn-primary" data-href="/admin/post/98213/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/98213/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Jasmine Blu</b> is a senior staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/bleuangel88">Twitter</a>.</p>
</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/' data-id='98213' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a role="tab" data-toggle="tab" id="facebook_comments_tab" href="#facebook_comments">Facebook</a>
</li>
<li role='presentation'>
<a role="tab" data-toggle="tab" id="disqus_comments_tab" href="#disqus_comments">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-98213' data-disqus-url='https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-98213";
  var disqus_url = "https://www.tvfanatic.com/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/";
  var disqus_title = "Stolen By Their Father Review: Sarah Drew Captures a Mother\'s Hellish Nightmare";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Stolen By Their Father Review: Sarah Drew Captures a Mother\'s Hellish Nightmare"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div id="next_post_link" data-link="/2022/03/mary-j-blige-to-executive-produce-real-love-movie-at-lifetime/"></div>
<small class='hidden-print'>
Tags:
<a rel="tag" href="/networks/lifetime/">Lifetime</a>, <a rel="tag" href="/tags/movie-review/">Movie Review</a>, <a rel="tag" href="/tags/tv-movie/">TV Movie</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/networks/lifetime/">Lifetime Quotes</a></h4>
<blockquote>
<p>Real Estate Agent: Between you and me, this is the first time I've shown this place in a month. So you can get this place for a steal.<br>Vincent: My favorite way of getting things.</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/my-favorite-way-of-getting-things/"> My favorite way of getting things.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-07-25">July 25, 2020</time></li>
</ul>
</blockquote>
<blockquote>
<p> It's one of the great mysteries of life. You never know quite what's going to happen next.</p>
<small>Vincent</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/its-one-of-the-great-mysteries-of-life-you-never-know-quite-what/">It&#39;s one of the great mysteries of life. You never know quite what&#39;s going to happen next.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-07-25">July 25, 2020</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/networks/lifetime/">Lifetime</a></h4>
<ul class='nav'>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/03/stolen-by-their-father-review-sarah-drew-captures-a-mothers-hell/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Stolen By Their Father Review: Sarah Drew Captures a Mother&#39;s Hellish Nightmare" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--jcopkQLQ--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1646543767/kidnapping-her-daughters-back-sbtf" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--DUypDyQn--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1646543767/kidnapping-her-daughters-back-sbtf 31w, https://tv-fanatic-res.cloudinary.com/iu/s--NSmqTBo_--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1646543767/kidnapping-her-daughters-back-sbtf 62w, https://tv-fanatic-res.cloudinary.com/iu/s--Z7u2H4yi--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1646543767/kidnapping-her-daughters-back-sbtf 93w, https://tv-fanatic-res.cloudinary.com/iu/s--jcopkQLQ--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1646543767/kidnapping-her-daughters-back-sbtf 125w, https://tv-fanatic-res.cloudinary.com/iu/s--JIVJDZXj--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1646543767/kidnapping-her-daughters-back-sbtf 187w, https://tv-fanatic-res.cloudinary.com/iu/s--Q-tFHmez--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1646543767/kidnapping-her-daughters-back-sbtf 250w, https://tv-fanatic-res.cloudinary.com/iu/s--WjxjLxwX--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1646543767/kidnapping-her-daughters-back-sbtf 312w, https://tv-fanatic-res.cloudinary.com/iu/s--gUdUOOXe--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1646543767/kidnapping-her-daughters-back-sbtf 375w" class="lazyload" /></div></div>
</div>
Stolen By Their Father Review: Sarah Drew Captures a Mother's Hellish Nightmare
</a></li>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/03/mary-j-blige-to-executive-produce-real-love-movie-at-lifetime/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Mary J. Blige to Executive Produce Real Love Movie at Lifetime" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--uWdJGU45--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1518468995/mary-j-blige-attends-event" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--AswhBZZx--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1518468995/mary-j-blige-attends-event 31w, https://tv-fanatic-res.cloudinary.com/iu/s--lJXf4k9J--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1518468995/mary-j-blige-attends-event 62w, https://tv-fanatic-res.cloudinary.com/iu/s--cvy4Uh5D--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1518468995/mary-j-blige-attends-event 93w, https://tv-fanatic-res.cloudinary.com/iu/s--uWdJGU45--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1518468995/mary-j-blige-attends-event 125w, https://tv-fanatic-res.cloudinary.com/iu/s--XSzW_snP--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1518468995/mary-j-blige-attends-event 187w, https://tv-fanatic-res.cloudinary.com/iu/s--3eBeJz8L--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1518468995/mary-j-blige-attends-event 250w, https://tv-fanatic-res.cloudinary.com/iu/s--OQrTg2Ba--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1518468995/mary-j-blige-attends-event 312w, https://tv-fanatic-res.cloudinary.com/iu/s--NOoHKio3--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1518468995/mary-j-blige-attends-event 375w" class="lazyload" /></div></div>
</div>
Mary J. Blige to Executive Produce Real Love Movie at Lifetime
</a></li>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/02/lifetime-schedules-angie-harmon-movie-series-buried-in-barstow/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Lifetime Schedules Angie Harmon Movie Series Buried in Barstow" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--VTcMEgKR--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1645732573/harmon-on-buried-in-barstow" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--Q11LsP38--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1645732573/harmon-on-buried-in-barstow 31w, https://tv-fanatic-res.cloudinary.com/iu/s--KULttEKm--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1645732573/harmon-on-buried-in-barstow 62w, https://tv-fanatic-res.cloudinary.com/iu/s--AmQSj5qR--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1645732573/harmon-on-buried-in-barstow 93w, https://tv-fanatic-res.cloudinary.com/iu/s--VTcMEgKR--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1645732573/harmon-on-buried-in-barstow 125w, https://tv-fanatic-res.cloudinary.com/iu/s--q9kLC5Gh--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1645732573/harmon-on-buried-in-barstow 187w, https://tv-fanatic-res.cloudinary.com/iu/s--G6DeIbQg--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1645732573/harmon-on-buried-in-barstow 250w, https://tv-fanatic-res.cloudinary.com/iu/s--rGgu0Z9h--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1645732573/harmon-on-buried-in-barstow 312w, https://tv-fanatic-res.cloudinary.com/iu/s--js3QDeyn--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1645732573/harmon-on-buried-in-barstow 375w" class="lazyload" /></div></div>
</div>
Lifetime Schedules Angie Harmon Movie Series Buried in Barstow
</a></li>
</ul>

</div>
</div>
</div>
<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/networks/lifetime/">Lifetime Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/pi-work-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="P.I. Work -tall - SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--kIvwdAji--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646545208/pi-work-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/getting-to-greece-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Getting to Greece -tall - SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--DpG3NbL---/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544742/getting-to-greece-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/argumentative-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Argumentative -tall -SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--XmMZNQE5--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544577/argumentative-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/quarreling-parents-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Quarreling Parents -tall -SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--BLzs-wBs--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544459/quarreling-parents-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/back-to-greece-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Back to Greece -Tall -SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Bmqu8rTV--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544291/back-to-greece-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/let-down-lisbeth-tall-sbtf/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Let Down Lisbeth -tall - SBTF" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nSsjlSow--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1646544197/let-down-lisbeth-tall-sbtf.jpg" class="lazyload" /></div></div>
</a></div>
</div>

</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/videos/networks/lifetime/">Lifetime Videos</a></h4>
<div class='row'>
<div class='col-xs-12'>
<a class="thumbnail" href="/videos/lifetime-unveils-airdates-for-three-book-to-screen-summer-movies/"><div class="image_outter_wrapper" style="max-width:313px;"><div class="image_wrapper" style="padding-bottom:61.66134185303515%;"><img alt="Lifetime Unveils Airdates for Three Book to Screen Summer Movies" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--YFNE66r2--/t_v_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1556140357/video/lifetime-unveils-airdates-for-three-book-to-screen-summer-movies.png" class="lazyload" /></div></div>
<div class='caption'>Lifetime Unveils Airdates for Three Book to Screen Summer Movies</div>
</a></div>
</div>
<div class='row videos'>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/you-preview-welcome-to-your-new-obsession/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="YOU Preview: Welcome to YOUr Newest Obsession! " data-src="https://tv-fanatic-res.cloudinary.com/iu/s--UyuIq8Nx--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1536118742/video/you-preview-welcome-to-your-new-obsession.jpg" class="lazyload" /></div></div>
<div class='caption'>YOU Preview: Welcome to YOUr Newest Obsession! </div>
</a></div>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/you-trailer-see-penn-badgley-as-a-violent-stalker/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="You Trailer: See Penn Badgley as a Violent Stalker!" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--VbXSt4xg--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1523378191/video/you-trailer-see-penn-badgley-as-a-violent-stalker.png" class="lazyload" /></div></div>
<div class='caption'>You Trailer: See Penn Badgley as a Violent Stalker!</div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/networks/lifetime/">Lifetime</a></li> <li>Stolen By Their Father Review: Sarah Drew Captures a Mother&#39;s Hellish Nightmare</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/1883/">1883</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/resident-alien/">Resident Alien</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/9-1-1-lonestar/">9-1-1: Lone Star</a></li>
<li><a href="/shows/power-book-ii-ghost/">Power Book II: Ghost</a></li>
<li><a href="/shows/seal-team/">SEAL Team</a></li>
<li><a href="/shows/the-cleaning-lady/">The Cleaning Lady</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/chicago-pd/">Chicago PD</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2022/03/">March 2022</a></li>
<li><a href="/2022/02/">February 2022</a></li>
<li><a href="/2022/01/">January 2022</a></li>
<li><a href="/2021/">2021 Archives</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2022 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2022 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
