<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/' property='og:url'>
<meta content='Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More' property='og:title'>
<meta content='Paloma Faith speaks about Pennyworth Season 2, filming during the COVID-19 pandemic, and what fans should expect for Bet. Check out our interview. ' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--xvR1sMbg--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775279/paloma-horizontal-photo-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='421' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--iQXyFSd8--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774984/paloma-faith-is-bet-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='751' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--B4dJ0_R---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774815/in-character-as-bet-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='690' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--4rzkfLpN--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774787/looking-forward-to-this-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='727' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ZNWseG6j--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774760/bet-in-a-phone-box-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='736' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ePcYT9Hi--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774731/bets-new-mission-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='753' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--VYWWMeh2--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775025/bet-with-a-dead-body-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='425' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--I5oP1I0R--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774332/paloma-faith-as-bet-sykes-pennyworth.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='418' property='og:image:height'>
<meta content='2020-12-12T10:00:00-05:00' property='article:published_time'>
<meta content='2020-12-12T07:22:58-05:00' property='article:modified_time'>
<meta content='Interviews' property='article:tag'>
<meta content='Paloma Faith' property='article:tag'>
<meta content='Exclusives' property='article:tag'>
<meta content='Pennyworth' property='article:tag'>
<meta content='EPIX' property='article:tag'>
<meta content='Paul Dailly' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More' name='twitter:title'>
<meta content='Paloma Faith speaks about Pennyworth Season 2, filming during the COVID-19 pandemic, and what fans should expect for Bet. Check out our interview. ' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--xvR1sMbg--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775279/paloma-horizontal-photo-pennyworth.png' name='twitter:image:src'>

<meta content="Paloma Faith speaks about Pennyworth Season 2, filming during the COVID-19 pandemic, and what fans should expect for Bet. Check out our..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension2', 'Paul Dailly');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "interviews", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/","mainEntityOfPage":"https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/","headline":"Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, \u0026 More","datePublished":"2020-12-12T10:00:00-05:00","dateModified":"2020-12-12T07:22:58-05:00","description":"Paloma Faith speaks about Pennyworth Season 2, filming during the COVID-19 pandemic, and what fans should expect for Bet. Check out our interview. ","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--mUe9wclo--/f_auto,q_auto/v1607775279/paloma-horizontal-photo-pennyworth","height":1520,"width":2274},"author":{"@type":"Person","name":"Paul Dailly"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>

<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More</h1>
<small>
<a href="/authors/pauldailly92/" rel="author"><img alt="Pauldailly92" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--jzYlH3ci--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1437338558/user/pauldailly92.jpg" />
<a href="/authors/pauldailly92/" rel="author">Paul Dailly</a>
</a>at
<time datetime="2020-12-12T10:00:00-05:00" itemprop="datePublished">December 12, 2020 10:00 am</time>.
</small>
</header>
<div class='body'>
<p>
	Pennyworth returns for its second season Sunday, December 13, on EPIX, and we got the chance to chat with Paloma Faith about what's to come.</p>
<p>
	Faith plays the role of Bet on the Batman prequel. </p>
<p>
	The series was affected by the COVID-19 pandemic, having been shut down earlier this year. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/paloma-horizontal-photo-pennyworth/"><div class="image_wrapper" style="padding-bottom:66.73076923076923%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--xvR1sMbg--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775279/paloma-horizontal-photo-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--peQ9V_ve--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775279/paloma-horizontal-photo-pennyworth.png" class="lazyload" alt="Paloma Horizontal Photo - Pennyworth"></div></a>
</div>
<p>
	Below, Paloma speaks about her character, what's to come, and more!</p><div id="stp_target"></div>
<p>
	<strong>TV Fanatic: Bet has more layers than your typical TV character. What do you like the most about playing her?</strong></p>
<p>
	Paloma Faith: Well, I haven't ever had the opportunity to sink my teeth into like a fully well-rounded character or been in a series before.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/paloma-faith-is-bet-pennyworth/"><div class="image_wrapper" style="padding-bottom:119.24999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--iQXyFSd8--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774984/paloma-faith-is-bet-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--tuS4Yr9k--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774984/paloma-faith-is-bet-pennyworth.png" class="lazyload" alt="Paloma Faith is Bet - Pennyworth"></div></a>
</div>
<p>
	What I love about it is, as people know, I don't come from a traditional training background. </p>
<p>
	I'm really learning as I go along, and all of the emotional highs and lows and the fact that Bet is a character who's quite capable of jumping from any emotion to another within a split second means that I get to really explore a whole plethora of characters in one.</p>
<p>
	So I feel like I'm learning so much. It's like an acting apprenticeship to me because I can be aggressive and then vulnerable within like a moment and actually more so in season two because, in season one, I was just often very hard, but in season two, we start to really explore the nuances, and there's a lot of indication about Bet having a softer side as well.</p>
<p>
	So, it was really great to play her.</p>
<div style="max-width:426px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/in-character-as-bet-pennyworth/"><div class="image_wrapper" style="padding-bottom:109.85915492957747%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--B4dJ0_R---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774815/in-character-as-bet-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--eP8SoDRU--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774815/in-character-as-bet-pennyworth.png" class="lazyload" alt="In Character as Bet - Pennyworth"></div></a>
</div>
<p>
	<strong>Do you think Bet sees herself as a villain, or do you think she sees herself as misunderstood?</strong></p>
<p>
	She doesn't see herself as a villain. I think that she thinks everything she does is completely justified. </p>
<p>
	I actually understand why she would think that because there is a lot of supposed good guys doing just as much violence in the show as her and as harshly and weirdly.</p>
<p>
	I mean, Alfred Pennyworth and Bet Sykes are kind of neck in neck on the bizarre front in types of aggression.</p>
<p>
	<strong>Your scenes with Jack are great, but Alfred and Bet didn't share a lot of time on the screen in the first season. Do they cross paths even more in the second season?</strong></p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<strong><a href="/gallery/looking-forward-to-this-pennyworth/"><div class="image_wrapper" style="padding-bottom:115.25000000000001%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--4rzkfLpN--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774787/looking-forward-to-this-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--EvXQK90x--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774787/looking-forward-to-this-pennyworth.png" class="lazyload" alt="Looking Forward to This - Pennyworth"></div></a></strong>
</div>
<p>
	Even less, I'm afraid.</p>
<p>
	<strong>We closed Season 1 with Bet being locked up after kidnapping the Queen. What can you tease about where we pick up her storyline?</strong></p>
<p>
	Well, no one ever wants to be locked up!</p>
<p>
	But when we come to Season 2, we come into their lives a year later. It's a clever writing trick in that we don't have to explain how Bet is out.</p>
<p>
	<strong>She's such a fantastic character. The one-liners are probably some of the best on TV. </strong></p>
<p>
	I agree.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/bet-in-a-phone-box-pennyworth/"><div class="image_wrapper" style="padding-bottom:116.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ZNWseG6j--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774760/bet-in-a-phone-box-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Spj4i-Zh--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774760/bet-in-a-phone-box-pennyworth.png" class="lazyload" alt="Bet in a Phone Box - Pennyworth"></div></a>
</div>
<p>
	<strong>Is there anything else you can tease about the second season?</strong></p>
<p>
	We've got a lot more references. I really liked it when I watched the show, and it had these Easter eggs of the history of British culture. </p>
<p>
	Last season, we had Jack the Ripper, and we had John Ripper, and then we had, like, James Saville getting hung, and all these sort of little jokes if you're like really nerdy like me, you get to take out the names.</p>
<p>
	There's quite a lot of that going on in Season 2.</p>
<p>
	I've only seen the first three episodes, but I actually enjoy watching it to pick up on who comes up.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/bets-new-mission-pennyworth/"><div class="image_wrapper" style="padding-bottom:119.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ePcYT9Hi--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774731/bets-new-mission-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--OKA84_kz--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774731/bets-new-mission-pennyworth.png" class="lazyload" alt="Bet's New Mission - Pennyworth"></div></a>
</div>
<p>
	There are a few Batman characters that come into Season 2 also. We start to see how the relationships are made with the people that ended up being around Batman.</p>
<p>
	<strong>I understand production was shut down due to the pandemic earlier this year. Are you able to speak about the differences in shooting the series nowadays?</strong></p>
<p>
	So afterward, we had very strict protocols in place where we all tested several times a week.</p>
<p>
	We had to fill in a form every day and test our temperature every day to get on to the production lot.</p>
<p>
	And we have to wear masks right up until shooting. So even like rehearsing in masks. When they say cameras was the only time we took them off.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/bet-with-a-dead-body-pennyworth/"><div class="image_wrapper" style="padding-bottom:67.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--VYWWMeh2--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775025/bet-with-a-dead-body-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--fcKdFnRy--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607775025/bet-with-a-dead-body-pennyworth.png" class="lazyload" alt="Bet With a Dead Body - Pennyworth"></div></a>
</div>
<p>
	And then, as soon as they say cut, we put them back on again. Everyone was trying to reduce the amount of exposure we might have If there was anyone on set with the virus.</p>
<p>
	And then, obviously, the crew were socially distanced from us. We weren't allowed to go near them, and they all had to wear masks, and we weren't allowed to eat together.</p>
<p>
	So it was different, but to be honest, because it was in such a massive contrast to the isolation of, if we weren't at work, we felt like we were living the dream because we were at work and we were able to have a laugh and be around people.</p>
<p>
	And also, you know, in, in the knowledge as well, that like everyone had had a test, and stuff was quite reassuring. That felt quite luxurious. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/paloma-faith-as-bet-sykes-pennyworth/"><div class="image_wrapper" style="padding-bottom:66.34615384615384%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--I5oP1I0R--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774332/paloma-faith-as-bet-sykes-pennyworth.png" data-pin-description="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" data-pin-url="https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--NsU-dAa7--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607774332/paloma-faith-as-bet-sykes-pennyworth.png" class="lazyload" alt="Paloma Faith as Bet Sykes - Pennyworth"></div></a>
</div>
<p>
	<strong>I know you recently released Infinite Things, your fifth studio album, and hosted The Voice Kids. Are you working on anything else at the moment?</strong></p>
<p>
	I'm making a human being, actually. </p>
<p>
	<strong>Congratulations!</strong></p>
<p>
	So, I'm very heavily pregnant, and I'm just waiting a bit for that. Promoting the album and Pennyworth simultaneously up quite a lot of time. </p>
<p>
	So, I'm pausing on the creative stuff for now, just while I promote. I don't think the two go together very well. </p>
<p>
	<em>Pennyworth Season 2 airs on EPIX. If you're watching along internationally, new episodes are available on Starz Play. </em></p>
<p style="text-align: center;">
	<iframe allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/VenjQzZxQRU" width="560"></iframe></p>


<div class="buttons admin edit_object_links" data-user-id="66541"><button class="btn btn-primary" data-href="/admin/post/90776/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/90776/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Paul Dailly</b> is the Associate Editor for TV Fanatic. Follow him on <a href="http://twitter.com/pauldailly1992">Twitter</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/' data-id='90776' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-90776' data-disqus-url='https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-90776";
  var disqus_url = "https://www.tvfanatic.com/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/";
  var disqus_title = "Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, & More";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, & More"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2020/12/laurence-leboeuf-on-transplant-mags-and-what-comes-next/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/tags/interviews/" rel="tag">Interviews</a>, <a href="/stars/paloma-faith/" rel="tag">Paloma Faith</a>, <a href="/tags/exclusives/" rel="tag">Exclusives</a>, <a href="/shows/pennyworth/" rel="tag">Pennyworth</a>, <a href="/networks/epix/" rel="tag">EPIX</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/tags/interviews/">Interviews</a></h4>
<ul class='nav'>
<li>
<a class="clearfix" href="/2020/12/paloma-faith-talks-pennyworth-season-2-filming-during-covid-19-a/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--r_HQDOcA--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607775279/paloma-horizontal-photo-pennyworth" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--5I19885i--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1607775279/paloma-horizontal-photo-pennyworth 31w, https://tv-fanatic-res.cloudinary.com/iu/s--tXCl0jYW--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1607775279/paloma-horizontal-photo-pennyworth 62w, https://tv-fanatic-res.cloudinary.com/iu/s--d8urinch--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1607775279/paloma-horizontal-photo-pennyworth 93w, https://tv-fanatic-res.cloudinary.com/iu/s--r_HQDOcA--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607775279/paloma-horizontal-photo-pennyworth 125w, https://tv-fanatic-res.cloudinary.com/iu/s--xUgIRsxG--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1607775279/paloma-horizontal-photo-pennyworth 187w, https://tv-fanatic-res.cloudinary.com/iu/s--5e53t_rd--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1607775279/paloma-horizontal-photo-pennyworth 250w, https://tv-fanatic-res.cloudinary.com/iu/s--ZWppW5gG--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1607775279/paloma-horizontal-photo-pennyworth 312w, https://tv-fanatic-res.cloudinary.com/iu/s---X12dA1b--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1607775279/paloma-horizontal-photo-pennyworth 375w" /></div></div>
</div>
Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More
</a></li>
<li>
<a class="clearfix" href="/2020/12/laurence-leboeuf-on-transplant-mags-and-what-comes-next/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Laurence Leboeuf On Transplant, Mags, And What Comes Next!" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--d9tbzHEG--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607032899/cast-of-transplant" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--Qf2lm-IJ--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1607032899/cast-of-transplant 31w, https://tv-fanatic-res.cloudinary.com/iu/s--eDbB5q5b--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1607032899/cast-of-transplant 62w, https://tv-fanatic-res.cloudinary.com/iu/s--RC3oHgeA--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1607032899/cast-of-transplant 93w, https://tv-fanatic-res.cloudinary.com/iu/s--d9tbzHEG--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607032899/cast-of-transplant 125w, https://tv-fanatic-res.cloudinary.com/iu/s--nREqpOI3--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1607032899/cast-of-transplant 187w, https://tv-fanatic-res.cloudinary.com/iu/s--ruMIbPu9--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1607032899/cast-of-transplant 250w, https://tv-fanatic-res.cloudinary.com/iu/s--Hnx3XNYF--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1607032899/cast-of-transplant 312w, https://tv-fanatic-res.cloudinary.com/iu/s--hZvPFKX5--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1607032899/cast-of-transplant 375w" /></div></div>
</div>
Laurence Leboeuf On Transplant, Mags, And What Comes Next!
</a></li>
<li>
<a class="clearfix" href="/2020/12/looking-back-on-the-100-lola-flanery-on-madis-story-getting-to-g/" style="font-weight:bold;"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Looking Back On The 100: Lola Flanery on Madi&#39;s Story, Getting To Grow Up With A Character, and More!" class="lazyload" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1gacLfHk--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607055763/attachment/lolaf" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--aQVDPvXL--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1607055763/attachment/lolaf 31w, https://tv-fanatic-res.cloudinary.com/iu/s--x48LaP6F--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1607055763/attachment/lolaf 62w, https://tv-fanatic-res.cloudinary.com/iu/s--kkpS6VbP--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1607055763/attachment/lolaf 93w, https://tv-fanatic-res.cloudinary.com/iu/s--1gacLfHk--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1607055763/attachment/lolaf 125w, https://tv-fanatic-res.cloudinary.com/iu/s--ePzBh8xg--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1607055763/attachment/lolaf 187w, https://tv-fanatic-res.cloudinary.com/iu/s--_x_CNZhP--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1607055763/attachment/lolaf 250w, https://tv-fanatic-res.cloudinary.com/iu/s--7lh62eV2--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1607055763/attachment/lolaf 312w, https://tv-fanatic-res.cloudinary.com/iu/s--xJ_2T3SB--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1607055763/attachment/lolaf 375w" /></div></div>
</div>
Looking Back On The 100: Lola Flanery on Madi's Story, Getting To Grow Up With A Character, and More!
</a></li>
</ul>

</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/tags/interviews/">Interviews Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/christmas-she-wrote-poster/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Christmas She Wrote Poster" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--i9Q3KnKI--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042728/christmas-she-wrote-poster.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/threes-a-crowd-on-christmas-she-wrote/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Three&#39;s a Crowd on Christmas She Wrote" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Rh-_T1ox--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042711/threes-a-crowd-on-christmas-she-wrote.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/dylan-neal-on-christmas-she-wrote/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Dylan Neal on Christmas She Wrote" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--OzjWqqhr--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042687/dylan-neal-on-christmas-she-wrote.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tripp-asks-kayleigh-to-dance/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tripp Asks Kayleigh to Dance" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--s0ogqr_c--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042659/tripp-asks-kayleigh-to-dance.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/kayleigh-comforts-her-ex/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Kayleigh Comforts Her Ex" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--eK3P6rYN--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042622/kayleigh-comforts-her-ex.jpg" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tripp-smiles-at-kayleigh/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tripp Smiles at Kayleigh" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--wDRfwtwl--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1607042547/tripp-smiles-at-kayleigh.jpg" /></div></div>
</a></div>
</div>

</div>
</div>
</div>
<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/videos/tags/interviews/">Interviews Videos</a></h4>
<div class='row'>
<div class='col-xs-12'>
<a class="thumbnail" href="/videos/draft/"><div class="image_outter_wrapper" style="max-width:313px;"><div class="image_wrapper" style="padding-bottom:61.66134185303515%;"><img alt="Sarunas Jackson on Good Trouble, Games People Play, &amp; Finding His Swagger!" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--KBPYN1LZ--/t_v_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1567061546/video/draft.jpg" /></div></div>
<div class='caption'>Sarunas Jackson on Good Trouble, Games People Play, &amp; Finding His Swagger!</div>
</a></div>
</div>
<div class='row videos'>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/superstore-lauren-ash-discusses-dinas-birds-and-the-finales-gian/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="Superstore: Lauren Ash Discusses Dina&#39;s Birds &amp; Teases &quot;Giant&quot; Cliffhanger " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nZvYJ2zY--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1556938369/video/superstore-lauren-ash-discusses-dinas-birds-and-the-finales-gian.png" /></div></div>
<div class='caption'>Superstore: Lauren Ash Discusses Dina's Birds &amp; Teases &quot;Giant&quot; Cliffhanger </div>
</a></div>
<div class='col-xs-6'>
<a class="thumbnail" href="/videos/superstore-america-ferrera-talks-amy-and-jonahs-relationship-and/"><div class="image_outter_wrapper" style="max-width:150px;"><div class="image_wrapper" style="padding-bottom:62.0%;"><img alt="Superstore: America Ferrera Talks Amy and Jonah&#39;s Relationship &amp; More!" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--TMIL4MNY--/t_v_small_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1556915990/video/superstore-america-ferrera-talks-amy-and-jonahs-relationship-and.png" /></div></div>
<div class='caption'>Superstore: America Ferrera Talks Amy and Jonah's Relationship &amp; More!</div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/tags/">Tags</a></li> <li><a href="/tags/interviews/">Interviews</a></li> <li>Paloma Faith Talks Pennyworth Season 2, Filming During COVID-19, &amp; More</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/ted-lasso/">Ted Lasso</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/yellowstone/">Yellowstone</a></li>
<li><a href="/shows/p-valley/">P-Valley</a></li>
<li><a href="/shows/station-19/">Station 19</a></li>
<li><a href="/shows/star-trek-discovery/">Star Trek: Discovery</a></li>
<li><a href="/shows/a-million-little-things/">A Million Little Things</a></li>
<li><a href="/shows/bones/">Bones</a></li>
<li><a href="/shows/the-blacklist/">The Blacklist</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/virgin-river/">Virgin River</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2020/12/">December 2020</a></li>
<li><a href="/2020/11/">November 2020</a></li>
<li><a href="/2020/10/">October 2020</a></li>
<li><a href="/2020/09/">September 2020</a></li>
<li><a href="/2020/08/">August 2020</a></li>
<li><a href="/2020/07/">July 2020</a></li>
<li><a href="/2020/06/">June 2020</a></li>
<li><a href="/2020/05/">May 2020</a></li>
<li><a href="/2020/04/">April 2020</a></li>
<li><a href="/2020/03/">March 2020</a></li>
<li><a href="/2020/02/">February 2020</a></li>
<li><a href="/2020/01/">January 2020</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
<li><a href="/2010/">2010 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2020 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2020 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
