<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>Power Season 6 Episode 14 Review: Reversal of Fortune  - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/' property='og:url'>
<meta content='Power Season 6 Episode 14 Review: Reversal of Fortune ' property='og:title'>
<meta content="Rashad Tate's campaign sputters after Ghost joins a rival's ticket on Power Season 6 Episode 14 and he becomes desperate to get rid of Ghost. Read on! " property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--WTIEVYt9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='470' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--QY67gzii--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795386/tate-asks-a-favor-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='406' property='og:image:width'>
<meta content='614' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--WTIEVYt9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='470' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ZW-j55xB--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794968/tariq-questioned-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='425' property='og:image:width'>
<meta content='619' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--YCuvkdEs--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794787/stone-cold-tommy-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='373' property='og:image:width'>
<meta content='604' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--wQrspxQo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794851/getting-ready-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='391' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ZhDW0qIM--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795263/at-truth-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='329' property='og:image:width'>
<meta content='610' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--Z2kXJIVy--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795449/ready-to-shoot-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='374' property='og:image:width'>
<meta content='606' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--tklHdl7k--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795323/ramona-looks-on-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='392' property='og:image:width'>
<meta content='616' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--83RbPS3g--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1533476782/tariq-on-campus-power-season-5-episode-6.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--KNhSrE_r--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795531/a-meeting-with-tariq-power-season-6-episode-14.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='465' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--KnoQGELA--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1557278476/cookie-and-lucious-relationship-empire.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='493' property='og:image:height'>
<meta content='2020-01-26T21:00:00-05:00' property='article:published_time'>
<meta content='2020-01-26T13:33:54-05:00' property='article:modified_time'>
<meta content='Power' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Whitney Evans' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Power Season 6 Episode 14 Review: Reversal of Fortune ' name='twitter:title'>
<meta content="Rashad Tate's campaign sputters after Ghost joins a rival's ticket on Power Season 6 Episode 14 and he becomes desperate to get rid of Ghost. Read on! " name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--WTIEVYt9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png' name='twitter:image:src'>

<meta content="Rashad Tate&#39;s campaign sputters after Ghost joins a rival&#39;s ticket on Power Season 6 Episode 14 and he becomes desperate to get rid of..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'Power');
ga('set', 'dimension2', 'Whitney Evans');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "power", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/","mainEntityOfPage":"https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/","headline":"Power Season 6 Episode 14 Review: Reversal of Fortune","datePublished":"2020-01-26T21:00:00-05:00","dateModified":"2020-01-26T13:33:54-05:00","description":"Rashad Tate's campaign sputters after Ghost joins a rival's ticket on Power Season 6 Episode 14 and he becomes desperate to get rid of Ghost. Read on! ","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--yQqXlzYx--/f_auto,q_auto/v1579794574/new-faces-power-season-6-episode-14","height":562,"width":752},"author":{"@type":"Person","name":"Whitney Evans"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='1953' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="Power" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--_baYegyT--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1433317435/banner/power.jpg" /></div></div>
<div class='title'>
<h1><a href="/shows/power/">Power</a></h1>
<span class='airs'>
Sundays
 8:00 PM
on
Starz
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/power/">Power News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/power/tags/reviews/">Power Reviews</a></li>
<li><a class="" data-title="Watch Online" href="/shows/power/full-episodes/">Power Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/power/episodes/">Power Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/power/">Power Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/power/">Power Pictures</a></li>
<li><a class="" data-title="Videos" href="/videos/shows/power/">Power Videos</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow Power</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>Power Season 6 Episode 14 Review: Reversal of Fortune </h1>
<small>
<a href="/authors/whippy/" rel="author"><img alt="Whippy" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--1dwK4R-P--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1520206565/user/whippy.jpg" />
<a href="/authors/whippy/" rel="author">Whitney Evans</a>
</a>at
<time datetime="2020-01-26T21:00:00-05:00" itemprop="datePublished">January 26, 2020  9:00 pm</time>.
</small>
</header>
<div class='body'>
<p>
	Have you always wanted to meet Rashad Tate's family and watch his comeback from the brink of losing it all?</p>
<p>
	If the answer is yes, then <a href="/shows/power/episodes/season-6/reversal-of-fortune/">Power Season 6 Episode 14</a> is the one for you. </p>
<p>
	And if the answer was no, well then, you probably weren't thrilled with the second-to-last episode EVER of Power which offered more Rashad Tate than we've gotten since we met the man. </p>
<div style="max-width:396px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tate-asks-a-favor-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:151.5151515151515%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--QY67gzii--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795386/tate-asks-a-favor-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--kFfGDI4V--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795386/tate-asks-a-favor-power-season-6-episode-14.png" class="lazyload" alt="Tate Asks A Favor - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	It's been a frustrating ride over the back-half of this season because we've spent such little time with the characters that made this show what it became. </p><div id="stp_target"></div>
<p>
	No offense to the characters or the actors who portray them, but Dre, Paz, and Tate aren't central figures in this world. They've added to this world and are important pieces of the story in their own right, but they aren't the main attractions. </p>
<p>
	It feels odd to bid Power adieu and barely see Ghost, Tommy, and Tasha who have been there from day one. </p>
<p>
	And it's not even like these installments have been bad, but considering how close we are to the end, they've felt incredibly out of place. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/new-faces-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:74.61538461538461%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--WTIEVYt9--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--vS_oCYGG--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png" class="lazyload" alt="New Faces - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	Reliving the day of Ghost's deaths through all these different eyes hasn't been as fascinating as perhaps it was envisioned to be. </p>
<p>
	For Tate, much like everyone else, the day of the shooting was a wild twenty-four hours that had some highs and some lows. And like everyone else, Tate was blaming all of his current misfortune on Ghost. </p>
<p>
	Tate was so disillusioned with Ghost and wanting him dead that he called up a violent, country-loving father-and-son duo to kill Ghost for him. </p>
<p>
	Croop and Carter made their way up the 95 corridor to kill a man whose name they didn't even know for a payday. And when Tate tried to back out, they weren't taking no for an answer. </p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tariq-questioned-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:145.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ZW-j55xB--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794968/tariq-questioned-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--UkiBXiCM--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794968/tariq-questioned-power-season-6-episode-14.png" class="lazyload" alt="Tariq Questioned - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	For as smart as he can be at times, Tate can also be dumb and naive. And him thinking that he could just tell the men to turn around and go home was him showing us both of those things. </p>
<p>
	Groop and Carter were on a mission to kill Ghost, but they somehow missed Tommy being there, as well. </p>
<p>
	We've been trying to figure out who was after Ghost or Tommy since <a href="https://www.tvfanatic.com/2019/11/power-season-6-episode-10-review-no-one-can-stop-me/">Power Season 6 Episode 10</a>, so it was good to finally piece things together. </p>
<p>
	But again, did we really need a whole episode of Tate to get the information?</p>
<div style="max-width:370px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/stone-cold-tommy-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:162.16216216216216%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--YCuvkdEs--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794787/stone-cold-tommy-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--gUCQ-ZJA--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794787/stone-cold-tommy-power-season-6-episode-14.png" class="lazyload" alt="Stone Cold Tommy - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	Carter's escape from the shootout led him on a path to revenge and he wound up in Tate's brother's backyard. </p>
<p>
	If nothing else, we did get the feeling that Tate's family was lovely, and Kamaal seems like a much better version of Tate. He called him out on all the crap he's always spewing and held him accountable. </p>
<p>
	<blockquote>
<p>Kamaal: Just tell me if Imma have to arrest you after all this is over. <br>Rashad: Nah. My hands are clean. <br>Kamaal: Of course they are. You better stay lucky. </p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/of-course-they-are-you-better-stay-lucky/">Of course they are. You better stay lucky.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Carter's death by Kamaal's hand leading them both to the police station and then over to Truth was awfully convenient. And it set the stage for Tate's big redemption moment. </p>
<p>
	Unlike Dre, who ended up dead in the end, or Paz, who never got justice for Angela or Tommy and lost the only family he'd ever known, Tate benefitted from Ghost's death. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/getting-ready-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:62.11538461538461%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--wQrspxQo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794851/getting-ready-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--L2z5pDZr--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794851/getting-ready-power-season-6-episode-14.png" class="lazyload" alt="Getting Ready - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	He was off the Lorette Walsh ticket, his misdeeds were being made public, and it opened Tate to slide in and make himself the perfect candidate. </p>
<p>
	He'd never lost the support of certain people in the community, but without the backing of the Democratic Party, he no longer had resources. </p>
<p>
	Ghost's death made Lorette vulnerable, and it strengthened Tate's appeal to the voters that Ghost was trying to steal away. </p>
<p>
	And since this is Rashad Tate we're talking about, he seized the opportunity and then some, even going as far as to accept the nomination in a church. </p>
<div style="max-width:323px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/at-truth-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:185.75851393188853%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ZhDW0qIM--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795263/at-truth-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--d5LtUc30--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795263/at-truth-power-season-6-episode-14.png" class="lazyload" alt="At Truth - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	Never change, Rashad. </p>
<p>
	One thing he couldn't do was go quietly into the night, and his decision to drag Ramona on his way to the top was perfectly in line with who he is.</p>
<p>
	He has zero use for Ramona at this stage of the game, and she did everything she could to tank his campaign, so why not return the favor and sink her reputation? </p>
<p>
	Tate was literally on cloud nine in a hotel room he didn't pay for lounging a fresh robe when he saw the news and learned that Ghost's killer had been identified. </p>
<p>
	We, of course, didn't get to see who that was, but we are oh, so close to getting that answer. </p>
<div style="max-width:370px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/ready-to-shoot-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:162.16216216216216%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--Z2kXJIVy--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795449/ready-to-shoot-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--wm6MEEhA--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795449/ready-to-shoot-power-season-6-episode-14.png" class="lazyload" alt="Ready To Shoot - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	There are three suspects left, and I think at this point we can count out Saxe. Tommy had a visceral reaction to seeing the shooter on <a href="https://www.tvfanatic.com/2020/01/power-season-6-episode-13-review-its-always-your-fault/">Power Season 6 Episode 13</a>, and he would have shot before Ghost even had a chance to tell him otherwise if he'd seen Saxe's face. </p>
<p>
	That leaves us with Tasha and Tariq, and I'm putting my bold prediction out there that the person who pulls the trigger is ... Tasha. </p>
<p>
	Tasha played it cool when Tate approached her and told her that Ghost was planning to throw Tariq under the bus, but you could see the wheels in her head spinning. </p>
<p>
	Tasha has done many things to protect the St. Patrick family, including sacrificing her happiness. And to think that Ghost's willingness to preserve his self-interests over the family would have been enough to push her over the edge.</p>
<div style="max-width:381px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/ramona-looks-on-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:157.48031496062993%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--tklHdl7k--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795323/ramona-looks-on-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--7vT6Ve0L--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795323/ramona-looks-on-power-season-6-episode-14.png" class="lazyload" alt="Ramona Looks On - Power Season 6 Episode 14 "></div></a>
</div>
<p>
	She would never want Tariq to live with the memory of having killed his father.</p>
<p>
	<strong>Everything Else You Need To Know</strong></p>
<ul>
	<li>
		Fun fact: The actor who played Kamaal is Lahmard Tate aka Larenz Tate's real-life brother. As if you couldn't tell by the face and the voice.</li>
</ul>
<ul>
	<li>
		It wasn't even remotely professional to take Tate to the crime scene at Truth. And those cops he was talking to at the station seemed like caricatures. </li>
</ul>
<p>
	<div class="slideshow_teaser image_outter_wrapper ggnoads">
<a data-event-action="teaser" data-event-label="Power: 19 Times Tariq Irritated Everyone" data-event="slideshow" href="/slideshows/power-19-times-tariq-irritated-everyone/"><div class="image_wrapper" style="padding-bottom: 62.5%">
<img alt="" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--DCjVcEST--/c_fill,h_200,w_320/c_fill,h_200,l_upload:everyones-in-danger-power,w_320,x_324/c_fill,h_200,l_upload:slides:3169:becoming-a-bully,w_320,x_-162,y_204/c_fill,h_200,l_upload:face-to-face-power-season-5-episode-8,w_320,x_162,y_102/f_auto,fl_lossy,q_auto:420/v1533476782/tariq-on-campus-power-season-5-episode-6.jpg">
</div>
<div class="title">
Power: 19 Times Tariq Irritated Everyone
</div>
<div class="start">
Start Gallery
<i class="fa fa-long-arrow-right"></i>
</div>
</a>
</div>
</p>
<ul>
	<li>
		It's crazy to think how a show that started with Truth as a cover for the drug business has its penultimate episode of the series revolving around a political campaign. </li>
</ul>
<ul>
	<li>
		Cedric the Entertainer was too much as Croop. Singing while a man's leg was getting carved up was sadistic. </li>
</ul>
<p>
	We've only got one more episode of Power to digest, and for all our sakes, I hope it's an instant classic. </p>
<p>
	They've taken us inside the days of those who didn't murder Ghost, and it's finally time to get inside the head of the person who did. </p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/a-meeting-with-tariq-power-season-6-episode-14/"><div class="image_wrapper" style="padding-bottom:73.84615384615385%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--KNhSrE_r--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795531/a-meeting-with-tariq-power-season-6-episode-14.png" data-pin-description="Power Season 6 Episode 14 Review: Reversal of Fortune " data-pin-url="https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--QNWEN7TU--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795531/a-meeting-with-tariq-power-season-6-episode-14.png" class="lazyload" alt="A Meeting With Tariq - Power Season 6 Episode 14"></div></a>
</div>
<p>
	Who do you think shot Ghost?</p>
<p>
	Did you like the Tate centric episode?</p>
<p>
	How do you think the series will end?</p>
<p>
	As always, leave your comments down below so we can discuss. And remember that you can always <a href="/shows/power/full-episodes/">watch Power online</a> via TV Fanatic anytime you wish. </p>
<p>
	And we sure would appreciate a follow of our new Twitter account as we work to rebuild our audience!</p>
<h4 style="box-sizing: border-box; font-family: Merriweather, serif; line-height: 1.1; color: rgb(51, 51, 51); margin-top: 11px; margin-bottom: 11px; font-size: 20px;">
	<a href="https://twitter.com/tvfanatic/" style="box-sizing: border-box; background-color: transparent; color: rgb(0, 76, 135); outline: 0px;" target="_blank">@TVFanatic</a>
</h4>
<p>
	<div class="slideshow_teaser image_outter_wrapper ggnoads">
<a data-event-action="teaser" data-event-label="18 Shows Ending in 2019-20" data-event="slideshow" href="/slideshows/13-shows-ending-in-2019-20/"><div class="image_wrapper" style="padding-bottom: 62.5%">
<img alt="" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--urJf-fSI--/c_fill,h_200,w_320/c_fill,h_200,l_upload:phil-on-the-phone-modern-family-s10e14,w_320,x_324/c_fill,h_200,l_upload:conversation-among-friends-criminal-minds-s14e15,w_320,x_-162,y_204/c_fill,h_200,l_upload:feeling-the-pressure-madam-secretary-s5e20,w_320,x_162,y_102/f_auto,fl_lossy,q_auto:420/v1557278476/cookie-and-lucious-relationship-empire.jpg">
</div>
<div class="title">
18 Shows Ending in 2019-20
</div>
<div class="start">
Start Gallery
<i class="fa fa-long-arrow-right"></i>
</div>
</a>
</div>
</p>

<div class='widget'>
<h3>
<a href="/shows/power/episodes/season-6/reversal-of-fortune/"><span>Reversal of Fortune </span></a>
Review
</h3>
<b>Editor Rating:</b>
2.5
/ 5.0
<ul class="star-rating"><li class="current-rating" style="width:50%;">2.5 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_32821'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li class="current-rating" style="width:100%;">5.0 / 5.0</li><li><a class="star star-1" data-method="post" data-remote="true" href="/shows/power/episodes/season-6/reversal-of-fortune/vote/?rating%5Brating%5D=1" rel="nofollow">1</a></li> <li><a class="star star-2" data-method="post" data-remote="true" href="/shows/power/episodes/season-6/reversal-of-fortune/vote/?rating%5Brating%5D=2" rel="nofollow">2</a></li> <li><a class="star star-3" data-method="post" data-remote="true" href="/shows/power/episodes/season-6/reversal-of-fortune/vote/?rating%5Brating%5D=3" rel="nofollow">3</a></li> <li><a class="star star-4" data-method="post" data-remote="true" href="/shows/power/episodes/season-6/reversal-of-fortune/vote/?rating%5Brating%5D=4" rel="nofollow">4</a></li> <li><a class="star star-5" data-method="post" data-remote="true" href="/shows/power/episodes/season-6/reversal-of-fortune/vote/?rating%5Brating%5D=5" rel="nofollow">5</a></li></ul></div>
<br>
<span class='numeric_rating'>
Rating:
<span>5.0</span>
/ 5.0
</span>
<span class='total_votes'>
(<span>1</span> Vote)
</span>
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="45283"><button class="btn btn-primary" data-href="/admin/post/86026/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/86026/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Whitney Evans</b> is a staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/Whip216">Twitter</a>.<P></p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/' data-id='86026' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-86026' data-disqus-url='https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-86026";
  var disqus_url = "https://www.tvfanatic.com/2020/01/power-season-6-episode-14-review-reversal-of-fortune/";
  var disqus_title = "Power Season 6 Episode 14 Review: Reversal of Fortune ";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "Power Season 6 Episode 14 Review: Reversal of Fortune "]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2020/01/watch-power-online-season-6-episode-13/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/power/" rel="tag">Power</a>, <a href="/tags/reviews/" rel="tag">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/power/episodes/reversal-of-fortune/">Power Season 6 Episode 14 Quotes</a></h4>
<blockquote>
<p>Rashad: Certain things even I can't pull off. Political comeback for me right now is impossible. <br>Reverend Macedon: No, that's where you're wrong. Book of Luke says, 'What's impossible with man, is possible with God.'<br>Rashad: Then tell the good Lord to get off his ass and send me a miracle. </p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/then-tell-the-good-lord-to-get-off-his-ass-and-send-me-a-miracle/">Then tell the good Lord to get off his ass and send me a miracle.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-01-26">January 26, 2020</time></li>
</ul>
</blockquote>
<blockquote>
<p>Rashad: Look Maal, there's nothing wrong with me wanting to win. <br>Kamaal: Not if you really in it to help the people. But if you just looking to clap back at St. Ptarick, that's just about your bruised ego. </p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/not-if-you-really-in-it-to-help-the-people-but-if-you-just-looki/">Not if you really in it to help the people. But if you just looking to clap back at St....</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2020-01-26">January 26, 2020</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/power/episodes/reversal-of-fortune/">Power Season 6 Episode 14 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/a-meeting-with-tariq-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="A Meeting With Tariq - Power Season 6 Episode 14" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Fxl7fN6h--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795531/a-meeting-with-tariq-power-season-6-episode-14.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/ready-to-shoot-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Ready To Shoot - Power Season 6 Episode 14 " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--fQWCkBcz--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795449/ready-to-shoot-power-season-6-episode-14.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tate-asks-a-favor-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tate Asks A Favor - Power Season 6 Episode 14 " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--1c7d5Le6--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795386/tate-asks-a-favor-power-season-6-episode-14.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/ramona-looks-on-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Ramona Looks On - Power Season 6 Episode 14 " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--6gXrWCuO--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795323/ramona-looks-on-power-season-6-episode-14.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/at-truth-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="At Truth - Power Season 6 Episode 14 " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--qSpbAJr4--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579795263/at-truth-power-season-6-episode-14.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tariq-questioned-power-season-6-episode-14/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tariq Questioned - Power Season 6 Episode 14 " class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nVb6j_vX--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794968/tariq-questioned-power-season-6-episode-14.png" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/power/episodes/season-6/reversal-of-fortune/","url":"https://www.tvfanatic.com/shows/power/episodes/season-6/reversal-of-fortune/","name":"Reversal of Fortune ","episodeNumber":14,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/power/episodes/season-6/","url":"https://www.tvfanatic.com/shows/power/episodes/season-6/","seasonNumber":6},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/power/","url":"https://www.tvfanatic.com/shows/power/","name":"Power"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2020-01-26","location":{"@type":"Country","name":"US"}},"description":"The FEDS close in on Ghost, while Tate enlists Dre's help in getting rid of his biggest rival on Power Season 6 Episode 14. ","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/power/full-episodes/season-6/reversal-of-fortune/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2020-01-26T00:00","availabilityEnds":"2021-01-26T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--uEWirBtR--/c_thumb,f_auto,g_auto,h_562,q_auto,w_375/v1579794574/new-faces-power-season-6-episode-14","height":562,"width":375}}</script>
<h4>
<div class='clearfix'>
<time class="air" datetime="2020-01-26">1/26/20</time>
<div class='number'><a href="/shows/power/episodes/season-6/reversal-of-fortune/">Power Season 6 Episode 14</a></div>
</div>
<div class='title'>Reversal of Fortune </div>
</h4>
<img alt="New Faces - Power Season 6 Episode 14 " src="https://tv-fanatic-res.cloudinary.com/iu/s--oWXJhRvn--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1579794574/new-faces-power-season-6-episode-14.png" />
<ul class='nav nav-pills'>
<li><a href="/2020/01/power-season-6-episode-14-review-reversal-of-fortune/">Review</a></li>
<li><a href="/quotes/shows/power/episodes/reversal-of-fortune/">Quotes</a></li>
<li><a href="/gallery/shows/power/episodes/reversal-of-fortune/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/power/">Power</a></li> <li><a href="/shows/power/episodes/season-6/">Power Season 6</a></li> <li><a href="/shows/power/episodes/season-6/reversal-of-fortune/">Power Season 6 Episode 14</a></li> <li>Power Review: Reversal of Fortune</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/the-magicians/">The Magicians</a></li>
<li><a href="/shows/this-is-us/">This Is Us</a></li>
<li><a href="/shows/titans/">Titans</a></li>
<li><a href="/shows/succession/">Succession</a></li>
<li><a href="/shows/the-100/">The 100</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/the-blacklist/">The Blacklist</a></li>
<li><a href="/shows/legacies/">Legacies</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/dynasty/">Dynasty</a></li>
<li><a href="/shows/chilling-adventures-of-sabrina/">Chilling Adventures of Sabrina</a></li>
<li><a href="/shows/the-resident/">The Resident</a></li>
<li><a href="/shows/vikings/">Vikings</a></li>
<li><a href="/shows/power/">Power</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2020/01/">January 2020</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
<li><a href="/2010/">2010 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2020 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2020 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
