<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>SEAL Team Season 5 Episode 7 Review: What&#39;s Past Is Prologue - TV Fanatic</title>
<link href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" rel="canonical" />

<link href="https://www.tvfanatic.com/rss.xml" rel="alternate" title="TV Fanatic Feed" type="application/atom+xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/' property='og:url'>
<meta content="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" property='og:title'>
<meta content="On SEAL Team Season 5 Episode 7, the Bravo team returned to Afghanistan with a bang. We have a full review of how it all played out. It's a lot of drama." property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--1ArBuNsR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636893314/jasons-new-plan-seal-team.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='449' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--lB2to6Qz--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898865/ray-close-up-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='795' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--UOQGeugh--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898847/ray-next-to-the-next-mission-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='840' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--R0kaktt---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898830/tight-squeeze-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='737' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--OiCip490--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898814/new-mission-time-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='799' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--HePjc-Cx--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898794/dangerous-drama-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='859' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CR6TKjqf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898753/clay-moves-on-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='813' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--yU-XZZiY--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898727/in-afghanistan-seal-team-s5e7.png' property='og:image'>
<meta content='image/png' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='848' property='og:image:height'>
<meta content='2021-11-14T10:00:00-05:00' property='article:published_time'>
<meta content='2021-11-14T09:38:29-05:00' property='article:modified_time'>
<meta content='SEAL Team' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Paul Dailly' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" name='twitter:title'>
<meta content="On SEAL Team Season 5 Episode 7, the Bravo team returned to Afghanistan with a bang. We have a full review of how it all played out. It's a lot of drama." name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--1ArBuNsR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636893314/jasons-new-plan-seal-team.jpg' name='twitter:image:src'>

<meta content="On SEAL Team Season 5 Episode 7, the Bravo team returned to Afghanistan with a bang. We have a full review of how it all played out. It&#39;s..." name="description"></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'SEAL Team');
ga('set', 'dimension2', 'Paul Dailly');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link as="style" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" rel="stylesheet" />
<link as="style" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "seal-team", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/","mainEntityOfPage":"https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/","headline":"SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue","datePublished":"2021-11-14T10:00:00-05:00","dateModified":"2021-11-14T09:38:29-05:00","description":"On SEAL Team Season 5 Episode 7, the Bravo team returned to Afghanistan with a bang. We have a full review of how it all played out. It's a lot of drama.","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--BgNnzXV4--/f_auto,q_auto/v1636893314/jasons-new-plan-seal-team","height":857,"width":1200},"author":{"@type":"Person","name":"Paul Dailly"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input class="form-control" id="q" name="q" placeholder="Search" type="search" />
<div class='input-group-btn'><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='2169' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="SEAL Team" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--3TYTMqkW--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1636075052/banner/seal-team.png" /></div></div>
<div class='title'>
<h1><a href="/shows/seal-team/">SEAL Team</a></h1>
<span class='airs'>
Sundays
on
Paramount+
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/seal-team/">SEAL Team News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/seal-team/tags/reviews/">SEAL Team Reviews</a></li>
<li><a class="" data-title="Watch Online" href="/shows/seal-team/full-episodes/">SEAL Team Watch Online</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/seal-team/episodes/">SEAL Team Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/seal-team/">SEAL Team Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/seal-team/">SEAL Team Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow SEAL Team</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue</h1>
<small>
<a href="/authors/pauldailly92/" rel="author"><img alt="Pauldailly92" class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--jzYlH3ci--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1437338558/user/pauldailly92.jpg" />
<a href="/authors/pauldailly92/" rel="author">Paul Dailly</a>
</a>at
<time datetime="2021-11-14T10:00:00-05:00" itemprop="datePublished">November 14, 2021 10:00 am</time>.
</small>
</header>
<div class='body'>
<p>
	Did that feel like the end of an important chapter?</p>
<p>
	<a href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/">SEAL Team Season 5 Episode 7</a> found the Bravo team members and their families making significant strides in their lives, and it was a fascinating hour of TV.</p>
<p>
	We'll start with Jason and Mandy because, holy hotness, where did that hookup come from?</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/jasons-new-plan-seal-team/"><div class="image_wrapper" style="padding-bottom:71.34615384615385%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--1ArBuNsR--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636893314/jasons-new-plan-seal-team.jpg" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--AnETwcwK--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636893314/jasons-new-plan-seal-team.jpg" class="lazyload" alt="Jason's New Plan - SEAL Team"></div></a>
</div>
<p>
	I figured Mandy would be gone for another period after <a href="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-6-review-man-on-fire/">SEAL Team Season 5 Episode 6</a>, so it was a pleasant surprise to have her back in the fold.</p><div id="stp_target"></div>
<p>
	Jason and Mandy have a lot of chemistry, but I still believe Mandy is hiding something from the rest of her friends.</p>
<p>
	There has to be more to the story, and my immediate concern is that Jason puts everything into a relationship with her, only for the rug to be pulled from under him when he least expects it.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/ray-close-up-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:126.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--lB2to6Qz--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898865/ray-close-up-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--oRE2enj3--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898865/ray-close-up-seal-team-s5e7.png" class="lazyload" alt="Ray Close Up - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	Still, it is nice to see Jason in such a happy place, especially when you consider the recent events that have pushed him to his limit.</p>
<p>
	David Boreanaz is bringing a vulnerability to Jason we haven't seen before, and it is helping drive home the fact that he's changed, possibly for good.</p>
<p>
	The other members of Bravo clearly have their feelings about Mandy, and you could cut the tension with a knife when she showed up at the gathering.</p>
<p>
	Sonny will probably never trust Mandy, and who can blame him? He's a person who leads with honor and transparency, and if someone breaks that trust, he struggles to communicate with them.</p>
<p>
	Sonny is not making the best of decisions. Asking Hannah to uproot her life and move in with him was clearly driven by the fact that Davis has moved on.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/ray-next-to-the-next-mission-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:133.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--UOQGeugh--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898847/ray-next-to-the-next-mission-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--LKxOPYlu--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898847/ray-next-to-the-next-mission-seal-team-s5e7.png" class="lazyload" alt="Ray Next to the Next Mission - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	He's been following Davis around like a lost puppy, and while they have a connection, Davis has the right idea about keeping it strictly professional between them.</p>
<p>
	Sonny didn't make the best decision by ditching Hannah in the first place, so it was a bitter pill to swallow that he had this miraculous realization that he wanted to complete his family.</p>
<p>
	The issue is that Hannah will always be second best to Davis. If Davis gives Sonny a glimmer of hope that they can have a relationship, Hannah will be dropped and left to pick up the pieces.</p>
<p>
	What if Hannah says goodbye to her business, moves to a new city, and Sonny realizes it isn't going to work? Hopefully, I'm wrong, but something about this seems like a rash decision that will come back to haunt them.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/tight-squeeze-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:117.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--R0kaktt---/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898830/tight-squeeze-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--otJAN6vL--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898830/tight-squeeze-seal-team-s5e7.png" class="lazyload" alt="Tight Squeeze - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	Clay confronting his issues with his father was a long time coming. It's just a shame it took a terminal diagnosis to get the ball rolling.</p>
<p>
	The fundamental issue is the lack of communication between them. If they can find a way to communicate how they truly feel, they will use whatever time they have left to repair their relationship.</p>
<p>
	I knew Ash had to have had a plan being in the area, and the show did a standup job of confronting the fact that they have unresolved issues.</p>
<p>
	It seemed like they were going to hug it out before Stella popped up to clear her throat. The acting from Max Theriot and C. Thomas Howell was on another level during this scene.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/new-mission-time-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:126.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--OiCip490--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898814/new-mission-time-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Cr-5r36X--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898814/new-mission-time-seal-team-s5e7.png" class="lazyload" alt="New Mission Time - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	The actual test will be whether they can truly put the past in the past and focus on the future. Clay is desperate not to make the same mistakes when he becomes a father, and it's nice to see him recognize he was a part of the problem.</p>
<p>
	Ray and his daughter's meeting with the veteran was tragic because it was a harrowing look at the fact that people who have served their country are now out on the streets.</p>
<p>
	Ray's apprehension about trusting the man was evident, but when he realized what he said was true, his feelings wholly changed. This is a very good story that needs to be told to raise awareness.</p>
<p>
	The return to Afghanistan was a long time coming, and because of what's going in the world now, it couldn't be more topical.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/dangerous-drama-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:136.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--HePjc-Cx--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898794/dangerous-drama-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--dmomLD77--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898794/dangerous-drama-seal-team-s5e7.png" class="lazyload" alt="Dangerous Drama - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	SEAL Team truly does excel when it mimics real-life events. The show is a great platform to raise awareness on the injustices of the world, and the commentary about how things have changed was a nice touch.</p>
<p>
	"What's Past is Prologue" felt like the end of a chapter and the beginning of something new. It felt like a season -- or series -- finale in that all of the characters reached pivotal points in life with some big decisions to make.</p>
<p>
	When you add that we still have half a season left, it leaves us with many possibilities about where the story will go next.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/clay-moves-on-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:129.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--CR6TKjqf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898753/clay-moves-on-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nWgJzm14--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898753/clay-moves-on-seal-team-s5e7.png" class="lazyload" alt="Clay Moves On - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	The trip to Afghanistan will probably become bigger because of what is going on there.</p>
<p>
	What did you think of Jason and Mandy's hookup? Do you think it will lead to something more?</p>
<p>
	What's your take on Sonny at this point?</p>
<p>
	Do you think Ray will take the veteran in and try to find him accommodation?</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/in-afghanistan-seal-team-s5e7/"><div class="image_wrapper" style="padding-bottom:134.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--yU-XZZiY--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898727/in-afghanistan-seal-team-s5e7.png" data-pin-description="SEAL Team Season 5 Episode 7 Review: What's Past Is Prologue" data-pin-url="https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--AsZfR138--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898727/in-afghanistan-seal-team-s5e7.png" class="lazyload" alt="In Afghanistan - SEAL Team Season 5 Episode 7"></div></a>
</div>
<p>
	Hit the comments below.</p>
<p>
	<strong>SEAL Team continues Sundays on Paramount+.</strong></p>

<p>
	<br>
	 </p>








<div class='widget'>
<h3>
<a href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/"><span>What&#39;s Past Is Prologue</span></a>
Review
</h3>
<b>Editor Rating:</b>
4.5
/ 5.0
<ul class="star-rating"><li class="current-rating" style="width:90%;">4.5 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_37157'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li class="current-rating" style="width:0%;">0.0 / 5.0</li><li><a class="star star-1" data-method="post" data-remote="true" href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/vote/?rating%5Brating%5D=1" rel="nofollow">1</a></li> <li><a class="star star-2" data-method="post" data-remote="true" href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/vote/?rating%5Brating%5D=2" rel="nofollow">2</a></li> <li><a class="star star-3" data-method="post" data-remote="true" href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/vote/?rating%5Brating%5D=3" rel="nofollow">3</a></li> <li><a class="star star-4" data-method="post" data-remote="true" href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/vote/?rating%5Brating%5D=4" rel="nofollow">4</a></li> <li><a class="star star-5" data-method="post" data-remote="true" href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/vote/?rating%5Brating%5D=5" rel="nofollow">5</a></li></ul></div>
<br>
Unrated
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="66541"><button class="btn btn-primary" data-href="/admin/post/96294/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/96294/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Paul Dailly</b> is the Associate Editor for TV Fanatic. Follow him on <a href="http://twitter.com/pauldailly1992">Twitter</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/' data-id='96294' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a data-toggle="tab" href="#facebook_comments" id="facebook_comments_tab" role="tab">Facebook</a>
</li>
<li role='presentation'>
<a data-toggle="tab" href="#disqus_comments" id="disqus_comments_tab" role="tab">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-96294' data-disqus-url='https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-96294";
  var disqus_url = "https://www.tvfanatic.com/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/";
  var disqus_title = "SEAL Team Season 5 Episode 7 Review: What\'s Past Is Prologue";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "SEAL Team Season 5 Episode 7 Review: What\'s Past Is Prologue"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div data-link="/2021/11/seal-team-season-5-episode-6-review-man-on-fire/" id="next_post_link"></div>
<small class='hidden-print'>
Tags:
<a href="/shows/seal-team/" rel="tag">SEAL Team</a>, <a href="/tags/reviews/" rel="tag">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/seal-team/episodes/whats-past-is-prologue/">SEAL Team Season 5 Episode 7 Quotes</a></h4>
<blockquote>
<p> We can make this a thing. </p>
<small>Jason</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/we-can-make-this-a-thing/">We can make this a thing.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-11-14">November 14, 2021</time></li>
</ul>
</blockquote>
<blockquote>
<p> Well, if it isn't Spook. </p>
<small>Sonny</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/well-if-it-isnt-spook/">Well, if it isn&#39;t Spook.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-11-14">November 14, 2021</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/seal-team/episodes/whats-past-is-prologue/">SEAL Team Season 5 Episode 7 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/ray-close-up-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Ray Close Up - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--VUai9Fs5--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898865/ray-close-up-seal-team-s5e7.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/ray-next-to-the-next-mission-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Ray Next to the Next Mission - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--kbBATeWz--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898847/ray-next-to-the-next-mission-seal-team-s5e7.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/tight-squeeze-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Tight Squeeze - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--TT23JToW--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898830/tight-squeeze-seal-team-s5e7.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/new-mission-time-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="New Mission Time - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--yCIjBFUv--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898814/new-mission-time-seal-team-s5e7.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/dangerous-drama-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Dangerous Drama - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--F39tDy2_--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898794/dangerous-drama-seal-team-s5e7.png" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/clay-moves-on-seal-team-s5e7/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Clay Moves On - SEAL Team Season 5 Episode 7" class="lazyload" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--eJiizHVz--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636898753/clay-moves-on-seal-team-s5e7.png" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/seal-team/episodes/season-5/whats-past-is-prologue/","url":"https://www.tvfanatic.com/shows/seal-team/episodes/season-5/whats-past-is-prologue/","name":"What's Past Is Prologue","episodeNumber":7,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/seal-team/episodes/season-5/","url":"https://www.tvfanatic.com/shows/seal-team/episodes/season-5/","seasonNumber":5},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/seal-team/","url":"https://www.tvfanatic.com/shows/seal-team/","name":"SEAL Team"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2021-11-14","location":{"@type":"Country","name":"US"}},"description":"On SEAL Team Season 5 Episode 7, the team tries to make some plans to move on with their lives, leading to a big development for Jason. How did it play out?","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/seal-team/full-episodes/season-5/whats-past-is-prologue/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2021-11-14T00:00","availabilityEnds":"2022-11-14T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--uIapV3KR--/c_thumb,f_auto,g_auto,h_857,q_auto,w_571/v1636893314/jasons-new-plan-seal-team","height":857,"width":571}}</script>
<h4>
<div class='clearfix'>
<time class="air" datetime="2021-11-14">11/14/21</time>
<div class='number'><a href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/">SEAL Team Season 5 Episode 7</a></div>
</div>
<div class='title'>What's Past Is Prologue</div>
</h4>
<img alt="Jason&#39;s New Plan - SEAL Team" src="https://tv-fanatic-res.cloudinary.com/iu/s--XeG5jQf4--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1636893314/jasons-new-plan-seal-team.jpg" />
<ul class='nav nav-pills'>
<li><a href="/2021/11/seal-team-season-5-episode-7-review-whats-past-is-prologue/">Review</a></li>
<li><a href="/quotes/shows/seal-team/episodes/whats-past-is-prologue/">Quotes</a></li>
<li><a href="/gallery/shows/seal-team/episodes/whats-past-is-prologue/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/seal-team/">SEAL Team</a></li> <li><a href="/shows/seal-team/episodes/season-5/">SEAL Team Season 5</a></li> <li><a href="/shows/seal-team/episodes/season-5/whats-past-is-prologue/">SEAL Team Season 5 Episode 7</a></li> <li>SEAL Team Review: What&#39;s Past Is Prologue</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/yellowstone/">Yellowstone</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/arcane/">Arcane</a></li>
<li><a href="/shows/legacies/">Legacies</a></li>
<li><a href="/shows/succession/">Succession</a></li>
<li><a href="/shows/9-1-1/">9-1-1</a></li>
<li><a href="/shows/on-my-block/">On My Block</a></li>
<li><a href="/shows/seal-team/">SEAL Team</a></li>
<li><a href="/shows/only-murders-in-the-building/">Only Murders In the Building</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/chicago-pd/">Chicago PD</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/the-rookie/">The Rookie</a></li>
<li><a href="/shows/ncis/">NCIS</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2021/11/">November 2021</a></li>
<li><a href="/2021/10/">October 2021</a></li>
<li><a href="/2021/09/">September 2021</a></li>
<li><a href="/2021/08/">August 2021</a></li>
<li><a href="/2021/07/">July 2021</a></li>
<li><a href="/2021/06/">June 2021</a></li>
<li><a href="/2021/05/">May 2021</a></li>
<li><a href="/2021/04/">April 2021</a></li>
<li><a href="/2021/03/">March 2021</a></li>
<li><a href="/2021/02/">February 2021</a></li>
<li><a href="/2021/01/">January 2021</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
<li><a href="/2011/">2011 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2021 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2021 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
