<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>All American: Homecoming Season 1 Episode 1 Review: Start Over - TV Fanatic</title>
<link rel="shortcut icon" type="image/x-icon" href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" />
<link rel="canonical" href="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" />

<link rel="alternate" type="application/atom+xml" title="TV Fanatic Feed" href="https://www.tvfanatic.com/rss.xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/' property='og:url'>
<meta content='All American: Homecoming Season 1 Episode 1 Review: Start Over' property='og:title'>
<meta content='On the All American: Homecoming series premiere, Simone Hicks starts college with family-caused setbacks. Read on for our full review of the episode!' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CiAbV2pf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--ZvU0UqcO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300963/moving-in-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='900' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--OhL0lrQd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489670/first-day-on-campus-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='543' property='og:image:width'>
<meta content='795' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--IVJ-pNBt--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489707/coach-turner-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='510' property='og:image:width'>
<meta content='801' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--TdbBk5vo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489721/clashing-opinions-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='438' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--DWa1kcES--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489694/connections-made-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='552' property='og:image:width'>
<meta content='801' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--BgZsPZna--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645301322/jrs-speech-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='594' property='og:image:width'>
<meta content='800' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CiAbV2pf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--yS6ckzef--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489740/damon-pitching-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='463' property='og:image:width'>
<meta content='640' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s---3RaltQt--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489915/thea-vs-simone-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='472' property='og:image:width'>
<meta content='640' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CFew5sSF--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300743/new-family-dinners-all-american-homecoming-s1e1.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='420' property='og:image:height'>
<meta content='2022-02-21T22:00:00-05:00' property='article:published_time'>
<meta content='2022-02-21T19:16:26-05:00' property='article:modified_time'>
<meta content='All American: Homecoming' property='article:tag'>
<meta content='Reviews' property='article:tag'>
<meta content='Laura Nowak' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='All American: Homecoming Season 1 Episode 1 Review: Start Over' name='twitter:title'>
<meta content='On the All American: Homecoming series premiere, Simone Hicks starts college with family-caused setbacks. Read on for our full review of the episode!' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--CiAbV2pf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg' name='twitter:image:src'>

<meta name="description" content="On the All American: Homecoming series premiere, Simone Hicks starts college with family-caused setbacks. Read on for our full review of..."></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'All American: Homecoming');
ga('set', 'dimension2', 'Laura Nowak');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link rel="stylesheet" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" as="style" />
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" as="style" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "all-american-homecoming", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<link href='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/amp/' rel='amphtml'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/","mainEntityOfPage":"https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/","headline":"All American: Homecoming Season 1 Episode 1 Review: Start Over","datePublished":"2022-02-21T22:00:00-05:00","dateModified":"2022-02-21T19:16:26-05:00","description":"On the All American: Homecoming series premiere, Simone Hicks starts college with family-caused setbacks. Read on for our full review of the episode!","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--o6kuiC_x--/f_auto,q_auto/v1645293325/college-life-all-american-homecoming","height":2000,"width":3000},"author":{"@type":"Person","url":"https://www.tvfanatic.com/authors/lbchatterbox/","name":"Laura Nowak"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input type="search" name="q" id="q" placeholder="Search" class="form-control" />
<div class='input-group-btn'><button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='3171' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="All American: Homecoming" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--kfUce8dk--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1645292951/banner/all-american-homecoming.jpg" class="lazyload" /></div></div>
<div class='title'>
<h1><a href="/shows/all-american-homecoming/">All American: Homecoming</a></h1>
<span class='airs'>
Mondays
 9:00 PM
on
The CW
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/all-american-homecoming/">All American: Homecoming News</a></li>
<li><a class="visible-sm" data-title="Episode Guide" href="/shows/all-american-homecoming/episodes/">All American: Homecoming Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/all-american-homecoming/">All American: Homecoming Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/all-american-homecoming/">All American: Homecoming Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow All American: Homecoming</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>All American: Homecoming Season 1 Episode 1 Review: Start Over</h1>
<small>
<a rel="author" href="/authors/lbchatterbox/"><img class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--lFHpxITv--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1625537807/user/lbchatterbox.jpg" alt="Lbchatterbox" />
<a rel="author" href="/authors/lbchatterbox/">Laura Nowak</a>
</a>at
<time datetime="2022-02-21T22:00:00-05:00" itemprop="datePublished">February 21, 2022 10:00 pm</time>.
</small>
</header>
<div class='body'>
<p>
	Everyone is always excited to begin college, but no one is really prepared for the trials or challenges they'll endure there.</p>
<p>
	Both Simone Hicks and Damon Sims were eager to start over and reinvent themselves at historic Bringston University in <a href="/shows/all-american-homecoming/episodes/season-1/start-over/">All American: Homecoming Season 1 Episode 1</a>.</p>
<p>
	It was not that easy. Past decisions and family drama followed them to college and presented setbacks that could alter the college experience.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/moving-in-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:142.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--ZvU0UqcO--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300963/moving-in-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--T65oN6TR--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300963/moving-in-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Moving in - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Part of leaving college was saying goodbye to your family and childhood. Simone's family acted like they were angry she didn't choose a university like Yale.</p><div id="stp_target"></div>
<p>
	Her parents didn't even take her to the airport. Baby Shay's parents acted more maternal when they hugged her goodbye, and Tariq drove her to the airport.</p>
<p>
	<blockquote>
<p>Jordan: I can’t believe your parents aren’t coming to see you off.<br>Simone: I can.<br></p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/i-cant-believe-your-parents-arent-coming-to-see-you-off/">I can’t believe your parents aren’t coming to see you off.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	So many first-year students had their parents helping them lug their belongings into the dorms. Simone looked small and lonely, trying to handle everything by herself.</p>
<p>
	She'd hoped her Aunt Amara would be there to help her, but her aunt was dealing with issues that could alter her career.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/first-day-on-campus-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:146.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--OhL0lrQd--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489670/first-day-on-campus-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--OrA_M8kO--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489670/first-day-on-campus-all-american-homecoming-s1e1.jpg" class="lazyload" alt="First Day on Campus - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Amara Patterson is such a strong woman. She was so unapologetic that she brought the cheating scandal to life,</p>
<p>
	<blockquote>
<p> I didn’t perpetrate that scandal! All I did was bring the cheating to life to protect this institution.</p>
<small>Amara</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/i-didnt-perpetrate-that-scandal-all-i-did-was-bring-the-cheating/">I didn’t perpetrate that scandal! All I did was bring the cheating to life to protect this...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Amara valued education above all else and believed that the parents should want their children to get a high-quality education and not be about sports.</p>
<p>
	While the President backed her, he also had his agenda, which meant the baseball team was also on a short lease.</p>
<p>
	They only had a few months to put together a championship team, or the funding would be cut.</p>
<div style="max-width:382px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/coach-turner-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:157.06806282722513%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--IVJ-pNBt--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489707/coach-turner-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--cISUI157--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489707/coach-turner-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Coach Turner - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Amara and Coach Turner both want to better the lives of these students.</p>
<p>
	Amara felt compelled to apologize to Coach Turner for exposing the scandal. She still doesn't know he's the one that sent her the anonymous tip.</p>
<p>
	If she did, she might be angrier and less apologetic. For now, she's the only one bearing the brunt of the anger.</p>
<p>
	She had her class load reduced, and angry parents were criticizing her.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/clashing-opinions-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:69.61538461538461%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--TdbBk5vo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489721/clashing-opinions-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--iYYd9HA4--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489721/clashing-opinions-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Clashing Opinions - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Damon felt the expectations of fixing the baseball team riding on his shoulders. His mother made it difficult for him to fit it by bragging about Damon's sacrifice by giving up his professional career to play baseball at Bringston.</p>
<p>
	<blockquote>
<p> Folks, you are looking at the new face of HBCU baseball. One day, his portrait will hang in these great halls, too.</p>
<small>Keena</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/folks-you-are-looking-at-the-new-face-of-hbcu-baseball-one-day-h/">Folks, you are looking at the new face of HBCU baseball. One day, his portrait will hang in...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Her publicity campaign had the opposite effect she wanted. The guys on the baseball team haven't warmed up to Damon since they see him as a benefactor and not an equal.</p>
<p>
	<blockquote>
<p>Damon: Your teammates aren’t giving me the warmest welcome.<br>JR: Maybe start referring to them as our teammates and stop reminding them every two seconds that you gave up the pros for Bringston.<br></p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/maybe-start-referring-to-them-as-our-teammates-and-stop-remindin/">Maybe start referring to them as our teammates and stop reminding them every two seconds that...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	More trouble brewed when Damon and Coach Turner clashed on preparing the team. When Damon didn't get his way, he walked out of practice, angering the coach.</p>
<p>
	Despite what the President thought, Coach Turner believed in treating all of his boys the same, something Damon had never experienced.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/connections-made-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:145.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--DWa1kcES--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489694/connections-made-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Bejr7xNP--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489694/connections-made-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Connections Made - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Damon and Simone still share an undeniable connection, as they did in the backdoor pilot.</p>
<p>
	It's too soon to judge if they will stay close friends or tread into the flirting territory.</p>
<p>
	Damon actually shared his family issues with Simone and his hopes of finding his birth parents.</p>
<p>
	<blockquote>
<p>Damon: Families are highly overrated.<br>Simone: Damm. Who hurt you when you were a child?<br>Damon: Let’s see, should we go with the parents who gave me up for adoption or the mom who loves baseball more than the son?<br></p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/lets-see-should-we-go-with-the-parents-who-gave-me-up-for-adopti/">Let’s see, should we go with the parents who gave me up for adoption or the mom who loves...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Like Simone, he found families complicated and would benefit from a newly created family of friends.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/jrs-speech-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:134.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--BgZsPZna--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645301322/jrs-speech-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--LKjwczIQ--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645301322/jrs-speech-all-american-homecoming-s1e1.jpg" class="lazyload" alt="JR's speech - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	The first half of the series premiere felt a little slow as it was reestablishing information we already knew from the backdoor pilot.</p>
<p>
	The stakes grew higher when the college party and the sports scenes started.</p>
<p>
	Simone ran into Cam Hawkins at the party, who knew all her secrets from high school, and Simone didn't want everyone to know at Bringston to realize she was a teenage mom.</p>
<p>
	Simone wanted to start fresh at college, but college parties and hangovers have consequences.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/college-life-all-american-homecoming/"><div class="image_wrapper" style="padding-bottom:66.53846153846153%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--CiAbV2pf--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--8UqaP_T3--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg" class="lazyload" alt="College life - All American: Homecoming"></div></a>
</div>
<p>
	Simone seemed to forget how hard Keisha, Nathaniel, and others liked to party from her visit during Homecoming weekend.</p>
<p>
	They wanted to distract her from being homesick that they got her drunk, but Simone was so hungover she could barely function during tennis drills with Thea the next day.</p>
<p>
	In a scrimmage match against Coach Shaw's new team, the baseball team had to prove themselves too.</p>
<p>
	Watching the baseball and tennis sequences was one of the best parts since they showed these students' athletic drive.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/damon-pitching-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:138.0%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--yS6ckzef--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489740/damon-pitching-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--IjGdWmuw--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489740/damon-pitching-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Damon pitching - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Both Simone and Damon had to swallow their pride and prove they could do better.</p>
<p>
	Damon was so used to being the hotshot player that everyone obsessed over that he needed to work on his teamwork skills. In return, Coach Turner said the rest of the guys needed some of Damon's drive and passion.</p>
<p>
	It may take some time before Damon learns to communicate well with others.</p>
<p>
	On the other hand, Simone needs to prove that she belongs on the tennis team and isn't just a party girl, since so far, she hasn't made a great impression on the coach.</p>
<p>
	<blockquote>
<p> See on this team nothing just gets handed to you. It has to be earned. That’s what makes us the best.</p>
<small>Thea</small>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/see-on-this-team-nothing-just-gets-handed-to-you-it-has-to-be-ea/">See on this team nothing just gets handed to you. It has to be earned. That’s what makes us...</a>
</li>
<li>
</ul>
</blockquote>
</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/thea-vs-simone-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:135.5%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s---3RaltQt--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489915/thea-vs-simone-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--_DhpO_h2--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489915/thea-vs-simone-all-american-homecoming-s1e1.jpg" class="lazyload" alt="Thea vs. Simone - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	All American: Homecoming focused on building a new type of family so that the bringston University students support each other through rough times.</p>
<p>
	When Simone learned her parents didn't pay for her room and board, her Aunt Amara immediately offered Simone a place to stay, and Damon and his friends offered to help her move.</p>
<p>
	The students are all one tribal family. They look out for each other. It's comforting to have an adult still looking out for them as it's evident that Amara cares for all of them and their successes.</p>
<p>
	<blockquote>
<p>Nathianel: If the food is always like this, can we make this a regular thing?<br>Simone: I actually really like that.<br>Amara: Okay. Family dinner—once a week.<br></p>
<ul class="details hidden-print">
<li>
<i class="fa fa-link"></i> Permalink: <a href="/quotes/okay-family-dinner-once-a-week/">Okay. Family dinner—once a week.</a>
</li>
<li>
</ul>
</blockquote>
</p>
<p>
	Damon realized that families don't always need to be blood-related. JR asked about Damon's family in the cliffhanger scene, and then we saw him looking at some baby photos. Could JR and Damon be biological brothers?</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/new-family-dinners-all-american-homecoming-s1e1/"><div class="image_wrapper" style="padding-bottom:66.73076923076923%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--CFew5sSF--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300743/new-family-dinners-all-american-homecoming-s1e1.jpg" data-pin-description="All American: Homecoming Season 1 Episode 1 Review: Start Over" data-pin-url="https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--jHDOYF99--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645300743/new-family-dinners-all-american-homecoming-s1e1.jpg" class="lazyload" alt="New Family Dinners - All American: Homecoming Season 1 Episode 1"></div></a>
</div>
<p>
	Over to you, All American: Homecoming Fanatics. Are you intrigued by Simone's start at Bringston University?</p>
<p>
	Do you think Damon can connect with Coach Turner and his teammates so the team can succeed? Chime in below in the comments.</p>
<p>
	Remember, if you missed an episode, you can <a href="/shows/all-american-homecoming/full-episodes/">watch All American: Homecoming online</a> right here via TV Fanatic.</p>
<p>
	All American: Homecoming airs at 9/8c on Mondays on the CW.</p>



<div class='widget'>
<h3>
<a href="/shows/all-american-homecoming/episodes/season-1/start-over/"><span>Start Over</span></a>
Review
</h3>
<b>Editor Rating:</b>
4.5
/ 5.0
<ul class="star-rating"><li style="width:90%;" class="current-rating">4.5 / 5.0</li><li><i class="star-1">1</i></li> <li><i class="star-2">2</i></li> <li><i class="star-3">3</i></li> <li><i class="star-4">4</i></li> <li><i class="star-5">5</i></li></ul>
<div class='user_rating'>
<b>User Rating:</b>
<div class='rating-form' id='rating_37724'>
<div class='alert alert-danger error' style='display:none;margin:10px;'></div>
<div class='alert alert-success success' style='display:none;margin:10px;'></div>
<div class='inline-rating'><ul class="star-rating"><li style="width:100%;" class="current-rating">5.0 / 5.0</li><li><a class="star star-1" rel="nofollow" data-remote="true" data-method="post" href="/shows/all-american-homecoming/episodes/season-1/start-over/vote/?rating%5Brating%5D=1">1</a></li> <li><a class="star star-2" rel="nofollow" data-remote="true" data-method="post" href="/shows/all-american-homecoming/episodes/season-1/start-over/vote/?rating%5Brating%5D=2">2</a></li> <li><a class="star star-3" rel="nofollow" data-remote="true" data-method="post" href="/shows/all-american-homecoming/episodes/season-1/start-over/vote/?rating%5Brating%5D=3">3</a></li> <li><a class="star star-4" rel="nofollow" data-remote="true" data-method="post" href="/shows/all-american-homecoming/episodes/season-1/start-over/vote/?rating%5Brating%5D=4">4</a></li> <li><a class="star star-5" rel="nofollow" data-remote="true" data-method="post" href="/shows/all-american-homecoming/episodes/season-1/start-over/vote/?rating%5Brating%5D=5">5</a></li></ul></div>
<br>
<span class='numeric_rating'>
Rating:
<span>5.0</span>
/ 5.0
</span>
<span class='total_votes'>
(<span>1</span> Vote)
</span>
</div>

</div>
</div>

<div class="buttons admin edit_object_links" data-user-id="33370"><button class="btn btn-primary" data-href="/admin/post/97625/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/97625/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Laura Nowak</b> is a staff writer for TV Fanatic. Follow her on <a href="http://twitter.com/lbchatterbox2">Twitter</a>.</p></p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/' data-id='97625' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a role="tab" data-toggle="tab" id="facebook_comments_tab" href="#facebook_comments">Facebook</a>
</li>
<li role='presentation'>
<a role="tab" data-toggle="tab" id="disqus_comments_tab" href="#disqus_comments">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-97625' data-disqus-url='https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-97625";
  var disqus_url = "https://www.tvfanatic.com/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/";
  var disqus_title = "All American: Homecoming Season 1 Episode 1 Review: Start Over";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "All American: Homecoming Season 1 Episode 1 Review: Start Over"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div id="next_post_link" data-link="/2022/02/all-american-homecomings-geffri-maya-previews-whats-next-for-sim/"></div>
<small class='hidden-print'>
Tags:
<a rel="tag" href="/shows/all-american-homecoming/">All American: Homecoming</a>, <a rel="tag" href="/tags/reviews/">Reviews</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/all-american-homecoming/episodes/start-over/">All American: Homecoming Season 1 Episode 1 Quotes</a></h4>
<blockquote>
<p> Folks, you are looking at the new face of HBCU baseball. One day, his portrait will hang in these great halls, too.</p>
<small>Keena</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/folks-you-are-looking-at-the-new-face-of-hbcu-baseball-one-day-h/">Folks, you are looking at the new face of HBCU baseball. One day, his portrait will hang in...</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2022-02-19">February 19, 2022</time></li>
</ul>
</blockquote>
<blockquote>
<p>Jordan: I can’t believe your parents aren’t coming to see you off.<br>Simone: I can.<br></p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/i-cant-believe-your-parents-arent-coming-to-see-you-off/">I can’t believe your parents aren’t coming to see you off.</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2022-02-19">February 19, 2022</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/all-american-homecoming/episodes/start-over/">All American: Homecoming Season 1 Episode 1 Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/jrs-speech-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="JR&#39;s speech - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--dQyPJvVk--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645301322/jrs-speech-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/damon-pitching-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Damon pitching - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--Ex57HYzh--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489740/damon-pitching-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/the-movers-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="The Movers - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--5R1riXuA--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645301225/the-movers-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/thea-vs-simone-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Thea vs. Simone - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--QSzLvcyM--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489915/thea-vs-simone-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/clashing-opinions-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Clashing Opinions - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--9TvFiev_--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489721/clashing-opinions-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/coach-turner-all-american-homecoming-s1e1/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Coach Turner - All American: Homecoming Season 1 Episode 1" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ybFQ_IbI--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645489707/coach-turner-all-american-homecoming-s1e1.jpg" class="lazyload" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>
<div class='flat_widget'>
<div id='selected_episode'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","@id":"https://www.tvfanatic.com/shows/all-american-homecoming/episodes/season-1/start-over/","url":"https://www.tvfanatic.com/shows/all-american-homecoming/episodes/season-1/start-over/","name":"Start Over","episodeNumber":1,"partOfSeason":{"@type":"TVSeason","@id":"https://www.tvfanatic.com/shows/all-american-homecoming/episodes/season-1/","url":"https://www.tvfanatic.com/shows/all-american-homecoming/episodes/season-1/","seasonNumber":1},"partOfSeries":{"@type":"TVSeries","@id":"https://www.tvfanatic.com/shows/all-american-homecoming/","url":"https://www.tvfanatic.com/shows/all-american-homecoming/","name":"All American: Homecoming"},"releasedEvent":{"@type":"PublicationEvent","startDate":"2022-02-21","location":{"@type":"Country","name":"US"}},"description":"On All American: Homecoming Season 1 Episode 1, Simone experiences setbacks upon moving into the college dorm, and Coach Turner and Damon are hot with news about the team. ","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.tvfanatic.com/shows/all-american-homecoming/full-episodes/season-1/start-over/","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform","http://schema.org/IOSPlatform","http://schema.org/AndroidPlatform","http://schema.googleapis.com/GoogleVideoCast"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"2022-02-21T00:00","availabilityEnds":"2023-02-21T00:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--BYrTsIQO--/c_thumb,f_auto,g_auto,h_2000,q_auto,w_1333/v1645293325/college-life-all-american-homecoming","height":2000,"width":1333}}</script>
<h4>
<div class='clearfix'>
<time datetime="2022-02-21" class="air">2/21/22</time>
<div class='number'><a href="/shows/all-american-homecoming/episodes/season-1/start-over/">All American: Homecoming Season 1 Episode 1</a></div>
</div>
<div class='title'>Start Over</div>
</h4>
<img alt="College life - All American: Homecoming" src="https://tv-fanatic-res.cloudinary.com/iu/s--MgvIYwmx--/t_large_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1645293325/college-life-all-american-homecoming.jpg" />
<ul class='nav nav-pills'>
<li><a href="/2022/02/all-american-homecoming-season-1-episode-1-review-start-over/">Review</a></li>
<li><a href="/quotes/shows/all-american-homecoming/episodes/start-over/">Quotes</a></li>
<li><a href="/gallery/shows/all-american-homecoming/episodes/start-over/">Photos</a></li>
</ul>
</div>

</div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/all-american-homecoming/">All American: Homecoming</a></li> <li><a href="/shows/all-american-homecoming/episodes/season-1/">All American: Homecoming Season 1</a></li> <li><a href="/shows/all-american-homecoming/episodes/season-1/start-over/">All American: Homecoming Season 1 Episode 1</a></li> <li>All American: Homecoming Series Premiere Review: Start Over</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/1883/">1883</a></li>
<li><a href="/shows/resident-alien/">Resident Alien</a></li>
<li><a href="/shows/power-book-ii-ghost/">Power Book II: Ghost</a></li>
<li><a href="/shows/euphoria/">Euphoria</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/9-1-1-lonestar/">9-1-1: Lone Star</a></li>
<li><a href="/shows/all-american/">All American</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/dickinson/">Dickinson</a></li>
<li><a href="/shows/the-resident/">The Resident</a></li>
<li><a href="/shows/seal-team/">SEAL Team</a></li>
<li><a href="/shows/power/">Power</a></li>
<li><a href="/shows/only-murders-in-the-building/">Only Murders In the Building</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2022/02/">February 2022</a></li>
<li><a href="/2022/01/">January 2022</a></li>
<li><a href="/2021/">2021 Archives</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2022 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2022 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
