<!DOCTYPE html>
<html id='en' lang='en' xmlns:fb='http://ogp.me/ns/fb#'>
<head>
<style>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</style>
<style>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</style>
<meta charset='utf-8'>
<meta content='IE=edge' http-equiv='X-UA-Compatible'>
<meta content='width=device-width, initial-scale=1.0' name='viewport'>
<meta content='block-all-mixed-content' http-equiv='Content-Security-Policy'>
<meta content='DPR, Viewport-Width, Width' http-equiv='Accept-CH'>
<script type="text/javascript">
!function(n,t){"undefined"!=typeof module&&module.exports?module.exports=t():"function"==typeof define&&define.amd?define(t):this[n]=t()}("$script",function(){function n(n,t){for(var e=0,o=n.length;o>e;++e)if(!t(n[e]))return c;return 1}function t(t,e){n(t,function(n){return!e(n)})}function e(r,u,f){function c(n){return n.call?n():s[n]}function l(){if(!--y){s[v]=1,g&&g();for(var e in m)n(e.split("|"),c)&&!t(m[e],c)&&(m[e]=[])}}r=r[a]?r:[r];var d=u&&u.call,g=d?u:f,v=d?r.join(""):u,y=r.length;return setTimeout(function(){t(r,function n(t,e){return null===t?l():(t=e||-1!==t.indexOf(".js")||/^https?:\/\//.test(t)||!i?t:i+t+".js",p[t]?(v&&(h[v]=1),2==p[t]?l():setTimeout(function(){n(t,!0)},0)):(p[t]=1,v&&(h[v]=1),o(t,l),void 0))})},0),e}function o(n,t){var e,o=u.createElement("script");o.onload=o.onerror=o[d]=function(){o[l]&&!/^c|loade/.test(o[l])||e||(o.onload=o[d]=null,e=1,p[n]=2,t())},o.async=1,o.src=r?n+(-1===n.indexOf("?")?"?":"&")+r:n,f.insertBefore(o,f.lastChild)}var i,r,u=document,f=u.getElementsByTagName("head")[0],c=!1,a="push",l="readyState",d="onreadystatechange",s={},h={},m={},p={};return e.get=o,e.order=function(n,t,o){!function i(r){r=n.shift(),n.length?e(r,i):e(r,t,o)}()},e.path=function(n){i=n},e.urlArgs=function(n){r=n},e.ready=function(o,i,r){o=o[a]?o:[o];var u=[];return!t(o,function(n){s[n]||u[a](n)})&&n(o,function(n){return s[n]})?i():!function(n){m[n]=m[n]||[],m[n][a](i),r&&r(u)}(o.join("|")),e},e.done=function(n){e([null],n)},e});
</script>

<script type="text/javascript">
var windowWidth = Math.min(window.innerWidth || Infinity, screen.width);
var is_mobile = navigator.userAgent.match(/Mobile|iP(hone|od|ad)|Android|BlackBerry|IEMobile|Kindle|NetFront|Silk-Accelerated|(hpw|web)OS|Fennec|Minimo|Opera M(obi|ini)|Blazer|Dolfin|Dolphin|Skyfire|Zune/ig) ? true : false;
</script>

<script async src='//scripts.mediavine.com/tags/tv-fanatic.js'></script>

<script>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</script>

<script>
!function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
(function() {
  var event = document.createEvent('Event');
  event.initEvent('first_scroll', true, true);

  // First scroll
  var triggered = false;
  var event_listener = function(e) {
    window.removeEventListener('scroll', event_listener);
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  };
  window.addEventListener('scroll', event_listener);

  // Or first input
  perfMetrics.onFirstInputDelay(function(delay, evt) {
    if (!triggered) {
      triggered = true;
      window.dispatchEvent(event);
    }
  });
})();
</script>

<title>iCarly Scores Season 3 Renewal at Paramount+ - TV Fanatic</title>
<link rel="shortcut icon" type="image/x-icon" href="https://www.tvfanatic.com/assets/favicon-bc4bd0a7cc11420f92354513715993c9.ico" />
<link rel="canonical" href="https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/" />

<link rel="alternate" type="application/atom+xml" title="TV Fanatic Feed" href="https://www.tvfanatic.com/rss.xml" />
<meta content='119370714775514' property='fb:app_id'>
<meta content='TV Fanatic' property='og:site_name'>
<meta content='2220147' property='fb:admins'>
<meta content='article' property='og:type'>
<meta content='https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/' property='og:url'>
<meta content='iCarly Scores Season 3 Renewal at Paramount+' property='og:title'>
<meta content='iCarly has landed a Season 3 pickup at Paramount+, and we have all the details you need on the big announcement. Read on to get up to speed. ' property='og:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--op8lqxVC--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658942035/icarly-season-2-cast-members.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='354' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--0ck_jgwb--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658941837/icarly-season-3-still.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='509' property='og:image:width'>
<meta content='636' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--TGs37wO7--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650355059/laci-mosley-as-harper-icarly.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='792' property='og:image:height'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--tAjOeaIo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650354916/harper-and-carly-in-mall-jail-icarly.jpg' property='og:image'>
<meta content='image/jpeg' property='og:image:type'>
<meta content='630' property='og:image:width'>
<meta content='796' property='og:image:height'>
<meta content='2022-07-27T13:45:00-04:00' property='article:published_time'>
<meta content='2022-07-27T13:16:15-04:00' property='article:modified_time'>
<meta content='iCarly' property='article:tag'>
<meta content='TV News' property='article:tag'>
<meta content='renew/cancel' property='article:tag'>
<meta content='Paul Dailly' property='article:author'>

<meta content='tvfanatic' name='twitter:site'>
<meta content='summary_large_image' name='twitter:card'>
<meta content='iCarly Scores Season 3 Renewal at Paramount+' name='twitter:title'>
<meta content='iCarly has landed a Season 3 pickup at Paramount+, and we have all the details you need on the big announcement. Read on to get up to speed. ' name='twitter:description'>
<meta content='https://tv-fanatic-res.cloudinary.com/iu/s--op8lqxVC--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658942035/icarly-season-2-cast-members.jpg' name='twitter:image:src'>

<meta name="description" content="iCarly has landed a Season 3 pickup at Paramount+, and we have all the details you need on the big announcement. Read on to get up to..."></meta>
<script type="text/javascript">
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};
ga.l=+new Date;
$script.ready("application",function() {
  $script('//www.google-analytics.com/analytics.js');
});
ga('create', 'UA-2410076-31', 'auto');
ga('set', 'dimension1', 'iCarly');
ga('set', 'dimension2', 'Paul Dailly');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>

<script>
  $script('https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js', 'jquery');
  $script.ready('jquery', function() {
    $script('https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/js/bootstrap.min.js','bootstrap');
  });
  $script.ready('bootstrap', function() {
    $script('https://www.tvfanatic.com/assets/application-70a0debb67af7d8b196425b44f11409c.js','application');
  });
</script>
<link rel="stylesheet" href="https://www.tvfanatic.com/assets/application-6e13e66e078d96e77dca7eed6ed01a5b.css" as="style" />
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" as="style" />
<script>
  window.addEventListener('first_scroll', function (e) {
    var scripts = document.querySelectorAll("[rel=load_on_scroll]");
    Array.prototype.forEach.call(scripts, function(script, i){
      script.setAttribute('rel','stylesheet');
    });
  }, false);
</script>

<link rel="manifest" href="/manifest.json">
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(["init", {
    appId: "01bed192-d659-4d06-85d5-29c8b63aec4b",
    safari_web_id: "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc",
    welcomeNotification: {
      disable: true
    }
  }]);
  OneSignal.push(["sendTag", "icarly", "true"]);

  OneSignal.push(function() {
    OneSignal.on('notificationPermissionChange', function(permissionChange) {
      try { window.ga('send', 'event', 'OneSignal', permissionChange.to); } catch(e) {}
    });
  });

  OneSignal.push(function() {
    OneSignal.on('permissionPromptDisplay', function() {
      try { window.ga('send', 'event', 'OneSignal', 'prompt'); } catch(e) {}
    });
  });

  window.addEventListener('first_scroll', function (e) {
    $script("https://cdn.onesignal.com/sdks/OneSignalSDK.js");
  });
</script>


<!--[if lt IE 9]>
<script src="//oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="//oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script>
<link href='//assets.tvfanatic.com/respond-proxy.html' id='respond-proxy' rel='respond-proxy'>
<link href='/respondjs/respond.proxy.gif' id='respond-redirect' rel='respond-redirect'>
<script src='/respondjs/respond.proxy.js'></script>
<![endif]-->

<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-144-6350a815795de6c86811159420a19872.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-114-cfe429854446d63ad5898fd11705f962.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-72-98f1799cf02fc7651205bbb49b4d0736.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://www.tvfanatic.com/assets/icons/apple-touch-icon-57-f10b996e11f8722d1198f6f3fa1632da.png' rel='apple-touch-icon'>
<meta content='26398660' property='twitter:account_id'>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","@id":"https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/","mainEntityOfPage":"https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/","headline":"iCarly Scores Season 3 Renewal at Paramount+","datePublished":"2022-07-27T13:45:00-04:00","dateModified":"2022-07-27T13:16:15-04:00","description":"iCarly has landed a Season 3 pickup at Paramount+, and we have all the details you need on the big announcement. Read on to get up to speed. ","publisher":{"@type":"Organization","name":"TV Fanatic","logo":{"@type":"ImageObject","url":"https://www.tvfanatic.com/assets/amp-logo-04d1c623824f494a04bae142369db2b3.png","width":337,"height":60}},"image":{"@type":"ImageObject","url":"https://tv-fanatic-res.cloudinary.com/iu/s--Qkz7wtwY--/f_auto,q_auto/v1658942035/icarly-season-2-cast-members","height":1080,"width":1920},"author":{"@type":"Person","url":"https://www.tvfanatic.com/authors/pauldailly92/","name":"Paul Dailly"}}</script>


<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "Organization",
   "url": "https://www.tvfanatic.com",
   "name": "The Hollywood Gossip",
   "logo": "https://www.tvfanatic.com/square-logo.png",
   "sameAs": [
     "https://www.facebook.com/tvfanatic",
     "https://twitter.com/tvfanatic",
     "https://www.pinterest.com/tvfanatic/",
     "https://plus.google.com/+tvfanatic"
   ]
}
</script>

</head>
<body itemscope itemtype='http://schema.org/WebPage'>
<nav class='navbar navbar-default navbar-static-top' id='navbar' itemscope itemtype='schema.org/WPHeader' role='navigation'>
<div class='navbar-header'>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-search"></i>
</button>
<div class='dropdown-menu search-dropdown dropdown-menu-right'>
<form action='/search' role='search'>
<div class='input-group'>
<input type="search" name="q" id="q" placeholder="Search" class="form-control" />
<div class='input-group-btn'><button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button></div>
</div>
</form>
</div>
</div>
<div class='dropdown navbar-button'>
<button class='btn btn-link' data-toggle='dropdown'>
<i class="fa fa-user"></i>
</button>
<ul class='dropdown-menu user-dropdown dropdown-menu-right' data-disable-registrations='true'></ul>
</div>
<button class='btn btn-link' data-target='.navbar-collapse' data-toggle='collapse' type='button'>
<span class='sr-only'>Toggle navigation</span>
<i class="fa fa-bars"></i>
</button>
<div class='navbar-center'>
<a href="/"><img alt="TV Fanatic" src="https://www.tvfanatic.com/assets/logo-wide-f7e6b79ef438ae7299364d2900546da4.png" /></a>
</div>
</div>
<div class='navbar-collapse collapse'>
<ul class='nav navbar-nav'>
<li><a href="/tags/spoilers/">Spoilers</a></li>
<li><a href="/tags/exclusives/">Exclusives</a></li>
<li><a href="/tags/tv-fanatic-report-cards/">Report Cards</a></li>
<li><a href="/full-episodes/">Watch TV Online</a></li>
<li><a href="/tags/photo-galleries/">Photo Galleries</a></li>
</ul>
</div>
</nav>

<div class='container-fluid' id='wrapper'>
<div id='leaderboard_atf_target'></div>
<div class='row'>
<div class='col-lg-8' id='content'>
<div class='ggnoads' data-id='3024' id='show_banner'>
<div class="image_outter_wrapper" style="max-width:851px;"><div class="image_wrapper" style="padding-bottom:37.01527614571093%;"><img alt="iCarly" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--PAybot66--/c_fill,h_315,w_851/f_auto,fl_lossy,q_75/v1623797997/banner/icarly.jpg" class="lazyload" /></div></div>
<div class='title'>
<h1><a href="/shows/icarly/">iCarly</a></h1>
<span class='airs'>
Thursdays
on
Paramount+
</span>
</div>
<div class='menu'>
<div class='follow'>
<button class='btn btn-default' data-target='#show_follow_modal' data-toggle='modal'>Follow</button>
</div>
<div class='btn-group desktop-buttons'>
<div class='btn-group'>
<button class='btn btn-default dropdown-toggle' data-toggle='dropdown' type='button'>
<i class="fa fa-bars"></i>
</button>
<ul class='dropdown-menu' role='menu'>
<li><a class="visible-sm" data-title="News" href="/shows/icarly/">iCarly News</a></li>
<li><a class="visible-sm" data-title="Reviews" href="/shows/icarly/tags/reviews/">iCarly Reviews</a></li>
<li><a class="" data-title="Episode Guide" href="/shows/icarly/episodes/">iCarly Episode Guide</a></li>
<li><a class="" data-title="Quotes" href="/quotes/shows/icarly/">iCarly Quotes</a></li>
<li><a class="" data-title="Pictures" href="/gallery/shows/icarly/">iCarly Pictures</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='modal fade' id='show_follow_modal'>
<div class='modal-dialog'>
<div class='modal-content'>
<div class='modal-header'>
<button class='close' data-dismiss='modal' type='button'>&times;</button>
<h3 class='modal-title center'>Follow iCarly</h3>
</div>
<div class='modal-body'>
<form class='newsletter_signup' id='show_follow'>
<div class='alert alert-error error' style='display:none;margin:10px;'></div>
<div class='input-group input-group-lg'>
<input class='email form-control input-lg' placeholder='Enter Your Email Address' type='email'>
<span class='input-group-btn'>
<input class='btn btn-primary btn-lg' name='subscribe' type='submit' value='Follow'>
</span>
</div>
</form>
</div>
</div>
</div>
</div>


<div id='flash'></div>
<div class='autoload'>
<article>
<header class='header'><h1 itemprop='name'>iCarly Scores Season 3 Renewal at Paramount+</h1>
<small>
<a rel="author" href="/authors/pauldailly92/"><img class="img-circle avatar" src="https://tv-fanatic-res.cloudinary.com/iu/s--jzYlH3ci--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1437338558/user/pauldailly92.jpg" alt="Pauldailly92" />
<a rel="author" href="/authors/pauldailly92/">Paul Dailly</a>
</a>at
<time datetime="2022-07-27T13:45:00-04:00" itemprop="datePublished">July 27, 2022  1:45 pm</time>.
</small>
</header>
<div class='body'>
<p>
	The iCarly revival will remain alive for another season at Paramount+.</p>
<p>
	The streaming service officially picked the Miranda Cosgrove series up for a third season today.</p>
<p>
	The 10-episode second season completed its run earlier this spring and left its fans with a major #Creddie cliffhanger.</p>
<div style="max-width:520px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/icarly-season-2-cast-members/"><div class="image_wrapper" style="padding-bottom:56.15384615384615%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--op8lqxVC--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658942035/icarly-season-2-cast-members.jpg" data-pin-description="iCarly Scores Season 3 Renewal at Paramount+" data-pin-url="https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--nVqK_C0V--/t_xlarge_l/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658942035/icarly-season-2-cast-members.jpg" class="lazyload" alt="iCarly Season 2 Cast Members"></div></a>
</div>
<p>
	The third season will go into production later this year and will premiere in 2023 exclusively on Paramount+ around the world.</p><div id="stp_target"></div>
<p>
	“iCARLY’s loyal fan base grew up with Carly, Spencer and Freddie, and have now fallen in love with Harper and Millicent, too,” said Tanya Giles, chief programming officer of streaming for Paramount+.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/icarly-season-3-still/"><div class="image_wrapper" style="padding-bottom:124.75%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--0ck_jgwb--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658941837/icarly-season-3-still.jpg" data-pin-description="iCarly Scores Season 3 Renewal at Paramount+" data-pin-url="https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--V5arnuZA--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658941837/icarly-season-3-still.jpg" class="lazyload" alt="iCarly Season 3 Still"></div></a>
</div>
<p>
	“We’re thrilled to have Miranda, Jerry, Nathan, Laci and Jaidyn return for a third season and we know Paramount+’s growing YA audience is as well."</p>
<p>
	"And I, for one, must find out what happens with #Creddie!”</p>
<p>
	The first two seasons are available to stream exclusively on Paramount+, and in addition to catching up on new iCARLY episodes, fans can also binge all seasons of the original on the streaming platform.</p>
<p>
	iCARLY stars Miranda Cosgrove as Carly, Jerry Trainor as Spencer, Nathan Kress as Freddie, Laci Mosley as Harper, and Jaidyn Triplett as Millicent.</p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/laci-mosley-as-harper-icarly/"><div class="image_wrapper" style="padding-bottom:125.49999999999999%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--TGs37wO7--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650355059/laci-mosley-as-harper-icarly.jpg" data-pin-description="iCarly Scores Season 3 Renewal at Paramount+" data-pin-url="https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--GVfPSfyD--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650355059/laci-mosley-as-harper-icarly.jpg" class="lazyload" alt="Laci Mosley as Harper - iCarly"></div></a>
</div>
<p>
	The series is produced for Paramount+ is produced by Nickelodeon Studios and is executive produced by Ali Schouten-Seeks (Young &amp; Hungry, Diary of a Future President) and Miranda Cosgrove, with Schouten serving as showrunner.</p>
<p>
	Jerry Trainor, Nathan Kress, and Alissa Vradenburg (The Simple Life) serve as producers.</p>
<p>
	The original series, which ran from 2007-2012, followed a group of best friends as they created a webcast for and about kids their age while grappling with everyday problems and adventures.</p>
<p>
	The series has been a huge hit for Paramount+, so renewal was always a sure thing. </p>
<div style="max-width:400px;margin:0 auto 10px;text-align:center;" class="thumbnail">
	<a href="/gallery/harper-and-carly-in-mall-jail-icarly/"><div class="image_wrapper" style="padding-bottom:126.25%;"><img data-pin-media="https://tv-fanatic-res.cloudinary.com/iu/s--tAjOeaIo--/t_full/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650354916/harper-and-carly-in-mall-jail-icarly.jpg" data-pin-description="iCarly Scores Season 3 Renewal at Paramount+" data-pin-url="https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--7r8vIhgC--/t_xlarge_p/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650354916/harper-and-carly-in-mall-jail-icarly.jpg" class="lazyload" alt="Harper and Carly in Mall Jail - iCarly"></div></a>
</div>
<p>
	It has a global following, which helps when the streaming service is currently hard at work going international.</p>
<p>
	What are your thoughts on the news?</p>
<p>
	Hit the comments below.</p>



<div class="buttons admin edit_object_links" data-user-id="66541"><button class="btn btn-primary" data-href="/admin/post/100447/edit"><i class="fa fa-pencil"></i> Edit</button> <button class="btn btn-danger" data-href="/admin/post/100447/delete"><i class="fa fa-trash-o"></i> Delete</button> </div>
<p><p style="font-style:italic;"><b>Paul Dailly</b> is the Associate Editor for TV Fanatic. Follow him on <a href="http://twitter.com/pauldailly1992">Twitter</a>.</p>
</div>
<div class='hidden-print'>
<div class='row footer_sharing margin-top'>
<div class='col-xs-6'>
<button class='btn btn-block btn-facebook margin-bottom' data-height='600' data-href='https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/' data-share='facebook' data-width='500'>
<i class="fa fa-facebook"></i>
Share
<span class='hidden-xs'>on Facebook</span>
</button>
</div>
<div class='col-xs-6'>
<button class='btn btn-block btn-default margin-bottom' data-href='https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/' data-id='100447' data-share='email' data-type='Post'>
<i class="fa fa-envelope"></i>
Email
</button>
</div>
</div>
</div>

</article>
<div class='btn btn-primary btn-block margin-bottom' id='show-comments'>
Show Comments
</div>
<div class='margin-top' id='comments-tabs' style='display:none;'>
<ul class='nav nav-tabs'>
<li class='active' role='presentation'>
<a role="tab" data-toggle="tab" id="facebook_comments_tab" href="#facebook_comments">Facebook</a>
</li>
<li role='presentation'>
<a role="tab" data-toggle="tab" id="disqus_comments_tab" href="#disqus_comments">Disqus</a>
</li>
</ul>
<div class='tab-content'>
<div class='tab-pane active' id='facebook_comments' role='tabpanel'>
<div class='fb-comments' data-href='https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/' data-version='v2.3' data-width='100%'></div>
</div>
<div class='tab-pane' id='disqus_comments' role='tabpanel'>
<div data-disqus-identifier='post-100447' data-disqus-url='https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/' id='disqus_thread'>

</div>
<script>
  var get_disqus_sso = function() {
    if(document.cookie.indexOf('user_id') != -1) {
      jQuery.getScript('/disqus/sso.js')
    };
  };
  
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = "tvfanatic"; // Required - Replace example with your forum shortname
  var disqus_identifier = "post-100447";
  var disqus_url = "https://www.tvfanatic.com/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/";
  var disqus_title = "iCarly Scores Season 3 Renewal at Paramount+";
  var disqus_config = function () {
    this.sso = {
      name:    "TV Fanatic",
      button:  "//www.tvfanatic.com/assets/disqus_button.png",
      icon:    "//www.tvfanatic.com/assets/favicon.ico",
      url:     "//www.tvfanatic.com/users/sign_in?close=true&css_layout=true",
      logout:  "//www.tvfanatic.com/users/sign_out",
      width:   "800",
      height:  "400"
    };
  
    this.callbacks.onNewComment = [function() {
      try {
        _gaq.push(["_trackEvent", 'Comment', 'New', "iCarly Scores Season 3 Renewal at Paramount+"]);
      } catch (_error) {}
    }];
  
    // Let apps hop in with callback(s)
    if (typeof(app.disqusOnNewComment) == 'function') {
      this.callbacks.onNewComment.push(app.disqusOnNewComment);
    }
  
    if (typeof(app.disqusOnPaginate) == 'function') {
      this.callbacks.onPaginate = [app.disqusOnPaginate];
    }
  
    if (typeof(app.disqusAfterRender) == 'function') {
      this.callbacks.afterRender = [app.disqusAfterRender];
    }
  };
</script>

</div>
</div>
</div>



</div>
<div id="next_post_link" data-link="/2022/04/laci-mosley-talks-comedic-inspirations-icarly-season-2-and-more/"></div>
<small class='hidden-print'>
Tags:
<a rel="tag" href="/shows/icarly/">iCarly</a>, <a rel="tag" href="/tags/tv-news/">TV News</a>, <a rel="tag" href="/tags/renew-slash-cancel/">renew/cancel</a>
</small>


<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/quotes/shows/icarly/">iCarly Quotes</a></h4>
<blockquote>
<p> By the way, you were so right! My type is totally hot and dumb. What a revelation! Do I need therapy? No, I'm good.</p>
<small>Carly</small>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/by-the-way-you-were-so-right-my-type-is-totally-hot-and-dumb-wha/">By the way, you were so right! My type is totally hot and dumb. What a revelation! Do I need...</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-06-24">June 24, 2021</time></li>
</ul>
</blockquote>
<blockquote>
<p>Carly: Are you thinking what I'm thinking?<br>Harper and Carly: Outfit Montage!<br>Carly: It's hurting my retinas. I feel like the lining of a really expensive casket. Too frilly. Too silly. Too racey. Too spacey. Too flirty. Too birdy!</p>
<ul class='details hidden-print'>
<li><i class="fa fa-link"></i> Permalink: <a href="/quotes/its-hurting-my-retinas-i-feel-like-the-lining-of-a-really-expens/">It&#39;s hurting my retinas. I feel like the lining of a really expensive casket. Too frilly. Too...</a></li>
<li><i class="fa fa-calendar"></i> Added: <time datetime="2021-06-24">June 24, 2021</time></li>
</ul>
</blockquote>


</div>
</div>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/shows/icarly/">iCarly</a></h4>
<ul class='nav'>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/07/icarly-scores-season-3-renewal-at-paramount-plus/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="iCarly Scores Season 3 Renewal at Paramount+" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--CbPJ5N8v--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1658942035/icarly-season-2-cast-members" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--nPoLDMc4--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1658942035/icarly-season-2-cast-members 31w, https://tv-fanatic-res.cloudinary.com/iu/s--BMi87YXi--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1658942035/icarly-season-2-cast-members 62w, https://tv-fanatic-res.cloudinary.com/iu/s--SQJRT4vB--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1658942035/icarly-season-2-cast-members 93w, https://tv-fanatic-res.cloudinary.com/iu/s--CbPJ5N8v--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1658942035/icarly-season-2-cast-members 125w, https://tv-fanatic-res.cloudinary.com/iu/s--GqRRGwTB--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1658942035/icarly-season-2-cast-members 187w, https://tv-fanatic-res.cloudinary.com/iu/s--KVtmZ31A--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1658942035/icarly-season-2-cast-members 250w, https://tv-fanatic-res.cloudinary.com/iu/s--WgNJ1hig--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1658942035/icarly-season-2-cast-members 312w, https://tv-fanatic-res.cloudinary.com/iu/s--jrxGUGgk--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1658942035/icarly-season-2-cast-members 375w" class="lazyload" /></div></div>
</div>
iCarly Scores Season 3 Renewal at Paramount+
</a></li>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/04/laci-mosley-talks-comedic-inspirations-icarly-season-2-and-more/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="Laci Mosley Talks Comedic Inspirations, iCarly Season 2, and More!" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--By3X0D46--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1650355014/laci-mosley-with-dog-icarly" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--sgvpHG7P--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1650355014/laci-mosley-with-dog-icarly 31w, https://tv-fanatic-res.cloudinary.com/iu/s--3Cj6yHO1--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1650355014/laci-mosley-with-dog-icarly 62w, https://tv-fanatic-res.cloudinary.com/iu/s--uehYNM_v--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1650355014/laci-mosley-with-dog-icarly 93w, https://tv-fanatic-res.cloudinary.com/iu/s--By3X0D46--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1650355014/laci-mosley-with-dog-icarly 125w, https://tv-fanatic-res.cloudinary.com/iu/s--SmOOMO0x--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1650355014/laci-mosley-with-dog-icarly 187w, https://tv-fanatic-res.cloudinary.com/iu/s--lCimrTZZ--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1650355014/laci-mosley-with-dog-icarly 250w, https://tv-fanatic-res.cloudinary.com/iu/s--ep-nW4Ws--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1650355014/laci-mosley-with-dog-icarly 312w, https://tv-fanatic-res.cloudinary.com/iu/s---s_3Ns61--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1650355014/laci-mosley-with-dog-icarly 375w" class="lazyload" /></div></div>
</div>
Laci Mosley Talks Comedic Inspirations, iCarly Season 2, and More!
</a></li>
<li>
<a class="clearfix" style="font-weight:bold;" href="/2022/03/icarly-season-2-gets-premiere-date-and-trailer-at-paramount-plus/"><div style='margin:0 10px 0 0;float:left;width:125px;'>
<div class="image_outter_wrapper" style="max-width:125px;"><div class="image_wrapper" style="padding-bottom:72.0%;"><img alt="iCarly Season 2 Gets Premiere Date and Trailer at Paramount+" data-sizes="auto" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--ry1OSPic--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1646237109/attachment/icarly-cropped-s2" data-srcset="https://tv-fanatic-res.cloudinary.com/iu/s--0ksdsBcm--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_22,q_auto:420,w_31/v1646237109/attachment/icarly-cropped-s2 31w, https://tv-fanatic-res.cloudinary.com/iu/s--uMelL40R--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_44,q_auto:420,w_62/v1646237109/attachment/icarly-cropped-s2 62w, https://tv-fanatic-res.cloudinary.com/iu/s--1M2z7sTO--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_66,q_auto:420,w_93/v1646237109/attachment/icarly-cropped-s2 93w, https://tv-fanatic-res.cloudinary.com/iu/s--ry1OSPic--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_90,q_auto:420,w_125/v1646237109/attachment/icarly-cropped-s2 125w, https://tv-fanatic-res.cloudinary.com/iu/s--C-DaePug--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_134,q_auto:420,w_187/v1646237109/attachment/icarly-cropped-s2 187w, https://tv-fanatic-res.cloudinary.com/iu/s--Qa2p5R1i--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_180,q_auto:420,w_250/v1646237109/attachment/icarly-cropped-s2 250w, https://tv-fanatic-res.cloudinary.com/iu/s--nJk02Xq9--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_224,q_auto:420,w_312/v1646237109/attachment/icarly-cropped-s2 312w, https://tv-fanatic-res.cloudinary.com/iu/s--9KTrJoia--/c_fill,cs_srgb,f_auto,fl_strip_profile.lossy,g_auto,h_270,q_auto:420,w_375/v1646237109/attachment/icarly-cropped-s2 375w" class="lazyload" /></div></div>
</div>
iCarly Season 2 Gets Premiere Date and Trailer at Paramount+
</a></li>
</ul>

</div>
</div>
</div>
<div class='row hidden-print'>
<div class='col-sm-6'><div class='flat_widget'>
<h4><a href="/gallery/shows/icarly/">iCarly Photos</a></h4>
<div class='row'>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/icarly-season-3-still/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="iCarly Season 3 Still" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--PHdUZg4E--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658941837/icarly-season-3-still.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/icarly-season-2-cast-members/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="iCarly Season 2 Cast Members" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--H_vJo5Xn--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1658942035/icarly-season-2-cast-members.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/laci-mosley-as-harper-icarly/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Laci Mosley as Harper - iCarly" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--oXwyGqAb--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650355059/laci-mosley-as-harper-icarly.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/laci-mosley-with-dog-icarly/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Laci Mosley with Dog - iCarly" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--p_wD46km--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650355014/laci-mosley-with-dog-icarly.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/harper-and-carly-sitting-in-mall-jail-icarly/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Harper and Carly Sitting in Mall Jail - iCarly" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--eCPeiTWK--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650354941/harper-and-carly-sitting-in-mall-jail-icarly.jpg" class="lazyload" /></div></div>
</a></div>
<div class='col-xs-4'>
<a class="thumbnail" href="/gallery/harper-and-carly-in-mall-jail-icarly/"><div class="image_outter_wrapper" style="max-width:90px;"><div class="image_wrapper" style="padding-bottom:100.0%;"><img alt="Harper and Carly in Mall Jail - iCarly" data-src="https://tv-fanatic-res.cloudinary.com/iu/s--hJGfIWzA--/t_thumb/cs_srgb,f_auto,fl_strip_profile.lossy,q_auto:420/v1650354916/harper-and-carly-in-mall-jail-icarly.jpg" class="lazyload" /></div></div>
</a></div>
</div>

</div>
</div>
</div>

</div>
<div class='col-lg-4 visible-lg' id='sidebar'>
<div id='sidebar_atf_target'></div>

<div id='sidebar_recommendations'></div>
<div id='sidebar_btf_target'></div>

</div>
</div>
<div class='row hidden-print'>
<ol class="breadcrumb"><li><a href="/shows/icarly/">iCarly</a></li> <li>iCarly Scores Season 3 Renewal at Paramount+</li></ol>
</div>
<div class='row'>
<div id='footer' itemscope itemtype='schema.org/WPFooter'>
<span class='hidden-print'>
<p>Top Shows</p>
<ul class='nav nav-pills'>
<li><a href="/shows/motherland-fort-salem/">Motherland: Fort Salem</a></li>
<li><a href="/shows/p-valley/">P-Valley</a></li>
<li><a href="/shows/only-murders-in-the-building/">Only Murders In the Building</a></li>
<li><a href="/shows/virgin-river/">Virgin River</a></li>
<li><a href="/shows/stranger-things/">Stranger Things</a></li>
<li><a href="/shows/star-trek-strange-new-worlds/">Star Trek: Strange New Worlds</a></li>
<li><a href="/shows/severance/">Severance</a></li>
<li><a href="/shows/greys-anatomy/">Grey&#39;s Anatomy</a></li>
<li><a href="/shows/hart-of-dixie/">Hart of Dixie</a></li>
<li><a href="/shows/days-of-our-lives/">Days of Our Lives</a></li>
<li><a href="/shows/1883/">1883</a></li>
<li><a href="/shows/killing-eve/">Killing Eve</a></li>
<li><a href="/shows/arrested-development/">Arrested Development</a></li>
<li><a href="/shows/legacies/">Legacies</a></li>
<li><a href="/shows/the-boys/">The Boys</a></li>
</ul>

<p>Archives</p>
<ul class='hidden-print nav nav-pills'>
<li><a href="/2022/07/">July 2022</a></li>
<li><a href="/2022/06/">June 2022</a></li>
<li><a href="/2022/05/">May 2022</a></li>
<li><a href="/2022/04/">April 2022</a></li>
<li><a href="/2022/03/">March 2022</a></li>
<li><a href="/2022/02/">February 2022</a></li>
<li><a href="/2022/01/">January 2022</a></li>
<li><a href="/2021/">2021 Archives</a></li>
<li><a href="/2020/">2020 Archives</a></li>
<li><a href="/2019/">2019 Archives</a></li>
<li><a href="/2018/">2018 Archives</a></li>
<li><a href="/2017/">2017 Archives</a></li>
<li><a href="/2016/">2016 Archives</a></li>
<li><a href="/2015/">2015 Archives</a></li>
<li><a href="/2014/">2014 Archives</a></li>
<li><a href="/2013/">2013 Archives</a></li>
<li><a href="/2012/">2012 Archives</a></li>
</ul>

</span>
<p class='hidden-print'>
&copy; 2022 TV Fanatic
|
<a href="/about-us/">About Us | Copyright Inquiry | Privacy Policy | Contact Us</a>
</p>
<hr class='visible-print-block print_footer_rule'>
<p class='visible-print-block'>
&copy; 2022 TV Fanatic
</p>
</div>

</div>
</div>

</body>
</html>
